MyBookWorld (white light) suddenly no longer accessible after resuming from standby


My MyBookWorld (white light) has been very reliable for several years, until now. In the last week or so I have been having all sorts of trouble reconnecting to it after it has gone into standby. The server\share names are as if they never existed, until I reboot the NAS. Then they are fine again.

Pinging it does wake it up, but it remains inaccessible to any file managers.

I am using Windows 8.1 (64-bit) on my desktop and Surface Pro tablet, along with Linux Mint (32- and 64-bit) on two different laptops and they are all affected, so I know it is not specific to a particular OS.

Here is what I do know:

I recently changed the IP address of the unit. I have tried giving it a static IP address, and having the router assign it an IP address. Both methods fail once the unit has gone into standby. I don’t think this is the problem.

I recently updated the SSL certificate. I didn’t notice any change in behaviour after doing so so I don’t think that is the issue either.

For the last couple of months the log file has been full of “NIC 1 link is down” errors along with “afp_alarm” and “Disconnected session” errors, although I don’t recall having the problem that far back. I’m not super network savvy and don’t really know what they mean. I can attach the log file if that will help – there are lots of entries both before and after the problem occurred so I’m sure someone knowledgeable will know what they mean.

Please help. Whilst I do have other copies of my data this unit is a central part of my backup strategy. Having to constantly reboot it is a royal pain in the rear, especially given it has only just started happening.


Have you tried resetting the device?

Make sure that you don’t have a firewall on the router affecting the connection

Hi Help4All,

Sorry for the delay in responding. I’ve been monitoring its behaviour and wanted to get a better picture before posting on the forum.

I had rebooted the MBW a couple of times, but that did not resolve the problem. Or did you mean a factory reset? Not sure I’m ready for something so drastic right now. And, given that I’ve been using the same router for years with no issues, I don’t think a firewall is the issue. But, read on…

I had read in another forum that the problem might be related to a faulty router or switch. My MBW is connected to my network via a switch, so I’ve reset that a few times to see what happens. It instantly resolves the connectivity issue, and I am a lot happier to reset that at any given time than the MBW.

Everything has been running smoothly for the last few days, without needing further switch resets. So for now I will put it down to a temporary glitch. If the problem reappears I will try swapping around the connections in the switch to see if it is related to a particular port; if so then I will replace it. Definitely cheaper than a new NAS…

I have the same problem with my device (the same type of device). It started happening several weeks ago, and initially I didn’t pay too much attention for it, because I thought it was my router problem. The router sometimes hangs and needs reset, so I thought it was the cause.

Later I discovered MBW becomes inaccessible even when the router works fine and provides internet connection without any issues. Besides the router I have a switch in my home network, so I moved the MBW to another location and connected via switch. The switch is very reliable - although this is cheap D-Link, my TV that’s connected via this switch has never lost network connection, I have never had to reset this switch (for last 2 years).

Reconnecting MBW to this switch didn’t help either. When I use the device, I mean read and save files from it or access it from web browser, everything is fine. When I leave it unused for a night, in the morning it is disconnected. I have to use back-panel switch to turn it off and then restart. I tried to turn off HDD sleep mode - didn’t help either.

I decided to reset it to factory defaults, it didn’t help.

I tried to ping it when it was inaccessible and the pings were returning fine.

The device has permanent IP assigned in the router. I access it from wire-connected computer running Windows 8 as well as Linux (Ubuntu). Tried accessing via web browser wirelesly from my phone, result is the same. I didn’t make any software updates for the MBW.

I will try changing socket in the switch, but actually have not too much hope that it will help - reconnecting it from router to switch didn’t help.

Anyone has any suggestions?




Removing ethernet plug from MBW socket and putting it in again causes that something begins to happen inside the device. Hard drive starts to live and doing some operations, ethernet socket orange diode starts flashing quickly, but it isn’t still accessible neither via web browser nor as a drive. Switching ethernet to different socket in the switch has the same result - something happens. 

I don’t know too much about ‘wget’ in linux, but I was able to get ‘connected’ response from this program, after entering 'wget’. 



Hi all,

This is very odd. I am also finding that MyBookWorld (White light) becomes inaccessible after a few hours. The NAS drive has worked absolutely fine but over the last 4 or 5 weeks I have had to power cycle the drive. In an effort to resolve the issues I updated to the latest firmware but to no avail.

I have performed a factory reset and that has not helped either!

I think that with so many people complaining about this sudden inaccessible issues perhaps WD need to review this issue. I have raised an RMA but I feel if/when I get my replacement unit I will see the same issues, I am still trying to find a solution so haven’t sent it off yet. I believe that the bug is in the firmware which is causing the network interface to stop responding. I also think that something on the network is causing the WDME to lockup/freeze. The unit will respond to a ping but that’s all you get and nothing else.

I have a combination of windows 8, windows 7, ios devices on the network, along with a Samsung Smart TV. The only new thing on the network is the TV, apart from Windows updates to the PCs.

Whatever is causing the issue, only WD can resolve it via firmware. It is not robust enough to cope with whatever is dropping it into a frozen/locked up state.

I have tried static and dynamic IP - that has not helped. Moved it to another switch - still no joy.

Getting fed up of power cycling this thing every time a use it - that’s daily!!!

Any one from WD looking at this issue to offer any kind of steer apart from going down the RMA route?

There must be some sort of nexus of MBW failures…

Mine has gone back to misbehaving after working okay for a few days. In fact it’s worse now as resetting the switch hasn’t fixed it. I even tried swapping leads in the switch to see if that would help, but the MBW is still unresponsive (other than to pings).

Not happy right now…

I seem to get about three days of good use before the MBW needs resetting. Not an ideal situation but it is workable.

I am still a bit put out by the sudden change after years of faultless behaviour and would be very grateful if someone knowledgeable could suggest some fault-finding ideas, or better, a solution.

Yes, would be good to hear any answer. Something like “we are aware of the problem and working on it”, or at least “we will not fix this issue and you have to live with it as it is”.

Did anybody hear about alternative, third party software that could be installed on MBW and make it usable again?



I have been twisting myself into knots reading a hundred different websites that talk about disabling TwonkyMedia as a possible solution. But none of them seem to mention how you get from “enabling SSH” to all of the linux terminal commands that I am seeing. Some of them do mention installing third party linux apps but I have no intention to do that.

I am willing to try disabling TwonkyMedia if someone will *please* give me straightfoward instructions on how to do it without installing other software.

(Whilst I do have some linux machines I am only an occasional linux user and have only been tinkering with it for a couple of months. Most of the terminal stuff is totally foreign to me.)

OK, I’ve had a breakthrough.

I’ll post my actions here, although I won’t mark this as a solution until the MBW has been running long enough for it to have hung had I not made the changes.

Please do take extreme care if you do this to your NAS as I’d hate for you to lose your data! This is the first time I’ve attempted something like this so please let me know if you notice any errors.

First, I enabled ssh (secure shell) via the web interface:

Advanced Mode > System > Advanced > SSH Access

Using a linux machine I was then able to log into the NAS as root using ssh via the terminal (and without needing other software):


where all of the X’s are the actual IP address of your unit.

I was prompted for a password, which by default is welc0me (with a zero).

Then I executed the following ssh command (which I found right at the bottom of this web page):

chmod 644 /etc/init.d/S97twonkyserver

As written on that page, this command removes the executable permissions from the script that starts TwonkyServer.

I then restarted the MBW via the web interface:

System > Shutdown / Reboot (in Avanced mode), or simply Shutdown / Reboot (in Basic mode).

Because the script is no longer executable the TwonkyServer (hopefully) didn’t start along with it.  To confirm, I then tried to access it via the web interface:

Advanced Mode > Media > Media Server

I could not establish a connection, indicating that the TwonkyMedia server had indeed stopped.

Whether or not this actually resolves the issue is another matter. The acid test will be to see how long my MBW keeps running, and I will post back onto this forum when I know one way or the other.

This is a non-destrictive change (as long as I didn’t screw anything up!) that can easily be undone via this command in an ssh session:

chmod 755 /etc/init.d/S97twonkyserver

 Given that I wasn’t even aware that TwonkyMedia was running, I don’t think I’ll be in any rush to renable it…

Yesterday I applied your solution and it has been working until now (24 hours). And I have a feeling that I can now traverse directory structure much faster than previously, when Twonky was running.

The only drawback is that I used Twonky for broadcasting music to my TV-set via DLNA.


@ptr100, some other people have had success by reducing the Twonky buffer size, as discussed at the bottom of this page:

It seems to be very hit and miss but it might allow you to keep using Twonky and still have a functional NAS…