WD World Edition white light freezes/locks up


#1

My WD World Edition (white light) Firmware 1.1.18 freezes again and again (I bought it 3 weeks ago brand new). I have no idea how to analyze this problem, but it seems that this box is running out of memory or disk space (10% used for backups currently). I tried to fix the problem by disabling mionet and twonky (but only by disabling startup-services and the “hack to make Mionet obey startup” as described. I left “cvm” “changeNotifySocket” and “miocrawler/miocrawler” untouched). Active Services are:

  • SMB
  • NFS
  • SSH

The box hangs after copying several 10GBytes, in the frozen state you experience

  • requests to open ports are answered by some SYN/ACK packets - then network traffic stalls (SMB, NFS, SSH)
  • ping requests are answered normally
  • an activated cron job with “reboot”-command is not working in frozen state
  • after manually switching off and on the device is working like a real NAS

Since this bug apparently will never be fixed by WD (forget their support, they “help” with text templates having absolutely nothing to to with the bug) I tried Vlado’s recipe here but had no success.

After stopping inetd the drive is running 9 days + without freezing until now:

  1. enable SSH in Web Interface (in Advanced Mode -> System-> Advanced-> SSH Access check “Enable”)
  2. connect to your drive with an SSH-Terminal (try PuTTY for Windows) - you need the IP-Address of the drive, Port is 22 -> click “Open” -> type username “root” and password “welc0me”
  3. you are hopefully logged into the drive (you see something like “~ #”), type following command:
    /etc/init.d/S60inetd stop
        (this will stop inetd temporary until next reboot)
  4. close your SSH Terminal

Update : drive is running without problems - several 100 GBytes were copied - uptime 9 days + :smiley:

Update : crash again after 10 days, firmware upgraded to 1.02.06, MioNet, Twonky, inetd stopped - lets wait …


MyBookWorld (white light) suddenly no longer accessible after resuming from standby
#2

See my thread . My WDWE(white light) locks up. Same problem. M


#3

Seems that stopping inetd solved the problem :smiley:, temporarily stop it with:

/etc/init.d/S60inetd stop

or permanently disable it by e.g.

mv /etc/init.d/S60inetd /root/

      (enable again by  mv /root/S60inetd /etc/init.d/)

my uptime is 10 days and I copied ~ 1 TB, I’ve never reached this limit before…

UPDATE : crashed again :angry: after 10 days - this thing is so buggy - i updated to firmware 1.02.06 , stopped MioNet, Twonky and inetd again (firmware update removes all system modifications!) and keep on trying … Consider rebooting your Windows machines (shared folders might not be accessible from Windows after the update!)

UPDATE : uptime 5 days now, ~ 3GB transferred since last reboot …

UPDATE : uptime 7 days, switched NFS to RW access

UPDATE : uptime 12 days …

UPDATE : uptime 18 days, I guess the firmware upgrade and deactivation of services has improved this poor device significantly :smiley: and WDC support suggests changing hardware (!!!) A friend of mine bought the same box in the meantime. He is very upset because he did not ask me before and  - surprise - his brand new MBWE II suffers from the exact same error !

UPDATE : uptime 43 days, I’m beginning to trust this box now :wink:


#4

I will give this a go. Thanks M


#5

what does S60inetd do?


#6

inetd is a process listening for incoming network connections and will launch according processes (e.g. ftp-Server etc.). I am not sure what this does on WDC Mybook (I guess not very much ;-), but I suggest switching it off temporarily and see if you miss services. The problem with this device is, that its software is very old and so inetd is from Nov. 2008! Since 2009 a bugfix for inetd is available , which might correct the problem - but this has not been updated in the box until now and no update is available from WDC.

UPDATE : They updated to firmware 1.02.06 two weeks ago, after the update inetd reports version 1.1.1 from 2009/12/24! (seems to be a weird self-compiled piece of software, current version should be 1.18.2 from 2011/01/16 ! ) - maybe the problem is solved with the “update” (or whatever this is?) - a spark of hope…


#7

I’ll give this a shot. its been ridicoulous that i have 2TB and cant depend on this thing not freezing up during an upload on windows 7.

update: still freezing upon uploads.

030811 update: the 64GB upload was a success!! i think we may be on to something here. here is a snapshot of what i did.

  1. followed LarsMaschke post to remove “nice -n -20” so that it just says " /usr/sbin/smbd -D"  in /etc/init.d/S90smbd.

 link: http://community.wdc.com/t5/My-Book-World-Edition/​Large-File-Problem-eg-Backup-Jobs/m-p/148222#M409…

  1. followed Vlado post to disable everything mionet (I didnt do mv /etc/init.d/S97twonkyserver /root which deals w/ twonky) and i also edited /usr/mionet/monitorCVM.sh to make Mionet obey startup flag.

link: http://community.wdc.com/t5/My-Book-World-Edition/​Drive-Becomes-Un-Accessible-After-short-use-II/td…

  1. reboot through putty and/or web interface.

  

i had undone everything else i’d tried on the forums here so truly mionet is the only thing disabled.


#8

Well. this option is definitely working for me. As I also purchased a new NAS from a competitor to be my primary NAS. I use this POS as to play around with now. So far it has backed up over 9gb of World of Warcraft DVD’s without lockup. So I also believe it has to due with the inetd’s 2009 bug issue. Shame WD couldn’t find that with as many people complaining about it.

Will keep playing around to see when/if it’ll lock up.


#9

I just don’t know how to rely on this product, This is a major bug and its not fixed I am not getting uptime of more then 2 days. And if I am using it as a proper media sever and itunes server I simple cant rely on this. I just cant trust it, is anything happening with it, I bought it 3 weeks ago and backed everything up so its difficult to just return it. AT the start I thought it was just me do not understanding how these work but after reading comments here I understand that it is a faulty firmware. Please WD fix this


#10

I’m having the same problem. The lowest white LED is frozen and when I use WD Anywhere Backup to check the status, I find that the device is not available. This morning I could get it to reboot by pushing the power button on the back, but often it has been unresponsive to that and I’ve had to unplug the power supply in order to get it to run again. Updated firmware to 1.02.06 but it still is happening. I’m NOT running MioNet or Twonky. I purchased this item in November, 2009 and it worked without freezing for ~ 1 year. Over the past month, however, it’s repeatedly come to a halt.

Comments on this bulletin board do not make me hopeful as many posters seem to be way ahead of me tech-wise.

I don’t know if it’s connected, but the machine is slow as molasses when I try to access it using Firefox. I don’t remember it being that slow in the past.


#11

Did you change anything before the first crash after running a year well? The problem might be related to transferral of huge amounts of data or large files (~ GBytes). My box has never worked after purchase in end of 2010, but stopping services manually helped (my uptime is 11 days now). Unfortunately twonky+inetd must be stopped or disabled by SSH as described in this thread :frowning:


#12

i’ve disabled everything and move all the init files like twonky, mionet, inetd…

but the problem remain!

i have some errors as I wrote in this post:

http://community.wdc.com/t5/My-Book-World-Edition/LOG-ERRORS-read-data-amp-getpeername-failed/td-p/121232

maybe in the end the problem is related to some error on the disk?

another theory is that the problem is related to some ethernet card… but that’s another story.


#13

The errors you posted seem to be a problem of the client machine (“connection reset by peer”). If disks were bad, you’d see errors in /var/log/messages (like “uncorrectable sector” or “I/O error, dev sdX” etc.). My experience was, that the MBWEII was only pingable in frozen state and it could not start new processes (cron jobs were not executed). So this seems not to be a problem of the ethernet card (TCP-packets could be initiated, but no session established), I think the box has a memory or swapping problem.


#14

you say “swapping problem”…

I’ive read somewhere that it is possible to umount the swap partition and check it with a check disk utility.

could be a fix?


#15

Yes, you can switch off swap by:


cat /proc/swaps           # identify swap partition

swapoff /dev/mdX          # should be /dev/md1 from above output


and format swap by:

mkswap -c /dev/mdX    # check for bad blocks + format swap space

                      # /dev/mdX is critical, do not format data partitions !!!

swapon /dev/mdX       # activate swapping again


Hope this helps :slight_smile:


#16

thank you hurtware!

I have successfully done it on both my MBWE without any error message.

Would you be so kind to tell me also how to check the data partitions to see if it’s all ok?

just to be sure and remove any possible cause.

Anyway the var/log/messages do not show anything strange (to me)

The errors in the CIFS log refers to samba errors, as I found searching on google.


#17

after one hour, one of my MBWE freezed again.

I found it because I left the WINSCP session opened, but the drive was in standby (led flashing)

the only things in the log are the usual samba errors.

I’m really depressed  :cry:


#18

can you post the process list of one bad MBWE?


#19

tell me what to do and i will be your hand


#20

oh sorry, type this command in SSH-terminal:

ps -efl

and copy/paste output. This is the process list…