MybookWorld Edition undetectable - White lights blinking


I’m running under windows 7.

Mybook world Edition is now undetectable when it started to blinking curiously. It was working perfectly until now.

There are 3 white lights in the front. The top light is blinking, the middle light is off and the bottom light is ON.

There is nowhere such light configuration is explained.

Anyone knows how to help me to retreive my datas ?


Try resetting the drive to clear out any possible configuration issues.

How to reset the WD ShareSpace or the WD My Book World (White Light) drive

I had this for more than 3 years and it has never given me problems till now. I realised I had an old firmware so upgraded (very painfully) to the latest version. that didn’t help till i read this post (which is unfortunately closed) it mentions to turn off mionet and twonkyserver and

also mentions

The fix, suggested by magugu, is to edit /usr/mionet/ and just below the comment lines at the top (prefixed by ‘#’) add the following:

Start of hack to make Mionet obey startup flag

if [! -f “/etc/.mionet_on_startup”];

then exit 1 fi

End of hack to make Mionet obey startup flag -------------------------------------

My Qs 1. Does one disable NAS from going into standby?

  1. How do you edit this file? Can you please provide some detailed command lines and explanation like the one for the disabling mionet and twonkyserver?

  2. Why does WD staff not providing a fix for this? I see so many people having problems with this issue and with more data being stored-people may be coming closer to optimum storage with issues like these!! i still have 220G space and I am having trouble someone please keep this link open till it is resolved!

I have reset the NAS by pressing the button off and on again (number of times now)

Had static IP but now after reset has become dynamic and yet connection is not regained

Connection comes on briefly but is lost again

Light is on (white long light)

Can ping the IP address but not by name

WD discovery tool will not find it

Windows explorer mapped drive doesn’t find it (win 8) -it was working relatively well till about 1 week ago, after which I did an upgrade to new firmware and it has gone worse

managed to get into SSH and followed the instructions as per the link above

but after reboot cannot connect now


Can you not see the person cannot even connect…which is most people have trouble with

How are you asking the person to log into the WD config when they can’t even get to the unit!!!NOTHING WORKS

If at all this link is more useful than what you are providing!!!

How is it so difficult for WD staff to get on and provide some solution to something that has already been noticed as a bug 3 years ago and SOLVED BY USERS!!!

I’ve tried already the reset procedure several times but without succes because MyBookWorld is still undetectable.

Even I press the ON/OFF button nothing appens, it doesn’t turn off. I’m oblige to take off the power cable.

MyBookWorld is still blinking telling me that there is a boot error.

Please Help me !