Drive Becomes Un-Accessible After short use II

All users of WD MyBook World Edition II (white light) have problems with firmware 1.1.16 and 1.1.18 with freezing the device and WD won’t help them to fix this BUG and release new firmware. The problem is in Twonky and Mionet. I communicated more then two weeks with WD Support and they ignore our problems! Somebody closed the problem Drive Becomes Un-Accessible After short use , however it was not solved.

Here is an update guide from dzentai how to fix this problem till we are waiting 9 months for new firmware which should fix this BUG permanently.

In the web configuration switch to Advanced Mode, then on the System tab using the Advanced button check the SSH Access checkbox on the top of the page, then Submit.

Using Putty or any other SSH client connect to your NAS’s IP address, and log in using “root” as username, and “welc0me” as password!

Now you are inside your NAS.

Type the following on the prompt (this will move/save the startup scripts to the /root/ folder and disable running of mionet and twonky main program and miocrawler it is unnecessary):

mv /etc/init.d/S9M_mionet /root/

mv /etc/init.d/S97twonkyserver /root/

mv /usr/mionet/bin/cvm /root/

mv /usr/mionet/changeNotifySocket /root/

mv /usr/mionet/plugin/miocrawler/miocrawler /root/

then reboot your NAS with


Disable all other unused services in the web configuration to free up some more RAM and make your NAS more stable.

Or something for experts.

The white light has an option on the web interface (Basic > Remote Access) that allows you to disable Mionet at startup, unfortunately, while the startup script correctly obeys that setting, there is a bug in a watchdog script that ignores it and will re-enable Mionet every ~20mins.

The fix, suggested by magugu, is to edit /usr/mionet/ and just below the comment lines at the top (prefixed by ‘#’) add the following:

Start of hack to make Mionet obey startup flag

if [! -f “/etc/.mionet_on_startup” ]; then
 exit 1

End of hack to make Mionet obey startup flag

The fix makes the script look for the flag (/etc/.mionet_on_startup) created by the web interface. The script terminates if the flag isn’t found, but if the flag does exist it will continue as normal (it’s designed to automatically restart Mionet if it is found not to be running)

I hope that more users will write to WD and they will start work on new firmware to fix all those BUGs written on this forum, because WD MyBook World Edition II (white light) has definitely more BUGs than iPhone 4 :slight_smile: You don’t need restart iPhone every 20 minutes!!!




Yes, I can confirm that MioNet starts though the flag is set NOT to start during system startup.

This is a bug, definitely!

Uptime after fix the problems 3 days!!!:smiley:

Uptime after fix the problems 7 days!!!

Hi WD guys,

When will be a new firmware?

It is easy to fix, you need only use your brains and hands to fix the problem, the guide is few lines above, however I forget you don’t know how to read!

Vlado wrote:

Uptime after fix the problems 7 days!!!



Hi WD guys,


When will be a new firmware?


It is easy to fix, you need only use your brains and hands to fix the problem, the guide is few lines above, however I forget you don’t know how to read!

I doubt any WD guys are looking at this thread.  They’re supposed to be working on a firmware update, but I wouldn’t know when it will be available.

When will be available new firmware which will fix all those BUGs?


Uptime after fix the problems 14 days!!!

Who need new firmware?! :slight_smile:

The users are better than internal WD programmers!

Do that, don’t do that, fix this, don’t touch this, disable this part of functionalities, try to edit this script, don’t use this version of OS, it will be better to don’t click on this button, this is not supported part of the device… Those are classic answers from WD support stuff!

What the f…! 

Using WD products is more complicated then drive a Space ship!

They offer me to refund money when I will be quit and send them the device back at first.

I have there 4 TB of my personal data, so they advice to me to buy a new NAS move the data out from WD MBWE II and send it back to them.

OK, I have no problem with that, however the question is simple.

Who will pay for my time which I spent to fix the problems instead of WD stuff, who will pay for all the troubles and all the costs for transfer the data and for new device?

This is a principle question and I hope that another WD users with same problems will support me with this activity, to get better support from WD for the money we already paid to them.

I’m interesting on your feedback.

1 Like

I’m having the same problem.  It works when I first start my computer but freezes after a while and won’t let me open it.  It is connected to my AT&T DSL Modem.

The fix seems to have worked perfectly. Just transfered about 30gb of home videos with no problems. I can’t believe those ding dongs at WD haven’t figured this out yet. What gives with that. Thanks for the fix.

Well, after three unexplainable freezes (even the power button had no effect: had to unplug/replug), 24 to 48 hours apart, I’ll try this fix.  Oddly, the unit froze a fourth time right after I edited the script as indicated in the first post…We’ll see.

It froze again.  But I had only done the edit.  I’ll try the rest of Vlado’s/Dzentai’s suggested manipulations and see what happens.

Friday now, and no freeze.  Looks like the file moves *and* the script edit were all that it needed…Not that we should have needed to do this in the first place!

Just another jaded WD 4TB MBWE2 user here…  as with too many other users here my personal experience with WD support has been miserable with unacceptably long response times and ■■■■ poor (i.e. generic cut&paste) information that failed to address what I was asking anyway.

Putting my soapbox aside though, I’m currently on 1.02.04 firmware and have the ‘unaccessible after short use’ problem and would like to know if Vlado’s suggestions (post 1) still apply to 1.02.04 and not just 16&18…

Also, what’s the risk of bricking the device performing those suggestions (I’m just very cautious and can’t afford the pissing around if I lose the data contained on the drives).

Would appreciate any information ppl are willing to share…


On a separate note, I wanted to add that I personally don’t begrudge the work that the support team are doing with regard to working on new firmware and attempting to isolate the problems that are apparently plaguing a huge number of MBWE users…  I encourage them in what they’re doing and hope they’re able to resolve the issue ASAP.

The real failing within WD is obviously within the ranks of management that has failed to recognise an under staffed support/development team and the implications this has on long term company reputation.

I for one will not consider WD for anything other than bare HDD’s anymore - based purely on my experience with the MBWE I’ll be looking to Synology or NetGear to replace it - definitely no WD products!

Well, mine is running 01.01.18…And unless something fails to work, I’ll not upgrade, considering the risk being bandied about here.

I’m happy to report that following the first lot of steps (not the expert steps) from Vlado’s initial post appears to have resolved the frequent inability to access the drive  that I was experiencing on 1.02.04 firmware…  The NAS has been up and running without a hitch for ~2-3 weeks now…

Well worth the effort and kudos to Vlado…


Firmware 01.02.05 does not fix this promblem. I still needed to do what on the first post and no freeze for couple days.

1 Like