MyBookLive crash during file transfer with samba

Hi

I am facing this problem: when I transfer some files from my pc (Win Vista) to my MBL (3 TB, fw 02.10.09-124), my MBL crashes (samba, ssh, web ui does not respond anymore).

I have to unplug/plug power cable to restart it.

It only happens during the copy with samba of these specific files (ex: a 250 MB .mp4 video file, a 6 GB .ts video files); no problem with all other video files (also mp4 and ts files).

Same problem occurs if try to rename these files before the copy

I also tried to stop twonky and itunes services before the copy; not a solution :cry:

If I transfer these files using WinSCP, no problem.

I tried to umount and e2fsck /dev/sda4, and have no problem of the disk

Before trying to upgrade the fw, do someone wuld have a brilliant idea to help me ?

Regards

Really Great :angry:

This morning I finally decided to upgrade to fw 02.11.09-053 via the web interface

Download was ok

Update 10% … stuck … check network connectivity error

Now my MBL is bricked with white led

SSH service down

Dashboard down

Only ping answers

What should I do now ???

Ok … 1h of white led … I presumed fw update was not in progress anymore.

So I unplugged power cable to reboot the MBL. MBL seems to start, fw version is still the previous one 02.10.09-124

SSH service available.

Could someone tell me what I should do now ?

My MBL is almost full (300 GB available on the initial 3 TB).

Samba transfers from my PC to the MBL crash more and more often

FW upgrade seems to crash the MBL the same way samba transfers do

Any advice welcome

EDIT: trying to contact support, and another pb on their web site after I posted:

https://westerndigital.secure.force.com/apex/WD_WebToCase

There was a problem processing your request:
Class.WD_WebToCaseController.init: line 78, column 1

Nobody ???

Ok … continue speaking alone here

I now have no idea of what I can do with my 3 TB MyBookLive (except throwing it out of my window):

File transfer from my PC to MBL still crash the MBL operating system.

Short Diagnostic Test -> passed

Full Diagnostic Test -> passed

e2fsck -f /dev/sd4 -> clean

Firmware update, tried twice -> update fails a 10%, have to reboot MBL, and firmware not update

Support form on WD website does not work (error on WD website)

No help from WD on this forum.

What a terrible support

Give this a go and report back… You seem to know what you are doing, so go with guide 3

http://community.wdc.com/t5/My-Book-Live/GUIDE-Restore-Downgrade-firmware-via-the-reset-button/m-p/481588#M15044

Hi nfodiz, and thanks for helping me.

To be 100% sure I understand, do you suggest me to downgrade my firmware ?

I would go with the same firmware or higher

Ok.

I will then try with the one I failed to update yesterday.

Not @ home right now, I’ll try to apply your guide tonight and will report back to you :wink:

Thanks

If your OS currently resides on /dev/md0 the script will write a factory fresh firmware image to /dev/md1 and then boot from /dev/md1 if the image copies successfully. The data partition will not be touched but you will need to relink your shares using the dashboard when the script completes and reboots your drive.

If the script fails, the drive will reboot off /dev/md0 with no change to your OS and I would need you to post the output from the script

Ok, I’ll try that (but then, probably not tonight since I would like to apply the process safely to be sure I don’t make stupid mistakes; so maybe during the next week-end)

For info, I already tried to check what happened when my MBL crashes (i.e. during a file transfer, or during the fw upgrade).

I had pending ssh sessions with “tail -f /var/log/messages”, "tail -f “/var/log/samba/log.smbd”, “top”, …

The only thing I saw was:

  • the smbd process disappeared

  • the load avg increased (from 1.x to 13.x during 1mn, then decreased)

After that my ssh sessions where dead (still connected, but every command I tried like “ls” or “ps” resulted either in a segmentation fault or bus error message), and the green light blinks … forever

As a result: no SSH, FTP, HTTP connection allowed anymore. But the MBL replies to ping

I also tried to replace the smbd process nice value (/etc/priority.sh) from -15 to 0, and change the various oplock settings in the samba configuration, but no success.

So I restored the initial settings.

I’ve also read stopping the inetd process would also be a solution, but did not tried that yet.

Here is the full story :wink:

Sounds like you tried everything you can but to restore a fresh copy of the OS. Has the drive worked for large file transfers previously?

I bought it more than 1 year ago, and use it almost every day for my laptop’s backups and to store video files generated by my DVB-T recorder (files between 1 and 10 gb). I never had such problems until 1 or 2 weeks ago.

My drive is now 90% full … I just hope this is not the reason :wink:

hi koala1 do you care to share what’s the outcome of your problem? have you tried the newest fw just released today? thanks

Hi TKart

No problem to share :wink: Do you also have problems with your MBL ?

I think I will not be able to upgrade to this fw, for the simple reason I first have to upgrade to 02.11.09-053: it is not possible to upgrade directly from 02.10.09-124 to the most recent firmwares :frowning:

Next week-end, I’ll then try to upgrade the firmware manually (using ssh .sh script or nfodiz guide).

Besides that, I lauched a full diagnostic test. After 10h, test passed.

Yesterday I successfully transfered 2 HD video files I recorded on TV (<=> 2 * 2GB). But that doesn’t mean my problem is solved … let’s wait and see.

I have also been contacted by WD support. They will propably call me to analyze the problem.

Regards

Hi

Some news: not only samba crashes my disk, but also ftp when I try to copy a 2 GB file on my MBL

And I confirm, crash ONLY occurs when I try to transfer file -> MBL

This morning, I decided to try a firmware update via SSH:

/usr/local/sbin/updateFirmwareFromFile.sh /DataVolume/shares/Public/apnc-021109-053-20120413.deb

MyBookLive:~# /usr/local/sbin/updateFirmwareFromFile.sh /DataVolume/shares/Public/apnc-021109-053-20120413.deb
version_newfile=021109053
version_current=021009124
package_newfile=apnc
master_package_name=apnc
/usr/local/sbin/updateFirmwareFromFile.sh: line 141:  4241 Bus error               dpkg -i ${filename} 2>&1
      4242                       | tee ${updatelog} > /dev/null
/usr/local/sbin/updateFirmwareFromFile.sh: line 109: rm: command not found
/usr/local/sbin/updateFirmwareFromFile.sh: line 111: grep: command not found
/usr/local/sbin/updateFirmwareFromFile.sh: line 33: awk: command not found
/usr/local/sbin/updateFirmwareFromFile.sh: line 33: cut: command not found
/usr/local/sbin/updateFirmwareFromFile.sh: line 54: mdadm: command not found
/usr/local/sbin/updateFirmwareFromFile.sh: line 56: mdadm: command not found
/usr/local/sbin/updateFirmwareFromFile.sh: line 32:  4416 Segmentation fault      sleep 1
/usr/local/sbin/updateFirmwareFromFile.sh: line 133: /usr/local/nas/led_color: No such file or directory
/usr/local/sbin/updateFirmwareFromFile.sh: line 141:  4216 Exit 1                  { function restoreRaid ()
{
    currentRootDevice=cat /proc/cmdline | awk '/root/ { print $1 }' | cut -d= -f2;
    duplicate_md=;
    if ["${currentRootDevice}" != “/dev/nfs”]; then
        if ["${currentRootDevice}" == “/dev/md0”]; then
            if [-e /dev/md1]; then
                duplicate_md="/dev/md1";
            fi;
        else
            if ["${currentRootDevice}" == “/dev/md1”]; then
                if [-e /dev/md0]; then
                    duplicate_md="/dev/md0";
                fi;
            fi;
        fi;
        if [! -z ${duplicate_md}]; then
            echo “stopping duplicate md device ${duplicate_md}”;
            mdadm --stop ${duplicate_md};
            mdadm --wait ${duplicate_md};
            sleep 1;
        fi;
        mdadm ${currentRootDevice} --add ${rootfsDisk1} > /dev/null 2>&1;
        mdadm --wait ${currentRootDevice};
        mdadm ${currentRootDevice} --add ${rootfsDisk2} > /dev/null 2>&1;
        mdadm --wait ${currentRootDevice};
        sleep 1;
    fi
}; filename=${1}; updatelog="/CacheVolume/update.log"; if [$# != 1]; then
    echo “usage: updateFirmwareFromFile.sh “; exit 1;
fi; if [! -f ${filename}]; then
    echo “File not found”; exit 1;
fi; dfout=df | grep /DataVolume; avail=echo "$dfout" | awk '{printf("%d",$2-$3)}'; if [”${avail}” -lt “${fwUpdateSpace}”]; then
    error=“failed 201 “not enough space on device for upgrade””; echo ${error} > /tmp/fw_update_status; echo ${error}; exit 1;
fi; version_current=cat /etc/version | tr -d .-; version_newfile=dpkg -f ${filename} Version; version_newfile=echo ${version_newfile} | tr -d .-; echo “version_newfile=$version_newfile”; echo “version_current=$version_current”; package_newfile=dpkg -f ${filename} Package; echo “package_newfile=$package_newfile”; echo “master_package_name=$master_package_name”; if ["${master_package_name}" != “${package_newfile}”] || ["${version_newfile}" -lt “${version_current}”]; then
    error=“failed 200 “invalid firmware package””; echo ${error} > /tmp/fw_update_status; echo “Error: $0 (${filename}) version ($version_newfile) is less than current system version ($version_current)”; echo “Error: $0 (${filename}) version ($version_newfile) is less than current system version ($version_current)” | logger; exit 1;
fi; old_color=cat /usr/local/nas/led_color; echo white > /usr/local/nas/led_color; dpkg -i ${filename} 2>&1 | tee ${updatelog} > /dev/null; status=$?; rm -f /CacheVolume/*.deb; cat ${updatelog} | grep -q “not a debian format archive”; if [$? -eq 0]; then
    error=“failed 200 “invalid firmware package””; echo ${error} > /tmp/fw_update_status; echo ${error}; restoreRaid; if ["$old_color" == “red”]; then
        echo “red” > /usr/local/nas/led_color;
    else
        echo “green” > /usr/local/nas/led_color;
    fi; exit 1;
fi; if [${status} -ne 0]; then
    echo “dkpg exited with non-zero status: ${status}”; error=“Update failed. Check ${updatelog} for details.”; echo ${error} > /tmp/fw_update_status; echo ${error}; restoreRaid; if ["$old_color" == “red”]; then
        echo “red” > /usr/local/nas/led_color;
    else
        echo “green” > /usr/local/nas/led_color;
    fi;
fi; }
      4217 Bus error               | tee -a ${SYSTEM_SCRIPTS_LOG}
/usr/local/sbin/updateFirmwareFromFile.sh: error reading input file: Input/output error

Ok, now I’m pretty sure my recent MBL problems are related to the disk usage %

After deleting a big file on my MBL (9.5 GB), I was finally able to install fw 02.11.09-053 using the same SSH command from my above post !

Ok, issue this command

df

… and report back

MyBookLive:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
tmpfs                    51200         0     51200   0% /lib/init/rw
udev                     10240      6784      3456  67% /dev
tmpfs                    51200         0     51200   0% /dev/shm
rootfs                 1968336   1008068    860280  54% /
tmpfs                    51200      3712     47488   8% /tmp
ramlog-tmpfs             20480      6592     13888  33% /var/log
/dev/sda4            2914267776 2584463040 329804736  89% /DataVolume

or with df -h for a more readable output

MyBookLive:~# df -h
Filesystem            Size  Used Avail Use% Mounted on
tmpfs                  50M     0   50M   0% /lib/init/rw
udev                   10M  6.7M  3.4M  67% /dev
tmpfs                  50M     0   50M   0% /dev/shm
rootfs                1.9G  985M  841M  54% /
tmpfs                  50M  3.7M   47M   8% /tmp
ramlog-tmpfs           20M  6.5M   14M  33% /var/log
/dev/sda4             2.8T  2.5T  315G  89% /DataVolume

Weird.  Looks like there’s plenty of space remaining – 315 Gbytes free.