MyBook Essential USB 3.0 problem

I have just purchased a 3TB myBook essential external harddrive, and it works perfectly on the older USB 2.0.

Which leads me to believe that there is no fault with the drive.

It is not identified by my computer when it is plugged into my USB 3.0 port, but when I plug in anything else into the USB 3.0 port it works… 

Which leads me to believe that there is no fault with the port…

I have updated all of my drivers and flashed my BIOS.

I am currently running an ASUS g53jw-xn1

@ BIOS version 211

Any help would be greatly appreciated.

It sounds like some problem on OS which one? Did the PC come with USB 3.0 or is this an upgrade? If it’s an upgrade what card? Are all of the USB and USB Controlers up to date?


its all original hardware, and all of the drivers are up to date…

I am running Windows 7 64-Bit Home Premium

I am using the same OS (Win 7 64 bits) just purchase 2T ‘My Book Essential’ that meant to support both USB 3.0 & 2.0.

I am having identical problem!  That is USB 2.0 works fine, but NOT USB 3.0.  Can someone from WD please confirm that this is OS issue? or somehting else?  My PC motherboard is ASUS P8P67evo - it has 4 built in USB 3.0 ports.

Updating the BIOS would not fix this issue.  I would suggest the following:

  1. update the drive firmware

  2. update your chipset drivers (should be available from ASUS, or whoever manufactures your system).

One other recommendation, you may want to check which ports are actually USB 3.0 because not all of them usually are.  You should be able to find this in the motherboard’s manual.

The computer I am using is a laptop, which has the USB 3.0 port clearly labeled on the side.

I have updated all drivers and utilities to thier most recent editions and it is still not working.

I am thinking about just taking it back and getting one which works with my computer.

Thanks for the help though :smiley:

I had similar problems with my external My Book Essential 1tb USB 3.0 drive. I have a ASUS P8P67 Deluxe mobo and OS Windows 7 Pro x64. The drive worked fine when using a USB 2.0 port but when I tried a USB 3.0 port I had all kinds of boot hangs and/or delays. The solution for me was to disable the BIOS option “Legacy USB 3.0 Support”. 

That sounds interesting… but what does that precisely mean? Legacy is generally a term for backward compatability and related issues (or the lack thereof). Is this BIOS solution of disabling so-called legacy support endorsed by WD? What other implications are there?

I’ve had no luck in getting any meaningful answer to this issue (see other thread) despite all attempts, or even acknowledgement of my efforts in trying to help them figure it out.

I’ve got a problem with the 3TB as I can’t get it to play on my old WDTV Media Player 1st generation. Is there a firmware update issue w/ the player or is it the drive? My 3TB drive is 2.0 & 3.0 friendly. Any help would be appreciated!

DAA80, as far as I know, the WD TV Gen 1 does not support drives of 3 TB.

[Deleted] Would the generation 2 support it?

I’m having the same problems with the 2TB version of the MyBook Essential on the same motherboard.  In fact I have tried two different ASUS P8P67 Deluxe motherboards because I was afraid the problem was the USB 3.0 port on the motherboard.  I am convinced this is a *Western Digital* problem because I have the latest USB 3.0 drivers installed, the latest BIOS on the motherboard, the latest firmware in the MyBook Essential, and I have had this problem with two different ASUS motherboards.  (I also have more faith in ASUS than I do in WD.)

WD is churning out some real junk enclosures lately.  My experience was that I bought a 3 TB USB 3.0 MyBook 1130, but it only worked as a USB 3.0 device for about one day.  After that, it would only connect as a USB 2.0 device.

I later placed the drive (WD30EZRX) inside a different USB 3.0-capable enclosure, and have been using it as a USB 3.0 device ever since.

Clouding the issue was that I wasn’t sure whether the problem was with the MyBook, or with my USB 3.0 card.  The USB 3.0 card used a cheap Chinese knockoff of the Renesas/NEC USB 3.0 controller, so I had doubts until I bought an aftermarket USB 3.0/eSATA enclosure.

FWIW I have a fairly old motherboard, Asus P5E3 WS Pro.  But it has no problem supporting USB 3.0 ports through the 1x PCI Express card I bought.  However, probably because the BIOS was last updated in 2008, the USB 3.0 devices are not available as boot options or otherwise detected in the BIOS menus.

That’s very interesting.  As the MyBook Essential is already *in* an enclosure, it sounds like a lot of work to remove the drive from the enclosure and then to migrate it to an external USB 3.0 enclosure.  I guess I could simply use a different hard drive in my Thermaltake external USB 3.0 enclosure.

Nevertheless, I feel I was cheated by Western Digital for two reasons:  (a) they sold me a product advertised as supporting USB 3.0 when it doesn’t actually support USB 3.0 correctly, and (b) I had to go through all the trouble of replacing my ASUS P8P67 Deluxe motherboard–and the associated insues with reactivating Windows 7–for a fault that was Western Digital’s.

My time is valuable and I don’t appreciate Western Digital wasting it and then not admitting to it.  I have *never* had similar problems with Seagate drives.

jmegas wrote:

That’s very interesting.  As the MyBook Essential is already *in* an enclosure, it sounds like a lot of work to remove the drive from the enclosure and then to migrate it to an external USB 3.0 enclosure.  I guess I could simply use a different hard drive in my Thermaltake external USB 3.0 enclosure.



No, it really isn’t at all. You can pry open the MyBook enclosure with a flathead screwdriver, remove the special USB controller board with a Phillips head screwdriver, and then install the bare drive in another enclosure. Takes maybe 5 minutes.

I had the option to return the MyBook for a refund. But I got such a deal on it, paying $20 less than just the bare WD30EZRX drive would have cost, that I kept it and put up with the “hassle” of installing the drive in a new enclosure. If I had paid full retail, I would have looked at things differently.

Thanks!  :slight_smile:

I didn’t realize it was that easy to do.  Do you have a recommendation of a particular brand of enclosure you have found to work well with USB 3.0?  My guess is that anything with a Renesas (NEC) 3.0 controller would be good, as they seem to make the best chips.

I’ll try that if I keep having this problem.  Right now it is intermittent.

Absolutely.  I bought one of these a couple of weeks ago:

This is the Zalman HE-350-U3E.  It features both USB 3.0 and eSATA connections, and has a real power switch.  No disk encryption.  So if the Zalman enclosure ever fails, you can simply move the disk to yet another enclosure, or hook it up internally, to retrieve your data.

There is also the HE-350-U3 model, which is about $2 cheaper and has only the USB 3.0 connection.

The following review helped convince me to get the HE-350-U3E:

Hi Tech Legion review of Zalman HE-350-U3 and -U3E external disk enclosures

Both enclosures will support a 3 TB disk, which is not true of all USB 3.0 enclosures.

A word about chipsets: Actually it’s not the USB 3.0 enclosure that has the Renesas/NEC (or other brand) USB 3.0 controller, it’s the USB 3.0 interface on the computer side.  It will be either built into the motherboard, or on a PCI Express card.  I have the latter, on a PCI Express 2.0 1x slot.

The enclosure will have its own chipset, to act as the SATA-USB 3.0 bridge.  A common one is the Prolific Technologies PL2771 (USB 3.0 only) or PL2773 (USB 3.0 and eSATA).  My Zalman enclosure uses a PL2773.

The enclosure’s chipset matters if you want to do SMART monitoring of the external disk.  Some SATA-to-USB 3.0 chipsets support it, some don’t.  The PL2773 apparently does, because I can monitor HDD temperature etc. through a third-party utility (such as Hard Disk Sentinel) through the USB 3.0 connection.

I am very satisfied with my Zalman enclosure, and will probably buy another HE-350-U3E when/if I buy a second external backup disk.  I like having eSATA because I have some other computers that lack USB 3.0, but do have eSATA ports.

Thank you, that was *extremely* helpful!  :smiley: 

I had been looking at the AZiO E377-U31, but this Zalman sounds better.  I have always used their CPU fans.  Also, I noticed that the AZiO only has a SATA 2 controller on it, so it might be slower.  I do have a SATA drive to put in, although I imagine USB 3.0 can’t really benefit from the difference.  Being able to use eSATA also is a benefit.  One can never have too many interfaces.  :smiley:

Thanks again for the extremely helpful post.  I will order one right now.:smileyvery-happy:

You were *extremely* helpful!!

BTW, I found some *new* drivers for the Renesas USB 3.0 Host Controller, version  Some people reported that they fixed a number of their problems, but not specifically with the Western Digital drives.

I actually found them available from Intel at:

I am running the new driver on the two machines I have USB 3.0 in, and the driver appears to be stable.

You might have a go at it.

Good luck!:smileyvery-happy: