My PC can't see my WDTV?

I’ve been using my WD TV Live SMP fine for a while now but just today I tried and play some movies from my PC, the WD TV said my folders where empty, nothing to play. I checked the folders I was sharing and no longer seems to be allowing me to share them. I get this message:

Any idea what the issue is?

slightly off-topic … check your PM (Personal Messages)   the little letter envelope icon at the top right of your screen

Also, WDTV doesn’t show up in this list anymore:

Can anyone help me out with this? I still don’t understand why m WDTV isn’t showing up in these areas? It use to show up under Network Locations/Devices which use to be under “Devcies and drives”, now nothing is there except Mezzmo.

pokit_3416a75f4cea9109507cacd8e2f2aefc.jpg

WDTV also use to be shown in this list and now its gone. I haven no clue whats going on. My WDTV is still working, I use Window Shares but still confused on what happend. Unless the WDTV is now know as one of the Unkown Devices? Should I remove them all and try turning the WDTV on and off to see if it shows up again? Also, all the unkown devices have an IP address. I found one Unknown Device that has the IP 192.168.1.8. That is the same address for my WDTV:  http://192.168.1.8/Main.php

Untitled.png

Have you tried turning off the entire home network, starting with modem, router PCs and then all devices?  Then bring it back up.

Yes. Here is what I’ve tried:

  • Unplugged all cables from the Verizon FiOS router. Hit the reset button on the back and let it remain off for a few minutes.

  • I’ve reset the WDTV several times, started from scratch.

  • I’ve reset my PC numerous times, shut it off, etc.

Do you think this Unknown Device is the WDTV? It has the same IP I believe. I went into “Control Panel\All Control Panel Items\Network and Sharing Center\Media streaming options”. I might have removed it by accident at one point, I don’t know. Also, is using Windows HomeGroups a must for streaming, I’m kind of confused on why I needed to created a Homegroup? I have to folder on my PC (Movies/TV) that I need to share, I don’t know if I have it set up correctly/the best way.

Homegroups are not necessary; in fact discouraged, since the WD and other devices do not use this Windows-only feature.  Turn it off .  All devices must be within the same Workgroup.  Be sure they are.

Sharing devices can be confusing to folks new to the concept.  See your WD user guide for more info about sharing as well as WIndows Help.

Make sure your WIndows Advanced sharing is set like this screen shot:



The last setting of this screen is not shown – it pertains to Homegroups, and as said,turn it off.

Have you run the WD Discovery tool to map your drives?  Found in the product’s support pages.

I’m on Windows 8.1 btw. I turned Homegroups off, screeshot below:


I went into Windows Advanced sharing like you said and mine where already set up like yours. Mine has 3 sections as shown below:

I also have the WD Discovery Tool installed, really not sure how it’s suppose to help me? I’m currently using Mezzmo now through WDTV’s media share option becaise Windows/Network Shares does not work anymore? I don’t know what is going on.


I have no idea what is going on?

  • WDTV no longer shows up under Media Streaming options or under Network Location in My Computer. WDTV still works now and again though, just that WDTV is no where to be found on my PC.

  • Yesterday I was able to still use WIndows Shares. Now it can’t find any files using that option. I have to use Mezzmo to share my files from my PC. I don’t know if it’s due to WIndows Firewall being on but that was never an issue before.

  • I did just turn Media Streaming back on, it was off for some reason.

 Before all these Issues, all I had to for WDTV to work was right click on the folders I wanted to share and that was it. But now I get these messages. I was using WIndows Shares on my WDTV and Media Server before.

  filesharing.png

lan.png

Is mezzmo something new you are using?  Maybe it is interferring, so turn it off and see if things can be brought back to normal.  There is really no reason for another server program, I believe.  Windows does fine when it is working correctly.

One time my sharing was all messed up, so I found everything that was being shared and un-shared them all in Windows.  I rebooted the PC and reshared what I wanted shared and things worked right again. 

Also, quite a few people have reported their shares are messed up on the SMP since installing the latest firmware recently.  Have you seen those messages?  I think you could be in the same boat.

Sorry I cannot be of further assist.  Good luck, and after the holiday, give WD Support a phone call.

generally speaking having the WD be the master browser is a bad idea

I would unplug the WD, wait about 2 minutes

verify that your PC is now the master browser

plug the WD in

confirm that pc is still master browser and see if it works

Mezzmo is DNLA program that allows me to stream movies from my PC to TV. I just click on Media Server on my WDTV and select Mezzmo. I’m using this b/c Windows Shares is not working like I mentioned above. Mezzmo is not the issue b/c I just installed it and the problem started before Mezzmo. I haven’t installed the lastest firmware so that can’t be the issue either.

I’ve done this several times. I unplug my WDTV and plug it back in and them my PC is the master browser again.

UPDATE:  my pc is now the master workgroup. windows share is now working again.

but for some reason wdtv is not showing up under Network Locations:

It also is not showing up in Media Streaming Options:

KAD79  >>>  generally speaking having the WD be the master browser is a bad idea

Wow, I don’t see how I missed seeing that in the screen shot the OP sent.

Of course, yet another MB issue; they just keep coming.

Lots has been written here about the master browser, so suggest searching the forums for various threads for more info.

I’m not only talking about the MB. Here are my issues. This is becoming to a point where my WDTV is useless now, it’s process just to watch a movie.

1. WDTV does not show up anymore under Media Streaming Options. (Network and Sharing Center - Change advanced sharing option)

  1. The WDTV icon no longer appears under Network Locations in My PC/My Computer.
  • Basically WDTV is no longer recognized…Screenshots are above in my previous posts of what I’m talking about.
  1. And now everytime I turn my WDTV box off and then back on the WDTV goes back to being MB again. I then go into Windows Shares and it says “No content avaible”. Do I have to unplug-replug my WDTV everytime I turn it off & on to get my PC back to being MB again? This is nuts what I have to do to now, nothing is working and everything is gone like I mentioned above. I unplug my WDTV for a minute or two, plug it back in, run the LANscan_v1.54 to make sure my PC is MB again. I have to do that every time I turn my WDTV off. Unless I keep my WDTV on at all times.

Why not keep the WDTV on 24/7/365?  I do, and many others do, too.  It hardly uses any power when doing “nothing”; especially if the drives attached go to an idle state in five or ten minutes, as mine do.  I have a Roku; it doesn’t even have an off/on switch – it is on all the time – just like a set top box for cable is.  Why?  So any of these devices are ready to go when you are. 

If the PC is the MB, is everything OK, or do you still have problems?

As long as I don’t turn my WDTV off my PC seems to stay as the MB. So I guess you can say that’s solved but it’s **bleep** solution to the problem.

But here are other issues like I mention in every post above.

1. WDTV does not show up anymore under Media Streaming Options. (Network and Sharing Center - Change advanced sharing option)

  1. The WDTV icon no longer appears under Network Locations in My PC/My Computer.
  • Basically WDTV is no longer recognized…Screenshots are above in my previous posts of what I’m talking about.

OK, so perhaps you need to run the WD Discovery tool for your model WDTV which is found in the Downloads area for the unit’s support page.

bal1985 wrote:

As long as I don’t turn my WDTV off my PC seems to stay as the MB. So I guess you can say that’s solved but it’s **bleep** solution to the problem.

 

Well WD didn’t design the SMB browsing protocol, MS did.  So blame them for its inane periodic “elections” scheme.  Or try reading up on how to set registry values to try to control it.  There is tons of stuff on the web about MB problems–in all Windows setups.  For example:

http://support.microsoft.com/kb/188001

I have written, (too many times now) that there are two excellent ways I know of to control the MB:

  1. Certain routers allow one to set the router as the MB. e.g. WD routers.  Since a router is on 24/7/365, the best MB is the router.

  2. My Asus router became the MB when I attached a drive to its USB port with media on the drive.  It liked that so much that it became my permanent master browser!