My Passport Ultra 3TB not being detected

I have two My Passport Ultra 3TB portable hard drives, one black, the other white. I had both connected to my laptop computer via the same USB C to 4-USB 3.0 hub and was copying a folder from the black one to the white one when both drives briefly lost power, likely due to the hub not being able to draw enough for both drives. Immediately after, the white one (but not the black one) stopped showing up on my computer at all: not in file explorer, not in disk management, not even in device manager. Disconnecting it from the hub and connecting it to one of the USB 3.0 ports on the laptop itself didn’t fix it, nor did restarting the computer.

However, I then connected the drive to my desktop computer and it was working just fine; I could read and write files, no problem. But when I reconnected it to my laptop, it still wouldn’t show up on anything. Both computers are running the latest version of Windows 10. Neither computer has any WD software installed on it, and both drives (white and black) are unencrypted.

I have had this problem, or one similar to it, a few years ago with a different Western Digital external hard drive, but I don’t remember what fixed it then, since I am still using that one today.


It is possible the partition is corrupted.

I recommend you try formatting the drive.

Just backed up all the data from the drive using my desktop and deleted the partition in disk manager, and when I did I noticed something I had never seen before. Rather than it being a GPT disk with a max partition size greater than the size of the disk, it was set as an MBR disk with the max partition size being 2048.00GB. This is the first time this has happened that I have seen, and I am not sure if it had anything to do with the issue, but I thought it was worth mentioning, just in case. As I’m typing this, I am reformatting the drive, and will test it when it is done formatting.

Just finished formatting the drive, tried both NTFS and exFAT, laptop wouldn’t recognize the drive with either. Also, I installed the WD Drive Utilities software on my desktop and ran a drive status check and a quick drive test; neither came up with any issues with the drive.

Just got it to work again, not sure exactly what did it. I shut my laptop off, plugged in the drive with a different cable, turned my laptop back on again, and it started working again. Unplugged it and plugged it back in with the original cable, and it also worked, but wasn’t consistent: it disconnected from the laptop a few times briefly, even though the cable was still plugged in.