My Cloud Mirror Has High RAM/CPU For Undetermined Reason

I posted here a few months ago that I was having difficulty accessing my dashboard on my My Cloud Mirror (Gen 2). This had been an ongoing issue that I chalked up to the two 4TB drives being almost 95% full from movies I had synced through Plex.

In that time, I also bought a Synology server onto which I offloaded all of my movies.

I decided to delete all of the movies from my WD server, and repurpose it for a music and documents backup server (with the hope that Plexamp would be my replacement once Google Play Music shuts down).

I loaded about 60GB of my Google Play Music library on to the server, leaving about 3.9TB free on the drives, and let them index and sync. However, even though it’s been a few weeks since I did this, the server (both in the WD Dashboard and the Plex app) responds very slowly and unreliably.

If I try to access the WD Dashboard, it can sometimes take 3-4 tries before I get in to the server without it timing out.

On the Plex Dashboard, I have noticed that the server’s RAM is being used at 60%-80%, while Plex (the only app I have installed on the server) is using a minimal amount of the CPU.

Is there a good way to go about determining what is causing the hangup on my server, either in Plex on with the drive itself? Any suggestions on how to revive it so it can be used functionally to at least stream music?

I’m surprised it’s taking this much effort for MP3s when it used to be able to stream a movie with video and audio… I’m sure it’s more than capable, but just getting over this last hurdle will make it more than a paperweight again.

Thanks for any and all help!

Its because you have a syn diskstation. This became incredibly noticable once i upgraded to the ds918. It is so fast with its intel celeron vs ARM. Not to mention DDR4, I think most myclouds are 256mb ddr3 with the exception of a few that have 512/1gig. I removed plex from my ex2 ultra just because of the reason you stated, High CPU, load averages that never come down. Wouldnt suprise me if you dont have a SMR drive in your nas. Best of Luck.

edit: enable sshd and login to terminal and run the cmd atop it will tell you whats using what.

I’d be surprised if that’s it. The WD used to be able to stream multiple movies at the same time. Playing an MP3 can’t be as taxing as that, right?

I checked, and it does have 512mb of RAM.

I ran the atop command that you suggested, and this is the result:

Let me know if that reveals anything.

Hi, I found a tip here in the community I use when have high CPU usage or see NAS IS DOING SOMETHING AND i DON’T USE IT…

/etc/init.d/wdphotodbmergerd stop
/etc/init.d/wdmcserverd stop
/etc/init.d/wdnotifierd stop
/etc/init.d/wddispatcherd stop
killall crond off
sleep 1 on 5

It works!
Here the link => Very Slow Dashboard access on My Cloud Mirror 8TB 2 Gen

Much appreciated for the script suggestion.

This is what happened after I ran it. Looks like wdphotodbmergerd and wdmcserverd had trouble, but the rest were able to be stopped. I haven’t really noticed a difference in performance yet, but I’ll keep an eye on it.

Had been away from home for a few days, and while I was able to get into the WD Dashboard without issue, I couldn’t connect to Plex. Had to stop and restart the service.

I will make a post on the Plex forums tomorrow to start tracking the issue there.

To check the status of some deamons:

root@WDMyCloudMirror root # /etc/init.d/wdphotodbmergerd status
wdphotodbmerger is not running.
root@WDMyCloudMirror root # /etc/init.d/wdmcserverd status
wdmcserver is not running.
root@WDMyCloudMirror root # /etc/init.d/wdmcserverd info
wdmcserver (Build 09-Sep-2018 19:56:40)
root@WDMyCloudMirror root #

root@WDMyCloudMirror root # /etc/init.d/wdnotifierd status
wdnotifier is not running
root@WDMyCloudMirror root #
root@WDMyCloudMirror root # /etc/init.d/onbrdnetloccommd status
onbrdnetloccomm is not running.
root@WDMyCloudMirror root #

########## IN STATUS RUNNING ###########
root@WDMyCloudMirror root # /etc/init.d/wdtmsd status
wdtms is running
root@WDMyCloudMirror root #

root@WDMyCloudMirror root # /etc/init.d/wdappmgrd status
wdappmgr is running
root@WDMyCloudMirror root #

root@WDMyCloudMirror root # /etc/init.d/atop status
atop is running
root@WDMyCloudMirror root #

root@WDMyCloudMirror root # /etc/init.d/restsdk-serverd status
restsdk-server is running
root@WDMyCloudMirror root #

If some of process are not killed… kill it manual

Check and verify that they are indeed stopped:
ps aux | grep wd

kill -9 (PID/process number)


I did confirm that the processes that we attempted to kill earlier were still killed. The processes that you noted as being In Status Running, I was able to kill manually.

I have noted that CPU usage is down below 10% according to the dashboard. System RAM (512mb) usage continues to be between 50%-75%.

Those are the kinds of processes still running after the kills we made.

Is there anything further that you can suggest that we do? Or is this as lean as we can make the device when Plex is installed and running?

To kill a process you need to use the “PID” number… is not the correct way…
put on google: how to kill process Linux, and see how to do it…

I see is normal use now. Memory use is correct, PLEX is a server use and it consume memory. If you whant to see a bette rperformance, disable Plex, and see how it works… in any case this NAS use old app. Is a HOME use low profile NAS… if you need more performance i suggest to buy other …

DiskStation DS220+