My Cloud home not letting multiple files move across from Macbook and Mycloud.com server down?

Hello all. Firstly please excuse my naivety when it comes to this, I am not very ‘in the know’ about it. I bought My Cloud Home approximately 8 months ago from the advice from friends and PC store colleagues.

I bought the storage for me and my partner to use as we work on many projects together and we need to look at the same files etc. Her Macbook has terrible built in memory so she uses the Cloud to dump files on and clear them from her Macbook storage.

Recently (1+ months) she has struggled using our home device, if she tries to move several files at one time it will freeze and eventually fail. “The Finder can’t complete the operation because some data in FILE NAME can’t be read or written (error code - 36)”. Panicked at first and thought we must have some dicky files but can move them across fine if it’s one by one and the FILE NAME is always a different file. Surely it cannot be random. She is running macOS High Sierra.

FURTHERMORE tried to come online to sort this today and the MyCloud.com sign in is down, is says the server is down but when I check on service status is says it’s all online.

Does anyone have any advice on how to solve this. It is really affecting our work as she needs to free up some space on her Macbook urgently.

Many thanks.

@saz247 Have you tried this, http://www.mycloud.com/#/ .