My Cloud failure - physical drive or enclosure/board? Recovery?

Until recently, my (3GB) My Cloud was working well enough (some remote access issues, the usual). It is about 25 months old and I had it on the “sleep” setting with the front LED turned off.

When I tried to access it last via a WD Live TV media player, the player said that the “source” has moved. This usually happens in the (very rarely) event of power failure. I tried accessing the drive from my Mac, but it didn’t show up in the finder, nor did the “WD Dashboard” work. I then unplugged the drive and plugged it back in.

After doing this, the front LED still did not come on - also the back Ethernet LEDs. I could hear the drive spinning up, with the usual noises it/any working HDD makes, but no LEDs.

  • It is not the power adaptor (checked with another WD adaptor).
  • I opened it (out of warranty anyway) and put the drive in a USB case - my Mac did pick up the drive (but it is obviously a different file format - ext4, so it can’t read it), and asked to “initialize” the drive. I then ejected the drive.

So what can be possible causes/scenarios of this?
1. Has the drive failed?
a) is it worth it to send the drive for data recovery, and if so, what is the difficulty of the recovery? Anything to keep in mind?
2. Has the casing/controller board failed?
a) Can I purchase another 3TB My Cloud and just swop the boards out?
b) Can I put the HD in any other WD Cloud product (i.e. EX2) and be able to access the data?

The point is what is the best way to get access to the data back, for both scenarios.

Any help/assistance/guidance would be tremendously appreciated thanks.

Use the forum search feature, magnifying glass icon upper right, the subject of recovering data from a My Cloud hard drive has been discussed extensively.

One can remove the My Cloud hard drive from the My Cloud enclosure and using either a USB to sata adapter/docking station or using a spare SATA port within a computer, one can access the My Cloud hard drive contents using a Linux boot disc/live CD (, or using Linux drivers for Windows from Paragon (

I think it’s far more likely to be #2, since your MAC can “read” the drive. If only the drive fails, the front LED will still illuminate, but will never go “blue” because it can’t boot up. The network LEDs won’t illuminate because the OS won’t load.

You can get the data back fairly simply using your Mac, as long as you install support for the EXT4 file system.

Thanks I am just first trying to get an opinion or two to see if it is the drive or the enclosure/board so I can get a starting point from where to go/search/action - I have done a few searches in the forum prior and I am still to find one with similar circumstances (dead LEDs), so by process of elimination I am trying to solve this.

Thanks I will check it out and see if I can find something that will support EXT4 on a Mac.

Did you try the 40 second reset?

No I didn’t - but will give it a try thanks.

I can try the Mac version of Paragon. I was just under the impression that My Cloud drive might be encrypted, and I also read somewhere else that the controller board has a decryption chip for the drive.

The My Cloud doesn’t do encryption, so you’re OK there…

1 Like

We really can’t tell you that remotely, I’m afraid. Now that you’ve got the HDD out of the case, go for the recovery methods Bennor pointed to. If you can get to the data, the HDD is okay, and the problem lies elsewhere.

Have you checked the router (reset, try different router port, try different cable)?
Have you checked the MyCloud’s IP address hasn’t been changed by your router?
Have you tried a 4-second, or 40-second reset?
What were the ethernet port LEDs doing before you opened the case?
Have you changed your ISP/router to AT&T Uverse?

I’d have done all of these before cracking the case.

I took the drive to a data recovery company. They said the My Cloud circuit board has failed, and there is also an issue now on the drive as well (suspected electro-magnetic failure) due to the failed circuit board. I will take it for a second opinion as well. The My Cloud is just out of warranty, which is not great.

Did you try the Paragon extfs driver on your Mac to access the drive?

Yes. Also booted computer with Ubuntu USB. The drive “shows”, but it is not accessible.

Seems the MyCloud’s infamous “sleep-wake-sleep-wake” option works as intended. It broke down the box. :wink:

You shluld check the warranty on the disk drive.

Okay; sounds like the disk is dead.

Dare I say ‘backup’…?