My Cloud EX2 Ultra collapsing, nothing seems to be working properly

Anyone else still having issues with Cloud access?

I opened a case with WD, after a few back and forth emails they called me, rep. said my ISP needs to open two ports (443 and 8443). Called ISP, they will only do it if I use their router.
I don’t remember ever needing to call ISP to open ports for my NAS, it worked perfectly fine before the outage, now it won’t allow access from outside the LAN. This really pissing me off.

Is anyone else having issues after the outage?

Sounds like a typically uninformed WD support response. Have you tried the 5 second reset and the 40 second reset? My single bay 2nd gen MyClouds (same gen and FW as your Ultra) are all working fine after the outages earlier this month.

Pardon my ignorance - what are the 5 and 40 seconds reset? I did unplug it from power for about an hour, which did not solve the problem. I will be happy to try anything, short of losing the 2TB of data that I have on it.

Won’t lose your data with either of these

If I do the 40 second reset, it does not delete the Data but it deletes the users. So what happens to all the data that is currently stored per user? Under which folder will it be and how do I “distribute” the data after re-boot to the new users?

Sorry, can’t help you there. What does the online manual say (the reset information is there, too) and the second video, below:

I have same problem with my EX2 Ultra. Cloud is Disabled and when I try to enable it by connecting it to my admin account in Cloud configuration panel, i get error 1002 but there is no problem in my network, using DHCP, same settings like before the attack to WD abd everything was worikng properlly. At this moment I am only able to acces to my files in my LAN but os5.mycloud says that my device is offline. I also did 4s restart and still same. Do you think there is problem with my device just global problem of multiple users after cyber attack to WD?

I did Restoring systems factory settings. There was info that it will not affect my data but after restoring my data are gone! what the ■■■■?

@romanskripek - there is no doubt in my mind that there is nothing wrong with your device. It is too much of a coincident that after a massive outage, more than one device will go bad out of nowhere. It has to be something on WD’s end.

I just read your 2nd post. Were you able to map the drive and the data is not there?

Before restoring system settings i was able to manipulate with my data in my LAN but after that there is only “Folder is empty”
Yeah now I can see in admin panel that after restoring there is not RAID version set but after setting raid it will wpe my whole discs

Which RAID did you have? You need to “rebuild” the RAID, not setting it up. Were you able to map the drive in a PC?

Using File browser on my PC i can only see that the folder is empty. I am not 100% sure about the RAID, it was RAID 1 i think

Are you 100% sure you did System Only Restore and not full? If so, and the data is lost, this is a royal Eff up by WD.

Before restoring default system there was popup window saying that this action will not affect stored data

I am not an expert on this, never reset/restored my EX2 Ultra, I am pretty sure the data is there and it’s a matter of setting it up correctly after the reset.
When you are on the Dashboard, how much available space do you have and what kind of HDD (size) is installed?

Yeah, I contacted support and he also wrote that there is no way to wipe discs by 4secs restart o reseting system default settings. Now i sent them my logs so we will see. Thank you for your time.
Btw. 8TB total ( 2x 4TB WD Purple)

Does it show you have 4 TB available in the dashboard when you login, here?


Before restore there was 3,6 TB for 100% so it must be RAID 1 and now i can se 0 kB free :smiley:

I wish they had specific instructions on how to do the reset. I can’t even find a proper and detailed .pdf manual, absolutely ridiculous. I am actually looking to buy a new NAS altogether, can’t waste my time and risking my data with this incompetent company and customer service that blames the closed ports of my ISP.

Keep us posted.

@romanskripek - I spoke with WD support yesterday and they assured me that a 40 seconds reset, which is the System Only reset that you did, with EX2 does not touch/delete data. It does with other storage devices but not EX2.