My Cloud EX2 Ultra collapsing, nothing seems to be working properly

  1. I am trying to re-enable Admin Cloud Access and keep getting this error:

  1. I am trying to login to My Cloud app on Android, it asks me to enter my first and last name and then I am getting a message “Something Went Wrong”

  2. Trying to back up to a USB drive, I go to Apps and the page is empty, blank. There are apps installed on this device but nothing shows up:

  1. I am not receiving System Emails even though two email address are set up and it is set to All Alerts.

Is Western Digital collapsing or is it something in my EX2?
Any solution or is it time for me to look for another NAS?

BTW - this happens in different browsers and different computers, so it is not a specific pc/browswer issue.

Thanks in advance.

Same problem here. I just tried to access via the (latest version of) the MyCloud app for iOS and suddenly it’s asking me for my name, but won’t accept any input. All I get is “Something went wrong”…

same problem here since today

@WD_Admin - looks like you have a system wide problem. Are you aware of it?

Thank you @matejvc .

I wonder where their statement and future updates are because I don’t see it. It would be nice of them to post something here and not let their customers scramble and worry about their data.

So Status Page shows problem is solved and all systems are up and running, but not really. I am still unable to log back in to my Admin page, still don’t see any apps, same exact behavior as I reported in the original post.

Works fine on a ex4100

Not with EX2 Ultra.

Can anyone else with EX2 Ultra share their experience after system is back up?

My experience is that the drive is currently unable to show me any of my files, says there’s no space but also is empty. No cloud connection - error when trying. Cannot update firmware.


@Wakoefiilms - Thanks for the update. Are you on EX2 Ultra?


In my case I cannot access to my EX2 ultra

No Ping response but all leds are blue

Solved, apply first rule of TI :grin:

Unplug 5 minutes and restart

All is working fine now

It may have cleared the wrong reading, but it did not fix my issues of unable to Sign In Admin to Cloud access, the missing installed Apps, etc.

Anyone else still having issues with Cloud access?

I opened a case with WD, after a few back and forth emails they called me, rep. said my ISP needs to open two ports (443 and 8443). Called ISP, they will only do it if I use their router.
I don’t remember ever needing to call ISP to open ports for my NAS, it worked perfectly fine before the outage, now it won’t allow access from outside the LAN. This really pissing me off.

Is anyone else having issues after the outage?

Sounds like a typically uninformed WD support response. Have you tried the 5 second reset and the 40 second reset? My single bay 2nd gen MyClouds (same gen and FW as your Ultra) are all working fine after the outages earlier this month.

Pardon my ignorance - what are the 5 and 40 seconds reset? I did unplug it from power for about an hour, which did not solve the problem. I will be happy to try anything, short of losing the 2TB of data that I have on it.

Won’t lose your data with either of these

If I do the 40 second reset, it does not delete the Data but it deletes the users. So what happens to all the data that is currently stored per user? Under which folder will it be and how do I “distribute” the data after re-boot to the new users?