My Cloud 4tb Flashing Red Light

Hi all, Typical first post on the forum when something goes wrong :slight_smile:

I was hoping someone might be able to point me in the correct direction…

I’ve had my mycloud 4tb device for about 12 months or so and had no issues and use it for general backup of data and file sharing between the PC’s in the house.

Today I think one of the kids has knocked the device on its side from its upright position and now all I seem to get is a blue flashing light for about 20 seconds then it goes to a flashing red light. The device is not appearing on my network I have checked the Ethernet connections and that seems fine with both lights flashing. I have also tried the 4 second and the 40 second reset neither seem to do anything.

Anyone any ideas how I can get it device back up and running or at least get some access to the data stored on it?

It does sound like physical damage. You may, if you’re lucky, still be able to recover data:

Thanks for the feedback, im going to have a propper look at this tonight when im home from work.
Last night i manage to get the drive appart and wired into my pc via a sata connection. I can see the drive in the device manager.
Then had my first attempt at creating a bootable usb with ubuntu but seems to stall part way through loading. Is there a simple third part piece of software that should identify the drive for viewing from windows? Or am i best off trying the ubuntu route again.

The link above that cpt_paranoia posted contains the following link to teh Paragon Windows software that will allow Windows to read the My Cloud drive.

Using Linux (Ubuntu or similar) is generally the preferred method when unbricking since it allows one to read/write to the My Cloud drive and use various Linux tools to possibly fix certain drive issues.

Thanks again, not having much luck with the 3rd part programs just given then a quick try extfs doesn’t seem to see the drive at all then tried another application called “Disk Internals Linux Reader” that sees the drive but labels it as empty… Don’t think its looking good, just going to try creating the USB boot drive again.

Not sure which USB boot creator you are using but in the past I’ve found that once in a while a USB boot drive created with one USB boot disc creator wouldn’t work but would with another one. Here are two USB boot creators I’ve used in the past.

Universal USB Installer:
LinuxLive USB Creator:

When one doesn’t work, I use the other.

I suspect that means your disk is FUBARed.