My Book World disappearing from network


I’m having a problem with my My Book network drive, where it keeps disappearing from the network, and hence is unaccessable. The router is showing it connected as a cabled connection & it’s allocated an IP address, but next to the address it’s has “UNKNOWN” as it’s network name. When connected properly this reads “MYBOOKWORLD”. The only way to get it to reconnect is to pull the plug & reset the disk drive. After this it’s accessable & remains so for approx a day before it disappears again ! Prior to this problem, I never had any issues. Disk was on 24/7 (as was the router) and it was always accessable. What I have noticed is that the router has given it new Ip address - was .02 and now it’s 06. We had a few extra devices connect recently, so I’m wondering if it’s something to do with that ? Would it help if I allocated it a static IP address on the network, as I don’t need to turn it off, so it’s the address should the same regardless.

Thoughts ?

Do you have the dual drive unit or the single one?

Is it the white light or blue rings model?

This could be either a connectivity issue or a hardware failure.


I think it’s a single drive unit & it’s the white light edition. I’ve now had it on, without incident, for about 2 days now. Can’t work out what has went on ! Is it worthwhile setting it up with a static IP address ? Do you do it on both the router & the disk unit ?

Exact same thing happening with my unit.

single drive edition

Error message on connection:   An occured while reconnecting to X:

The network path was not found

Marginwalker777,  you’ve had some look by ‘reset’ ?

I’ve tried powering off and on again, but this does nothing.    there’s a small ‘inset’ reset looking button at the back of the drive.   do I press this after a reboot?




I have the same problem here with MyBook world edition white, which is really strange is that it happens to several people at the same time!!

I have set IP in static it seemed to work but the day after it disappeared. I have to power down then up the NAS to recover it.

Cheers for the repsonses. Since I posted this - not a problem !!! Will need to just make sure everything is backed up & and keep an eye on it.


I have the same problem with my WD My Book World Edition 1To (white ligth).

I loos the access every days…  If i reboot them, the access is on agin… for 1 day max :frowning:

This is the error in the log file :

2014/01/22 07:56:25  read_data: read failure for 4 bytes to client Error = Connection reset by peer

Can you help me ?



Hi! I have the same problem with my world edition II white light dual drive. After a few hours, the NAS became unaccessible, it´s impossilbe tuo access via http or ssh too, only response to ping!!!

If I power off and then power on by button, the NAS became accessible again!!!

Please, I need help!



I had the same problem I ended up stoping twonky via command line my white light has not a problem since.
I am trying currently to have it only scan videos, not the music or pictures I am thinking there is to much to scan, for sure it’s twonky hanging it. Oh no problems for 2onths with twonky disabled after it’s enabled I am lucky to get one day out of it,


Same issue for me.

Strange, no changes for few months and suddenly …

I will try remove Twonky

Any other solution ? as I don’t understand why there is an issue now !!

Hi, same for me. I have the 2 worldbooks with 1 drive and one worldbook with 2 drives. All of them are white lights and when one of the worldbooks stops, the others are not accessible anymore. I hope there will be a solution because I like worldbooks…


I have been searching for a solutionfor a couple of weeks now.

Stumbled across this and seems to have worked. Hope it helps someone else.

In a browser go to your mybookworld IP (192.168.0.x)

Log in

Advanced mode (at the top right)


Scroll down to “HDD Standby” and uncheck “enable”


This, so far has worked for me, my drive was discoonnecting after 2 hrs, just gone 30hrs fully connected and showing “mybookworld” as a network drive, previously “unknown”

Good luck


I have the same problem since a weeks ago. I also upgrade my firmare to the last one, but the problem persists.

I’m going to try the solution provided by Dobbski, and see if it works


I think I found something. I have a network with a switch after the modem. When I use the modem as wireless acces I have to reset my Worldbooks 2 till 3 times a day. Now I use an extra router for wireless acces and switched off the modem’s WIFI, I didn’t have to reset for 2 days .

My modem is a Cisco EPC3925…


After two days, again the disk disappear from the Network, so the solution proposed by Dobski doen’t work at all. We must find another solution.

¿Does anyone have more ideas?

I think I found something. I have a network with a switch after the modem. When I use the modem as wireless acces I have to reset my Worldbooks 2 till 3 times a day. Now I use an extra router for wireless acces and switched off the modem’s WIFI, I didn’t have to reset for 2 days . My modem is a Cisco EPC3925… Har

For me this was the rigtht solution. I didn’t have to restart my worldbooks for one time again… Yippee

I’ve been experiencing the same this over the past month or so. I have two white 2TB World editions and they both go down at the same time. Sometimes can ping them, but other times not, and sometimes intermittently.

They are both set to have static IPs and are two switches removed from the router (BT Homehub 4 on Infinity).

Updated the firmware on both, removed all media from Twonky … not sshed in and disabled it yet.

Still no joy.

Thought ID revisit this as previous attempt unsuccessful. Drive was lasting 30 mins on server without activity

Did some googling and tried the following

  1. Moved drive from direct lan into router to a switch

  2. Stopped Mionet

  3. Enabled HDD sleep

  4. Enabled led lights

  5. Disabled iTunes

To be honest I think the disabling of te iTunes might be key as it was scanning every 30 mins

So far been up for 16 hours

Will update

Fingers crossed


Disappeared again so unchecked the enable HD sleep and has since been up and accessible for 2 weeks

Hopefully sorted, iTunes seems to be the culprit

When iTunes seems to be the culprit, did you try to enable HD sleep again? This would save some enrgy costs, wouldnt, but  IMHO HD sleep should be more the problem than iTunes.