My Book: Suddenly not recognized


#1

Hi folks,

A friend of mine has given me his My Book to test for him. Suddenly his computer has stopped recognizing it. I also can’t see it on my computer with a different cable and power source (they work fine for my own My Book).

I’ve tried to check though the forum for a solution without much luck.

Here’s some more info…

It doesn’t show up in My Computer or Disk Management
However I can see it in Device Manager under Disk Drives and also in USB device viewer - (output log below)…

Has anyone got a suggestion for getting this working again?

          —===>Device Information<===—
English product name: "My Book         "

ConnectionStatus:                  
Current Config Value:              0x01  -> Device Bus Speed: High
Device Address:                    0x03
Open Pipes:                           2

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x81  -> Direction: IN - EndpointID: 1
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x02  -> Direction: OUT - EndpointID: 2
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Device Descriptor<===
bLength:                           0x12
bDescriptorType:                   0x01
bcdUSB:                          0x0200
bDeviceClass:                      0x00  -> This is an Interface Class Defined Device
bDeviceSubClass:                   0x00
bDeviceProtocol:                   0x00
bMaxPacketSize0:                   0x40 = (64) Bytes
idVendor:                        0x1058 = Western Digital Technologies, Inc.
idProduct:                       0x1100
bcdDevice:                       0x0175
iManufacturer:                     0x01
     English (United States)  "Western Digital "
iProduct:                          0x02
     English (United States)  "My Book         "
iSerialNumber:                     0x03
     English (United States)  “202020202020202020202020202020”
bNumConfigurations:                0x01

          ===>Configuration Descriptor<===
bLength:                           0x09
bDescriptorType:                   0x02
wTotalLength:                    0x0020  -> Validated
bNumInterfaces:                    0x01
bConfigurationValue:               0x01
iConfiguration:                    0x00
bmAttributes:                      0xC0  -> Bus Powered
MaxPower:                          0x01 =   2 mA

          ===>Interface Descriptor<===
bLength:                           0x09
bDescriptorType:                   0x04
bInterfaceNumber:                  0x00
bAlternateSetting:                 0x00
bNumEndpoints:                     0x02
bInterfaceClass:                   0x08  -> This is a Mass Storage USB Device Interface Class
bInterfaceSubClass:                0x06
bInterfaceProtocol:                0x50
iInterface:                        0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x81  -> Direction: IN - EndpointID: 1
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00

          ===>Endpoint Descriptor<===
bLength:                           0x07
bDescriptorType:                   0x05
bEndpointAddress:                  0x02  -> Direction: OUT - EndpointID: 2
bmAttributes:                      0x02  -> Bulk Transfer Type
wMaxPacketSize:                  0x0200 = 0x200 max bytes
bInterval:                         0x00


My Book not recognized in Windows
#2

I, too have the same problem…all of a sudden, one day I plugged in my My Book…and nothing!  I tried 2 different laptops, changing out cables, and absolutely no recognition at all…what gives…?  Can anyone chime in with a suggestion…?  Also, respectfully, should the fact that no one has chosen to respond to the first post in over a week  make me uncomfortable about the effectiveness of this board…?   We both need help from someone…any help at all…in my case, I have precious data that I have trusted to this device…hope you’re out there…

                  Thanks in advance,

                              d


#3

I have the exact same problem and it’s very frustrating. Please help us!!


#4

When troubleshooting any detection issue, the problem lies with the drive, the data cable, power, or the computer.  Does the drive function on any other computer?  If not, what happens if you change the data cable?  Do you use the bundled power supply?  If so, do you have another one from another WD external that you can use with the drive?


#5

@ WDJeremy

Everything you’ve asked has already been stated in the first post of this thread.

The unit has been tried on a different computer with a different data cable and power source from another functioning My Book. What happens  is clearly explained above.


#6

If the issue follows the drive, unfortunately, the only thing left to do is to replace it.


#7

and what about the 300 plus gigs of backup on this drive. I have a different problem.  My computer and my laptop and my office computer recognizes My Book for about 5 seconds and then dosen’t for 5 seconds then does etc etc etc.  I can;t get all my backup files from it.  You will say just replace it.  WTH.  If this is the way you treat your WD customers I will never buy a WD product again.


#8

I apologize but if the drive isn’t working properly, you will need to replace it.  We have no data recovery capabilities ourselves but we do have a list of data recovery partners in the link below:

http://support.wdc.com/recovery/index.asp?wdc_lang=en


#9

WD needs to do a lot more than apologize.


These unit shouldn’t be failing for so many users after such a short period of use (in our case just over a year).


They need to acknowledge they’ve distributed a faulty product. Arrange for our data to be recovered free of charge and return to us a fully functioning unit.


#10

We can replace any drive that fails within its warranty period.  However, our warranty policy does not cover the data stored on the drive as it only covers the drive itself.  You can find a complete copy of our warranty policy through the link below:

http://support.wdc.com/warranty/policy.asp?custtype=end&lang=en


#11

Mine is now doing the same thing, still have 743 days left on my warranty. Is the “WD SmartWare” software compatible with the “My Book Home Edition 1TB” unit. I have used almost 700GB on my hard drive and can’t afford to be without out for any period of time for Data Recovery. I can back everything up back to my hard drive on my desktop if i can get access to the unit.


#12

SmartWare is incompatible with the MyBook Home since that drive lacks the hardware that SmartWare relies on.  If you have narrowed your issue to the drive itself, you will need to replace the drive.


#13

The flip side of that is i can read the drive on my Xbox 360, and it appears that everything is still on there. I am going to connect the eSata cable direct to my motherboard and see what result i get from that. I have used different USB cables in trying to eliminate something. But the USB cables both work on my Xbox360. I’m stumped, hopefully the eSata cable will sort it out.


#14

Well it is official. My WD Book 1TB drive is not being read at all. I have tried numerous power cables and USB cables all in different combinations and all i can tell is that it is stuffed. Like i said in a previous post. The Xbox360 will read the drive, but so far 3 different pc will not. My next step is to try and recover as much as possible through the Xbox and format the drive. This is really annoying.

Come on WD, lets get some tech help on this stuff. In this day and age you would presume there is some sort of fix especially considering we can get firmware updates regularly for these products. 

Anyways, I’ve vented what i had to and i am now building a bridge.


#15

I also have the same problem, this is one of the worst things I have bought for my computer since the very first days it’s been failing time after time it’s the most unstable software I have ever seen, (and I thought windows was bad)

Sadly I also see these people here don’t care for the customer service they seem to be into marketing and sales.

I’m really disappointed and somehow angry as well.


#16

mgomezmayorga wrote:

I’m really disappointed and somehow angry as well.

My exact feelings…

Here’s some more to my story…

My friend and I both bought a MyBook and WD Media Player each at the same time,  around a year ago. My Media Player was completely dead within three weeks. Living in Spain, I would have had to send it to France and pay the freight claim a new one. Fortunately, I eventually persuaded the shop to do a straight swap. My own My Book has never really worked properly. I bought the eSata model specifically to transfer data quickly. Guess what, when connected by eSata my computer constantly crashes. So back to USB (after wasting 15 euros on a good quality eSata cable that didn’t come with this so call eSata device!). Even when connected by USB the stupid thing doesn’t really work properly and won’t shut down when the computer is put to bed…

In summary: 4 units bought from WD - 2 completely dead within a year and 1 that’s never worked as advertised.

All WD can do is make some canned response to my post one week after I initially posted asking me all the things I’d already stated (in other words didn’t even have the courtesy to read my post before responding) and then follow up with an oh-well it’s stuffed, you’ll just have to replace the drive.

It’s disheartening to see how large companies like WD have such little regard for their clients. No REAL support. Obviously DEFECTIVE products being pushed out into to the market place and all they can do is hide behind a link to their “warranty policy”.

It’s ethically wrong…

I for one will never buy a WD product again and will be sure to warn others of this none to happy experience…

I wonder how long it will be before someone makes a WD equivalent of United Breaks Guitars


#17

I just came to the website to see if anyone had any solutions to this problem. I bought my external harddrive last year. It sat in the box for months before I opened it and started using it. I saved all my important files, pictures, music, e-books, etc on it and then over the weekend my PC started acting up to the point that  the hard drive needed to be replaced. That happened yesterday. I spent last night moving my files back to the PC from the external. Only did several files then decided to save the rest for today. This morning, I started transferring my music to the PC and it got down to 35 minutes when it flashed a quick error message then shutdown. I unplugged and replugged it in and got a message saying the external hard drive could not be recognized. I thought it was the PC so I called tech to tell them but everything else we tested in those ports were all recognized except for My Book. I tried it on the laptop too, with the same results. Not recognized. I’m frustrated that this external, that was supposed to be my backup so that I don’t lose important files seems to have gone *poof* in less than 2 years.


#18

So WD, are you guys actually reading these posts or not? If not, lets just close the WD community site down. ie: the word is “Community”, while the “community” is trying to help each other out to solve a problem, it seems that WD might have just closed their eyes in relation to it. If you guys can’t see there is a problem, i am personally wondering why any of us should buy another WD product? 

So on another note, if anyone is interested in buying a slightly used but still within “warranty” 1TB external My Book hard drive, (did i mention it doesn’t work), as well as a WD TV Live, which currently is working but i’m sure it will fail soon. Drop me a line and we can sort something out. Maybe WD might even freight it for free. “Maybe”.


#19

You guys are making me want to take mine back, I just bought it yesterday at Wal-Mart for 55 bux, it’s the 500 Gb drive, First thing I noticed was the preinstalled software on the drive was junk, I did not like the way it seemed to want to do backups of what it thought it should back up, So I came to their site and learned they had new firmware that claimed to make it work faster, and new Software that claimed it was better, Well after installing that junk, nothing seemed any better to me, so I reformatted the drive using Win XP then all that was on the drive was System Volume Info, And I read and write to it as though it was just another HD on my system, but if I can expect it to fail, well, Who knows when, in you guys case a year, I think I will take it back, I though I was getting  a good deal because the drive was about 20 to 25 dollars cheaper than the comparible drives the same size, now I know why.

( Trader Sam )


#20

SOLUTION

This is truly one of the most apalling situations I have ever seen perpetrated by a (once?) respectable company.  It’s as if WD fired all their engineers and hired a bunch of people to read scripts and answer the phone.  How the @%^ can anyone at WD not at least try to help us get our data back?  Truly appalling.

SOLVED

I had about 10 years of tediously organized files that I had on this drive… in fact I purchased it at Best Buy specifically for this reason.  I’ve used WD for over 20 years, and believe it or not I still USE hard-drives over 10 years old, and less than 1 GB!   So I figured this would be perfect.

I had already known about the Volume-Policy->Safe Removal vs. Performance setting danger in Windows, so I set it up for safe removal.  Right out of the box I zeroed the entire drive and then ran it through SpinRite, followed by creating a partition table, partition, and filesystems, which is my Modus operandi for all new drives.    I never install the autorun ■■■■. 

One day I had to use XP SP3 for a gotomeeting, and at some point XP bluescreened due to a PAGING fault problem I am still looking into…    Upon reboot my whole drive was bricked!  WTF!  10 years gone!  Not quite.  Thank god for my past work in the security field, including data forensics.   I’ve totally bricked around 50 hard-drives in my day, all of which I still keep just in case… (bricked means they won’t even power up to spin).  So I knew that it was almost impossible that my drive got bricked in this situation…   WRONG!   First things first I carefully extracted the drive out of its black case so I could feel/hear/see what it was doing, and it was acting like it was bricked.  Sometimes after a reboot the blue light would come on, sometimes not.   After several soft and then hard reboots and seeing that, I went into panic mode and got serious.  

HOW I FIXED IT

Well the easiest way would have been to just directly write the backup of the drives partition table to the disk, which has to be exact match, and then just run a chkdsk, but I hadn’t set up backups yet.  Here are a few of the Live Boot CD’s I used (that failed) to fix it.  Using anything other than a live os to boot is dangerous as you could bork the filesystem and have to use a tool like ddrescue and go bit x bit.

  1. BartPE
  2. Avast Live
  3. System Restore
  4. Ultimate Boot CD
  5. Norton Ghost
  6. Partition Magic 8
  7. WinXP Recovery Console.

Finally after all those failed, I booted up the Gparted Live CD, a truly incredibly useful live cd (free), and finally I was able to see the block device of the disk.  Gparted uses the ntfsresize utility to do a poor-mans chkdsk, but it atleast made the partition table viewable again.    So first step:  Run “Check” on the device in Gparted.  You could also try resizing the partition just a tad, then reboot.

Windows is so dumb that it can only make it worse, so I stay away from Windows as much as possible until at least the drives are recognized and showing up again.  So then I booted up the latest version of Knoppix, which has really nice hardware detection.  I just booted into runlevel 2 (non-graphical) and made sure I could see the block device (if not I would just load more modules)  then I used the ntfs-3g utils and the ntfsutils progs to see how the ntfs data structure was holding up…   First I ran some ntfsfix commands, followed by some reboots, and also ntfsls, ntfsinfo, and had to force them to run.

At this point I could now see the device again, so the only thing left to fix was the filesystem on the device, just 1 giant NTFS partition.    Because I really couldn’t afford to lose these files, but I didn’t want to risk/pay to send the drive into a reputable disk-recovery company, I made an exact clone of the drive (which took forever) just in case I lost the filesystem.  

Then I finally booted up into Windows once more, using my custom safe mode option from my boot.ini

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=“XP3 Pro Safe Command Shell” /sos /noguiboot /bootlog /noexecute=optin /safeboot:minimal(alternateshell)

 

Once logged in as the Admin, I used the runas command to start the registry editor for the user I was logged in as when the problem happened.  That let me modify the commands that are set in the registry, in this case I wanted to force chkdsk to run for as many drive letters as possible after rebooting, several times until my lost drive was no longer a “dirty volume”.    Then I shutdown and rebooted.  After the chkdsk;'s finished, I again go into safe mode, but I replace the chkdsk with chkntfs to force recovery of the filesystem upon a reboot.  Then I reboot and run the recovery chkdsk a couple times.until ho errors are produced.   Next I disconnect the Failed drive and reboot , logging in this time in order to clean up the device database by hand.  

  1. First I set the global environment debbuging variable DevMgr_Show_NonPresent_Devices to 1
  2. Then when in devmgt and you show hidden files, you will see hundreds.  
  3. Next I plugin my failed drive and run chkdsk until no errors  are produced.

Did that twice and then I had what resembled a working filesystem once again.  But every so many boots/hours/days??? my drive would disappear entirely from the device database, and I eventually noticed it was being recognized as the generic “USB Device” or other generic driver.  Uninstall that, unplug the drive, and then plug back inand it usually works again.  

So it’s not hard to get the data back, if you happen to have over 60 hours of available time to do it that is.  What I’m doing as I am writing this, is I have moved the drive to my main linux (archlinux.org) machine and am copying the enitre 700+ GB’s I’m using too a HITACHI drive.  Once that 5 hour process is completed I might drive down to best buy and throw this WD hard-drive throught the front glass doors.    My reasoning is that if WD employees aren’t even bothered enough by massive customer problems and complaints all over the world to help restore lost data on these drives, it only makes sense the police wouldn’t care either enough to look at it either.

Honestly if WD sent me 3 new better drives for free, that would make me happy again, anything less than that and geez, how will they stay in business losing 20+year loyal customers like this…