My Book sleeps after just 60 seconds

My 4TB My Book goes to sleep 60 seconds after being accessed. WD Drive Utilities is set with the sleep timer OFF.

In the MacOS, I’ve tried unchecking “put hard disk to sleep when possible” and I’ve also used the Terminal to try setting the disk sleep setting to 0 minutes and 10 minutes.

None of this has made any difference. It still goes to sleep in 60 seconds. Of course, this causes frequent delays when everything jams up for three or four seconds every time I access the disk.

Any ideas what’s wrong?


M1 MacBook Air
Running Ventura OS
The disc is connected to a Twelve South Stay-Go hub, which connects to the USB C Mac socket.

If you have already checked the sleep timer settings in WD Drive Utilities and made sure it is turned off, and also adjusted the system-level sleep settings in macOS without success, there are a few other things you can try to troubleshoot the issue:

  1. Update the firmware: Visit the Western Digital support website and check if there are any firmware updates available for your My Book drive.

  2. Change the USB cable and port: Sometimes, a faulty USB cable or port can cause connectivity issues and trigger the drive to sleep. Try using a different USB cable and connecting the drive to a different USB port on your computer to rule out any potential issues with the current setup.

  3. Disable Energy Saver settings: In addition to the “put hard disk to sleep when possible” option, there are other Energy Saver settings that could affect the sleep behaviour of your drive.

  4. Check for background processes: Certain applications or processes running in the background can cause the drive to sleep prematurely. Check for any backup software, cloud syncing services, or other applications that might be accessing the drive and causing it to sleep. Temporarily disabling or quitting those applications/processes can help identify if they are the cause.

  5. Run Disk Utility: Use the Disk Utility tool in macOS to verify and repair any potential disk errors. Open Disk Utility (Applications > Utilities > Disk Utility), select your My Book drive, and click on “First Aid” to run the disk repair process.

  6. Contact Western Digital support: If none of the above steps resolve the issue, it is recommended to reach out to Western Digital’s support team directly.

By following these suggestions, hopefully, you should be able to troubleshoot and resolve the issue with your My Book drive quickly.

I couldn’t do anything about the firmware, because firmware is not mentioned on the “Software for My Book” web page, or anywhere else on the web site I could find. There’s a Universal Firmware Updater that was retired 2020, with no mention of replacement or how to deal with firmware updates.

HOWEVER, when I switched from the Twelve South hub to a USB 3.1 socket in my fancy EIZO display, the disk stayed on. It’s been running for 20+ minutes now.

Next, I’ll try to make settings to have it sleep after about 10 minutes of inactivity. Would you recommend doing that via the macOS settings or the WD Utilities app?

Thanks for your help!


Both options can achieve the desired result, but it ultimately depends on your specific needs and preferences. Let’s explore each option:

  1. macOS settings: macOS provides power-saving options that allow you to control the sleep behavior of external drives. This method uses the native macOS settings and does not require any additional software. It offers a simple and system-wide approach to managing power-saving settings for external drives.

  2. WD Utilities app: WD Utilities app provided by Western Digital for managing their external drives, it may offer additional features and customization options. Using the WD Utilities app allows you to have more granular control over specific settings related to your WD external drive. It might provide additional features and options that are not available through the native macOS settings.

Furthermore, if you prefer a simple and system-wide approach, macOS settings would be sufficient. However, if you want more advanced control and access to specific features provided by WD, you may choose to use the WD Utilities app.

Unfortunately, the behavior reappeared after a couple of hours. I went through all your other suggestions and it made no difference. At one point yesterday, it was powering up and down about every 20 seconds. It’s about six years old, so this is probably a good time to replace it. I don’t need all 4 TB, so I’ll probably go with a 2TB SSD, which are quite affordable now.

A possible solution you can try is to check the power on your Mac and make sure that it’s not set to put the hard disk to sleep when possible. Sometimes, even if you’ve unchecked the option before, it might still be affecting the external drive. Another thing you can attempt is to connect the My Book drive directly to your M1 Macbook air’s usb c port instead of using the twelve south stay-go hub. Sometimes, using a hub can introduce compatibility or power management conflicts.

In the MacOS, I’ve tried unchecking “put hard disk to sleep when possible” and I’ve also used the Terminal to try setting the disk sleep setting to 0 minutes and 10 minutes.

Since my M1 MacBook Air’s ports are just two USB Cs, and my Eizo display needs one of them, it’s not practical to use a drive that can’t work well through a hub.


I have encountered a situation with my 4TB My Book external hard drive. Despite disabling the sleep timer in WD Drive Utilities and adjusting the disk sleep settings on my M1 MacBook Air running Ventura OS, the drive continues to go to sleep after only 60 seconds of inactivity. This frustrating issue leads to frequent delays and disruptions whenever I access the disk, causing my system to momentarily freeze. The My Book drive is connected to a Twelve South Stay-Go hub, which then connects to the USB-C port on my MacBook. I am now seeking assistance to troubleshoot and find a resolution for this ongoing issue. Regards
Learn Bitcoin

I suspected the problem was my StayGo hub, and I soon found the disc turning on and off every 10 to 20 seconds on its own. (I wasn’t touching anything!) Then I plugged it into the hub built into my Eizo Display, and I still found it sleeping every 60 seconds. Also, Finder view of the disc was occasionally turning up blank. I had to unplug – replug the disk’s USB cable to get the files to show up again. It was getting scary.

So, since the disk was already about six years old, I replaced it with a 2TB Samsung SSD. That’s more than enough to hold my photos, and much faster, of course.

I don’t know if the problem was the M1, Ventura, or my particular set up. I am, however still suspicious of the StayGo, after seeing your post!