My Book Live Not Seen as "Computer" in Network

Hello -

Recently my drive disappeared from File Explorer to be able to drag/drop files (and the mapped drive no longer connected). I am working on a Surface RT running 8.1 (but I THINK the issue started before upgrading, but I can’t be sure).

Previously the drive was listed as a storage device and as a computer on the network. Double clicking on the storage device would open the Web UI to adjust settings, and that is still showing, but the drive has disappared from the list of “Computers” to allow me to access the files.

I have reset the drive according to the instructions linked below to try fresh, but it just ended up with more of the same. Interestingly the drive is seen on the network on my MacBook Air  allowing me to drag and drop files. However I need to transfer the files from the drive to my Surface.

(Instructions I used to reset drive using reset button on the back:

Any advice?

(Apologies if this has been asked or answered - I tried searching both the Knowledge Base and the Community, but didn’t see any answers)

You can try connecting to the drive via the IP address.

If the Mac is connecting to the drive, this means there’s something blocking the connection on the other computer.

Make sure to check the firewall and internet security.

Thanks! I was able to access it via the IP address. I tried right-clicking on Network and “Mapping Network Drive”, then manually typing in the address for the drive. This worked to access the files in Explorer.


Then it looks like something was blocking the access to the device.