My Book Live 2TB

Hi All,

I am now at my witts end, i purchased this for my son for Christmas and it is far from plug and play.

We keep getting error messages.

When we go to users.

32102 - Error retrieving user information: Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

Then when we go to shares.

33166 - Error retrieving share information: Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

When we go to Safe Points

35550 - Error retrieving safepoint list on selected network device: Internal server error. Retry your last operation. If the error persists, contact WD Support for assistance.

Basically the system does not work, the software told us about a firmware update which we ran before doing anything else.

The computer im sitting at now is my sons and it does recognise the unit.

Device Name:



Serial Number: [Deleted]

Usage: 7 GB / 2 TB

My son managed to put a video file on but that was through My Computer and drag and drop.

Im afraid that i may have wasted my money, any help would be appreciated.

1 Like

OK I think i have solved the problem, This product is not fit for resale purposes and does not do what it claims.

It is merely a network drive that is slow at best and does not function as intended.

I might as well just have another pc working somewhere.

As a Christmas present you would think it would at least be plug and play but no. its plug and try to get it to work.

I would like to recieve a return code please to take it back to PC World where it was purchased.

Very dissapointed as is my son who it was a gift for.!!!

I have had a My Book Live 2Tb for over a month and it is working fine.  It was a bit slow, due to connection to my old router, which had only 10/100 ethernet ports, but since installing my new WD AC 1300, which has 10/100/1000 ethernet ports, the performance is satisfactory and all PC’s on the network, plus an iPad 2 are able to access and stream from the drive.  Two Windows PC’s are able to back up to the drive using Acronis, Windows and WD back-up software.  It took a bit of doing to get all the network settings right.  I never expected a network drive to be plug&play.

Many Thanks for your reply,

I have been playing and now all computers in our house can see the drive in the public folder and access all of the files there, I.E pictures videos etc, i have also been able to create folders to copy some of the content from each of the computers to keep them safe as a back up and my son who it is for was able to put all of his music on there and and his videos he puts on you tube so that has freed up alot of space on his computer ( Im out of jail on that one now ).

So my first response may have been a bit hasty but we still keep getting all of the error messages if i try to use the dashboard bit.

He keeps asking about getting the app thing to work and i bought him a Nokia Lumia for Christmas as well

Any help would be appreciated as i am out of my comfort zone here.

Many Thanks in advance.

I am having the exact same problem.  I have tried to download updates, update firmware, reinstall the software.  Hardly any of the utilities work.

Any help would be appreciated.


Similar problems.

I can save and access files, but can’t access the utilities or users etc on the dashboard and can’t get remote access to work.

Trying to access:

users - error 32102

shares - error 33166

settings, remote access- error 31550

utiities - just hangs saying please wait.

Any suggestions

Exactly the same problem here - I followed the link to update the firmware when setting up the drive (2TB model), and it seems this rendered the administration interface defunct.


Description:My Book Live Firmware

Version:MyBookLive 02.32.05-046 : Core F/W

Last Update:Mon 07 Jan 2013 12:28:49 PM CET

Not sure if this is the right place to post this, since there is not a lot to discuss, just swift action needed from WD.

HI guys

not sure if you fixed it! i had the same problem, but found this on the internet. Follow it exactly! You may not see the exact same results but it does work

You can use putty from te web and I used the ip address to access it. All worked fine

Totally rubbish though for Western Digital to let that firmware be released!

Thanks for the hint, worked perfectly - the interface is fully functional now.

Only flaw that I can see is that the firmware version and date have not been reset, so I actually don’t know which version I’m running.