My book and time machine not working

I’m not very adept at this sort of thing.  I have an intel based iMac. and have had an myBook acting as my Time Machine on it.  The My Book is about 3 years old and has worked fine until now.

I moved and packed up and moved all my electronic things myself.  I plugged everything in yesterday and it all worked like a charm.  Even the MyBook as Time Machine backed things up.

Then this morning I got an error when Time Machine tried to back up.  I ejected the My Book powered everything down plugged it all in and the My Book blue light on the front blinks, then is steady then blinks.  But its not working as Time Machine.  

In my Finder it shows up as WD Smartbook under devices.  But when I click on the Time Machine icon at the top left corner of my desk top it says there is no time machine device?

Is the Mybook dead?


Check if the my book is recognized fine on the disk utility window. Check the link below to run test.

When I go to the disk utility it shows:

999.5 gb wd my book

and below that it says My Book

However on both of them the verify disk and repair disk are grayed out regardless of which one I hightlight.  And when I try and do a back up it says files can’t be copied to back up disk because it appears to be read only.  How did that happen that the My book is now read only?

It says I may need to repair or reformat the disk using disk utility.  Well because its grayed out, I can’t do that.  I have the worst luck with back up disks.  I’ve had 3 in the 6 years I’ve had my computer.  They just sit on the desk, so I don’t know why they keep dying.  The computer works fine.