Mislead -- No Hulu?

I just bought this and am I led to believe the unit does not carry HULU plus even though it clearly shows the logo on the box? I don’t see it anywhere in the menu at all. Something tells me I should have stuck with my instincts and bought the Net___ brand!!

If not – this thing goes back to Stapes!

It most definitely does support Hulu Plus.

Have you looked under ALL SERVICES (the little bell icon at the top of the screen).

… and do you live in a territory where Hulu Plus is “allowed?”


This is all I get … No “bell” icon visable either


I am in California



Sorry, yeah, it’s not a bell.   But you found it anyway… :slight_smile:

You’re actually missing THREE apps.

I have 33, you have 30.

… and you have an app which hasn’t existed in ages:  Deezer.

You’re also missing Pandora and two others.

Are you running the latest version, and have you tried resetting the box back to defaults?

I have the same issue – I just bought WD TV Play, and stright out of the box, Hulu does not show. I’m in Austin TX, using Time-Warner Cable, and running the latest firmware. 

I also have a WDTV Live, and on Saturday the Hulu I’be been watching for over a year disappeared from that box. Reverting to an older firmware did not recover Hulu; resetting all setting did not recover Hulu, and re-updating to latest firmware did not recover Hulu. 

Any ideas? Could Time-Warner have blocked Hulu? 

I have the exact same issue. Just set up the unit today, but no Hulu+.
Tried all kinds of regional changes and resets, nothing.
Any help resolving this would be immensely appreciated :slight_smile:

Found the solution!!

Simply change your time region to ‘central America’ , apply and then say ‘restart device’.

Done. Hulu and Pandora listed :slight_smile: