Missing Apps on TV Play

My TV Play is missing Hulu, Vudu, and Pandora from the app list. I checked all over the player and they aren’t there. I live in California so I should be able to access them. I tried resetting it back to defaults several times and even changed the time zone around to see if that would help but it keeps coming up with the same 30 apps. Im having the same thing going on as this previous post:  http://community.wd.com/t5/WD-TV-Play-Discussions/Mislead-No-Hulu/td-p/657119.

Firmware version currently running is: 1.05.47

with the model number being: WDBMBA0000NBK-HESN - which should be the US model according to WD.

If it mattter im using the Pacific Time Zone (US-Canada)

Anyone know what I can do, should I RMA or contact support? Thanks.


Have you tried performing a factory restore?

Check the link below.


My guess is that WD’s Geolocate system is placing you in the wrong territory.

Yes, I did try both of those methods and the same issue comes up.

I would say TonyPH is right, its geolocation.

Search for something called unblock-us.com and it will instruct you how to set static IP details for your network settings. It will also include how to set a static DNS from unblock-us which will change your geolocation if this works then whatever your geolocation is showing is wrong.

Let me know how you get on, I can write better instructions if your unsure. 

Can you please add instructions to alter dns with un block us for the wd play. I got it to work with my pc but I can figure it out for my play, the website does not include specific detailfor the wd play.