MBLD Getting New Harddrive with different type / version (Red, purple)

I have a WD Mybook live Duo with mirroring mode (RAID1), and now both hard disks are physically damaged, I am trying to buy a new hard drive with the same specifications as the previous hard disk (WD Green 3TB 64MB cache), but I have trouble finding wd green in my city (SEA-Indonesia), and I can only get one hard drive of the same type, is it possible to use a different type of hard drive (WD green + WD Red) even with the same capacity (3TB) in my MBLD?

Thanks, all the help will be appreciated

Unfortunately, it appears the answer is No.

Important: Replacement hard drives must be an exact Model-for-Model match with the hard drives originally shipped with the device from the factory.

For example: A WD Green model WD30EZRX-00SPEB0 must be replaced with another WD Green model WD30EZRX-00SPEB0 to function properly.

https://support-en.wd.com/app/answers/detail/a_id/20504

Thanks for the reply, I really appreciate it, but what if I replace both hard drives? so i will get rid the WD Green then using 2 x 3TB WD Red instead, is it still possible? (WD green is the default HDD when i buy for the first time)

If WD have stated that it must be Model-for-Model … then that would apply to all of them. (i assume)

Anyways, there’s not much info out there with people trying it … because it’s a risk and not to mention an expensive experiment to see if it works or not.

Only one way to find out for sure.

Let us know how the experiment goes.

Alright then, thanks so much for your help, I’m not sure I’ll try it anytime soon, but if it works, I’ll post here the details, sorry for bad language.

I am about to replace my 3tb green drives with reds. I’ll post my results. Drives come in Thursday.

I am also interested in swapping a fault WD GREEN drive with a RED one.
Crashandburn, any news?

Oh yeah. Sorry I moved on to other projects. I replaced my drives with 3tb 5400rpm red drives with no problem. I chickened out on trying larger drives. I replaced 1 drive and let it run the initialization process and then replaced the 2nd drive and let it do its thing again. Back up and running with 6tb. The one odd issue I had was even though this is all on my home network, trying to copy data back and forth put me over comcast data limit for the month even though it is all within my home. I am going to keep using my mbld but have started to look into a plex nas system for a future upgraded. Good luck.

I’ve tried the steps on below thread, it works to expand my 6TB MBLD to 12TB :slight_smile: