An easier way to increase MBLD capacity

DISCLAIMER
Be aware that this will void your warranty and is only to be used as a last resort when you have no dashboard or SSH
I am not responsible for any loss of data as a result of you following this guide
PROCEED AT YOUR OWN RISK


I own a MBLD 4TB and recent I found one of it’s hard drive has bad block, so I want to replace the hard drive to a larger size.

To ensure the new disks were compatible, I read a lot of articles especially the debrick guide from @nfodiz

As my MBLD is not so bad, not bricked, so I find there is a easier way to replace the hard drives:

  • Backup your data
  • Prepare the new hard drivers, I purchased two 4T Red disk
  • Shutdown the MBLD, replace one disk with the 4T one
  • Reboot MBLD, it will rebuild the raid to new disk, although it can only recognize 2T capacity, we will fix it later
  • Shutdown MBLD and replace another disk, reboot and waiting for raid rebuild
  • Now you have the new disks ready, but the device still show only 4T capacity in total
  • Enable ssh from /UI/ssh
  • SSH login, and execute parted (an linux tool which can modify the partition table)
  • In the parted prompt, you should see something like below:

(parted) print list

Model: ATA WDC WD40EFRX-68W (scsi)

Disk /dev/sda: 4001GB

Sector size (logical/physical): 512B/4096B

Partition Table: gpt

Number Start End Size File system Name Flags

3 15.7MB 528MB 513MB linux-swap(v1) primary raid

1 528MB 2576MB 2048MB ext3 primary raid

2 2576MB 4624MB 2048MB ext3 primary raid

4 4624MB 2000GB 1996GB primary raid

Model: ATA WDC WD40EFRX-68W (scsi)

Disk /dev/sdb: 4001GB

Sector size (logical/physical): 512B/4096B

Partition Table: gpt

Number Start End Size File system Name Flags

3 15.7MB 528MB 513MB linux-swap(v1) primary raid

1 528MB 2576MB 2048MB ext3 primary raid

2 2576MB 4624MB 2048MB ext3 primary raid

4 4624MB 2000GB 1996GB ext4 primary raid

  • Select the first device, and resize the 4th partition (Please make sure you saw the partition table similar, and you know how to find your own data partition)

(parted) select /dev/sda
resize 4 4624M 4001G

  • Ignore the warnings

  • do the same on second device

select /dev/sdb
resize 4 4624M 4001G

  • Reboot, the MBLD will show the Red light
  • Login to Web UI, and do a Full Factory Rebuild
  • Everything goes well after it’s done
3 Likes

Thanks for sharing this with the community.

Please add a disclaimer to let the users know that they will be doing this at their own risk.

Has anyone else tried this and can confirm it’s working?
I have the same situation

1 Like

It worked for me, except the resize command failed due to an error, so I resorted to removing and then remaking the 4th partition on each drive,

Drive A,
select /dev/sda
rm 4
mkpart primary 4624M 3001G

Drive B,
select /dev/sdb
rm 4
mkpart primary 4624M 3001G

Note I was replacing a defective 2tb drive and increasing capacity to 3tb.
But I can’t see why this wouldn’t work for any other size drives.

Then from the drive webpage, reboot and do a quick factory restore to get the drive back up and running with the extra capacity.

All data on the drives will be lost, so make sure you have adequate backups before beginning.

2 Likes

Here’s what I ended up doing
I connected the new drives directly to my PC using SATA
I saw the 3TB partitions and a 1TB unallocated space.
I deleted the 3TB partition and created a new partition along with the other 1TB making a new 4TB partition and formatted it to exFAT. All with Windows 10 disk management.
The MBLD could not read the exFAT of course but after I did a full factory reset - voila! 8TB
Rebuilding my RAID 1 now

Generally I did the same as the original solution, but through Windows rather than ssh
Hope people find this useful

This is kind of what happened to me with a MyBook Duo and mac OS, I had 2x 1TB Green drives and I updated with 2x 2TB Red drives I had in my NAS, I removed a disk and replaced with the bigger capacity one, rebuilt lasted a few hours, did the same with the second drive and same thing after a few hours, RAID1 array rebuilt but both the finder and the disk utilities see the two disks as 1TB ones and not as 2TB, I wish there is a fix for this because WD still doesn’t answer my question and I am kind of bored since I bought this enclosure and drives hoping for max compatibility and a good service out of WD which doesn’t seem to be the case (yet).

Thank you

First, thank you very much for posting this encouraging description!

I would like to replace the original 3TB drives in my MBLD with 4TB or 6TB WD Red drives and preserve my user data. So, my concern arises at the point after resizing the partitions and rebooting the MBLD. Is the only solution to the “Red light” problem really to do a “Full Factory Rebuild”, which, as I understand it, will wipe out all my user data? That just seems a bit brutal. Please tell me there’s a way to resolve the red light without losing everything…

I also have a couple of questions: 1) Has anyone been successful at replacing the original 2x3TB drives with 2x6TB (or even larger) drives? I think the WD Red Pro (7200 RPM) drives consume nearly twice as much power during read/write operations as the regular Red (5400 RPM) drives - so I’m reluctant to try the Pro version in the MBLD, for fear of overloading the power supply. Any advice about these things?

Thanks very much in advance!

Greetings Tang_Jianyu,

First, thank you very much for taking time to describe this detail!

I was so encouraged when I first read your post, because I have the exact same scenario - replaced my original Green 3TB drives with new Red 4TB drives.

However, I have run into trouble at every turn, problems that you did not seem to experience when you performed these manipulations. Here is my attempt to repeat your instruction, and the error that resulted:
---- begin transcript ----
(parted) select /dev/sda
Using /dev/sda
(parted) resize 4 4624M 4001G
WARNING: you are attempting to use parted to operate on (resize) a file system.
parted’s file system manipulation code is not as robust as what you’ll find in
dedicated, file-system-specific packages like e2fsprogs. We recommend
you use parted only to manipulate partition tables, whenever possible.
Support for performing most operations on most types of file systems
will be removed in an upcoming release.
Error: File system was not cleanly unmounted! You should run e2fsck. Modifying an unclean file system could cause severe corruption.
Ignore/Cancel? Ignore
Error: File system has an incompatible feature enabled. Compatible features are has_journal, dir_index, filetype, sparse_super and large_file. Use
tune2fs or debugfs to remove features.
(parted)
---- end transcript ----

Then, I attempted to use debugfs (tune2fs is unavailable in this environment) to see if I could list/modify features to resolve the error:
---- begin transcript ----
MyBookLiveDuo:~# debugfs -w /dev/sda
debugfs 1.41.12 (17-May-2010)
/dev/sda: Bad magic number in super-block while opening filesystem
debugfs: quit
---- end transcript ----

I have no knowledge of filesystem/super-block internals, and thus no idea what to try next.

Any advice will be greatly appreciated!

Thanks for posting this option!

I had hoped to somehow preserve my data while expanding the primary partition. But the clear priority winner was to increase the capacity, even if at the expense of restoring all the data.

So, when I finally reached an impasse searching for a way to preserve the data, and saw your post in that light, the path was clear.

I have followed your device, my MBLD is stable and happy, showing 8TB capacity instead of 6TB.

I’m a happy camper!

1 Like

WARNING! Zombie Thread resurrection.

A big shout out and thanks to Tang_Jianyu & Alapha9.

A drive in my 4TB MBLD failed. Fortunately it was configured for RAID1 but unfortunately trying to get a replacement drive of the same model as recommended by WD was nigh impossible thanks to the drives being discontinued.

I bought two 4TB WD red drives and followed the procedure given by Tang_Jianyu. It partially worked in that I had a working MBLD again but with reduced capacity. I saw the same errors that Alapha9 mentioned and remade the partitions as per the instructions Alapha9 shared and it worked.

I’ve now got 8TB of storage in my MBLD ( well 4TB as I’m still running RAID1) and I’m a happy bunny.

Thanks for your time and efforts guys to investigate this and publish it here for others to follow. I for one greatly appreciate it.

Many thanks!