Map network drive after pc factory restore

I’ve been looking for days but can’t find an answer that works. I have my cloud. I previously had the folders mapped to my laptop for easy access. I had an issue with my pc’s sound driver so decided to restore to factory conditions. Sound now works. Great! I reinstalled all the my cloud programs and updates etc but now when I try to map the folders to my laptop it keeps saying the server won’t allow it. I found forums with help options for similar issues but none work. I’ve tried
turning off Windows firewall
deleting all Windows credentials
messed with the settings on my cloud dashboard
Reset wd my cloud
tried using the wd discovery but the map option is greyed out.
I can’t restore my cloud to factory state as it’s got all my stuff on and no room anywhere else to move it.

I can use the my cloud app to view the files on my laptop and I can see the drive in my network on file explorer so it knows the my cloud is there. I’ve ran out of ideas. Any idea?

Forgot to mention. When mapping, it asks if I want to use different credentials. It’s defaulted to unticked so I tried ticking it and entering all the different usernames and passwords I can think of but when I do that it says the details don’t exist.

what is the exact error message? I have never seen “server won’t allow” is this local or remote access? local use file explorer and remote use the mycloud app, there are exceptions to this but for 90%+ of operations this is true do you have a public share connected? you need to connect to private shares 1st and the user you connect with needs privilege to all the private shares you want to connect to.

It was saying something else before I started messing about with settings. Something about the server nut being able or allowed. I forget. But now it’s saying:
The mapped network drive could not be created because the following error has occurred:
A specified logon session does not exist. It may already have been terminated.

That is with the “connect using different credentials” unticked. If I tick it, it asks for a username and password. No matter what I try putting in it says the same error.

I’m not familiar with “local”. Im using my laptop at home connected to the home WiFi which is in the same room as the my cloud drive. I think that means it’s local.

It’s my drive and all the folders are set to public access off on the my cloud dashboard but I’ve tried it on as well and still didn’t work. I’m trying to map using the quick view icon in the bottom right corner of the desktop by the clock.

Also for some reason, on file explorer, I can see my cloud under the network heading but clicking it takes me to the online dashboard. I can also see my cloud icon under the “my pc” heading but it says the folder is empty when I click on it. It’s not empty though…

some screen shoots may help although it takes awhile for images to be approved yes you are local forget all the WD apps for now, they are not needed and can be added later if desired if you are using DHCP you can sign into your router to determine the current IP address in files explorer enter \mycloud_IP (preferred) or \mycloud_name , I think the default name is wdmycloud you may see up to 3 mycloud entries when you bring up file explorer, for DLNA streaming, for management and for shares

Not sure where in file explorer you’re saying to type \wdmycloud I know a fair amount about pc’s but apparently not as much as I thought.

above the directory / file displays there is an address bar that will display your current location, click it and enter the new location \wdmycloud or \ipaddress


make sure the workgroup of the PC and mycloud are set the same, if not you won’t be able to browse to it but can access it as above

Workgroup on the pc is called the same as what’s showing on the dashboard. I assume that’s what you mean.

When I you’re \wdmycloud the following Message comes up:
\wdmycloud is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. A specified logon session does not exist. It may have already been terminated.

Sorry. Auto correct. 2nd paragraph meant to say " when I enter \wdmycloud

Have you tried entering your MyCloud’s IP address in the File Explorer address bar?  For instance, if your MyCloud’s IP address was, you’d type


Have you changed the MyCloud’s Device Name from the default “WDMyCloud”?

Dashboard/Settings/General/Device Profile/Device Name

When I type the ip address (example \ a message says Windows cannot access (ip address). Check the spelling of the name. Otherwise there might be a problem with your network. To try to identify and resolve network problems, click diagnose. When I click on diagnose, it says it can’t find a problem.

Just checked. Device name is still WDMyCloud

Thanks for helping by the way.

For some reason, under network, it did say wdmycloud but it now says win- followed by random letters and numbers. I’m not sure what that is? Is it relevant?

Also I just changed my music and video folders media serving option to on. I can now see them when I click on the wdmycloud icon under the (this pc) heading in file explorer. That’s fine but it still won’t let me map the other folders that I don’t want to be media serving. 

I’ve just started a safepoint going to copy everything to a spare external hard drive. Hopefully if all else fails maybe if I reset the mycloud drive to factory settings then transfer my files back to it, that might fix the problem?

 Just checked. Device name is still WDMyCloud

Does that mean you can access the Dashboard?

If so, I’d say it’s not an IP problem, but a Windows network problem. Outside my experience, I’m afraid…

yes. I can access the dashboard as normal.

Think once I’ve copied all my files to the spare drive, I’ll try factory restoring both pc and my cloud and set the whole thing up as if I just bought it.