Live book not showing on samsung tv or any dlna streaming program

Hi guys,

I was wondering if you can stop me from tearing my hair out!!

Today I purchased a WD mybook live (3tb) and have managed to get it to connect to my network via a powerline adaptor. I mapped a network drive on my win7 pc and put some stuff into one of the folders… all good so far.

I then loaded up es explorer app on my android tablet and bingo it showed up as a network drive. Files play and stream nicely via wireless to the tablet. still good…

Then I powered up my Samsung tv (which is also connected wired to my network via another powerline adapotor) and started up allshare. Nothing… Nothing appears.?

Then I try some dlna apps on the tablet (skifta and bubble upnp) and neither apps show any devices available apart from my samsung tv.

It seems like the dlna is not working from the drive or am I missing something basic. I had a look in the instructions and it shows a picture of a page in the drives web interface with a DLNA section, which I seem to be missing (I have a bit with twonky in the media tab only).

Cheers for any help.


Maybe dumb questions, but are you sure you have activated the Media Server, and that the Media Server has indexed the files?

… and also that you’ve enabled sharing on the appropriate shares?

Hi Tony, yeah both my screens look like your screenshots and still no dlna devices can see it. The only connections to the drive I can get are via the tablet (visable via as a network drive via an app) and via the pc as a network drive via mapping a network drive. I really hope I can sort this or does it sound like the device is faulty?

Go to the Twonky web page at

at http://(ip address of your MBL):9000

note the :9000 at the end.

Go to CONFIG (the wrench icon on the left)

then click media receivers.

Are any of your devices listed?

Hi Tony

This is what I see in the twonky page

I added in the samsung tv bit manualy using the tv’s mac address and still no joy. :frowning:

ok, I had a play about and I think I know what is going on.The MBL is connected to a different powerline adaptor on my network to my tv (both are wired to their adaptors). When I connect wirelessly to the same powerline adaptor that has the MBL on it with my tablet I can see twonky on the MBL!!! when I connect the tablet wirelessly to the powerline adaptor with the TV attached The MBL vanishes from the DLNA software on it. So it seems to be that it needs to be on the same powerline adaptor as the tv for it to work.

Can anyone suggest a fix for this? I’m guessing that if it was connected to the router this would not be an issue? unfortunately this is not an option as I have no access to the router on my network.

What powerline adapters are you using? 

You say “when I connect the tablet wirelessly to the powerline adapter” – that’s confusing to me.  How are you connecting to a powerline (wired system) “wirelessly”?

Hi Tony,

I have 2 tp-link powerline adaptors (300mbps wireless N powerline extender) They have both wireless and wired on them.