Linux, "pushing" content from PC to WDTV Live like in Windows 7's "play to" feature SOLVED!

Hi there folks, John here in the N.W. UK and new here so hope you don’t mind me jumping in with a tricky question.

Firstly, me WDTV Live is working fine and is correctly networked via my router. It is “seen” (and can “see” shares) on both my Windows PC and my Linux (Mint13) laptop.

With Windows 7 the “play to” function worls fine. ie I can use media stored on my laptop and directly “stream” it to my TV via thw WDTV Live box via Windows Media Players “play to” (dnla compliant device) service.

I can even stream to it with my Andriod phone, using apps called “BubbleUPNP” and “Connected Media”

I would love to be able to do the same with my Linux (Mint 13) laptop. Having done a lot of research I have tried “Serviio” and some other media servers (so many I forget their names !) but I have got nowhere :angry:

Is there any chance anyone on here can give a solid, easy to follow solution ? (pref one that does not involve a lot of Terminal commands :wink:)

If anyone can, they will make a lot of folks happy. This seems to be a common question from many Linux users out there according to the hours I have spent trying to find out how to do it !

Thanks for looking as they say

Just to add I have spent ALL DAY here trying to get this finally sorted. I tried MediaTomb and XBMC but no luck. Although I can “see” the WDTV live box just fine I simply don’t know what you do to “push” audio to it :angry:

(It only took me 3 minutes to get it to work on my Android phone :confounded: )

I guess I fail to see what you can’t do from linux

serviio is a great dnla server

I guess what it might not have is a button “play to”

dnla has 3 components

server - windows play to, serviio, etc …

renderer - your WD

control point - optional, example bubbleUPNP ( I use UPNPplay on android )

with a control point you can select media from any dnla server on the network, and start playback on any dnla renderer on the network

What I fail to see is why would anyone want to push content to a WDTV when pulling it (via Network shares) is available and IMO, much better.  There is no (WD-approved) media type my WDTV can not play when using Network shares, whereas there are some types such as ISO and MKV files that cannot be pushed to the WDTV (via Media servers or Play To).  And, I don’t need a PC (and its software) to be involved other than it and its drives being shared on the network.  Yes, I can push media with Win 7 Play To to the WDTV, but like I said, who needs it?

Thanks for the input folks.

In reply to

The simple answer is “I do, and so it seems do a lot of folks out there asking the same question” :wink:

Plus there is the “because it’s there” challenge. I am like a Bulldog with a bone as in find it hard to “let go”. I know it can be done and I have now spent many hours with servers and control point software to know avail.

I imagine one needs to “select” the output device in the laptops audio properties (Pulse Audio ?) in a similar way to the Andriod app. Is this correct ? If “Yes” then at no time have I been presented with that option.

I installed upnp-Inspecter and that “sees” the WDTV box and indicates it is “ready to use” (from what I can understand).

To me it seems the almost total lack of “how to operate this software” information on all the packages I have tried might be my problem.

I am not the type to give up and any further help on this might save my sanity :laughing:


One difference between pushing DLNA content via Win 7 Play To and a Linux system (and I know nothing about Linux, so I am guessing here) is that Win 7’s Play To is a server software, meaning it sends decoded media data to the WDTV, the WDTV does no decoding  and only passes on decoded info the Win 7 sends,  and perhaps Linux does not have an equivalent decoding-server capability.

It also would seem to me that instead of generating the “send/push” command from Play To, or from the Linux system, the same thing could be accomplished using the Media server access via the WD’s menu.  I learned long ago that Play To and media servers of WD are different sides of the same coin, so when I want to send/push I do it from the WD and not the PC (as long as the PC folder I am acccessing is shared) .  So, my question to you is:  can you access your Linux computer via Media server, and if so, use that, and if not, it confirms the Linux PC does not have built-in server capability as Win 7 does.  In this case, you would need to add a server software to the Linux system.

You are right in what you say.

I do have “media server” software on the Linux machine and it is working. I can “see” the server software on both the WDTV box and the Android phone. I can also see simple NFS shares from the WDTV box.

I can use tthe WDTV remote to “pull” files from the Linux laptop (ETC) but this is not what I want. Partially because, as you say, the WDTV has limited decoding (flac/ape and some vid types) whereas “pushing” files from the computer allows transcoding.

I just want to sit, with my laptop on my lap (:dizzy_face:) and simply click on a file and have it play out of the WDTV box, into my (Dennon/Tannoy) amp & speakers. I find it so much easier to navigate my (huge) music collection on the laptop screen and the “search” facility is so much eaier than faffing about on an Andriod phone screen (plus the transcoding issue).

Thanks for the input.

I am determined to get this sorted, don’t care how long it takes. When I do, I will return the knowledghe to as many forums as I can, as this issue is on many !

Regards to all,

John in the N.W. UK

ghost123uk wrote:


I just want to sit, with my laptop on my lap (:dizzy_face:) and simply click on a file and have it play out of the WDTV box, into my (Dennon/Tannoy) amp & speakers. I find it so much easier to navigate my (huge) music collection on the laptop screen and the “search” facility is so much eaier than faffing about on an Andriod phone screen (plus the transcoding issue). 

Gee, John, why didn’t you say this in the first place!  You can do this with your phone or tablet with an app called Twonky Beam or others with similar capabilities,  Belkin has a derivative app of Twonky Beam called MediaPlay that uses a different interface you might prefer better.  The apps see DLNA servers and not network shares.  It so happens I can (by using either my Apple or Kindle tablets) send stuff from my PC to the WD this way to my TV and stereo, as well as access from a server device I have called a Pogoplug, that btw happens to run on Linux.

Now, Twonky also makes server software, and I have a free version of their server on my laptop I have played with, and they also sell a full version called Twonky Server that might be useful for you.  Check into these.

Sorry Mike, thanks so much for the input, but I must have worded it badly :wink:

I can already do it from my phone, that took me no brains at all to get working in 3 minutes.

I have tried Twonky server and it just seems to do the same as the other servers, ie makes my files accessible from the WDTV via it’s remote control, but that is not what I want either.

What I want to do is sit with my laptop on my lap and click on files stored on the laptop and have them play via the WDTV box into my Hi-Fi system.

well first off, dnla server software available in linux is very robust

in most instances, my opinion is that it does everything win 7 media player can do and more

the instance where this might not be true is the play to feature

and that’s because the play to feature is not a server feature, it’s a control point feature

essentially microsoft has included a basic dnla control point

so win7 has - dnla server & dnla control point

so on linux you will also need

both a server software and a control point

linux dnla servers and plentiful and well documented, install / choose one and stick with it

then move one to finding a control point

and while I’ve very familiar with linux

I use DNLA sparingly

serviio runs on a headless server (no monitor)

I’ve never tried to push to my WD from serviio (what for. no monitor, no keyboard, etc …)

except with UPNPplay from my tablet

which works flawlessly

if your wanting to do this with a linux desktop

you’ll need to look for a DNLA control point software to install

this quick search

has several suggestions on what software to install

although the other issue is that mint, basically tries as hard as possible to hide the cmd line and make it noob friendly

but something like the suggested gupnp-tools is likely cmd line only

John, I have told you all I know about this, but KAD79 is more experienced with Linux, so carry on the conversation with him.   Good luck.

kinsky appears to be a full featured linux control point

with phone/tablet & desktop versions

so you continue to run your dnla server, serviio, mediatomb, etc …

and then run kinsky on top of it


This app appears to be interesting, but proprietary to the Linn company’s stereo system hardware.

There are apps for iOS and Android, and I wonder if it would work on an iPad and Kindle to find music on home network servers (e.g. Win 7 PC) and direct the music to play on a WDTV to send to the TV/stereo?  The app description states it works with Linn DS systems. Do you have any insights here? 

Quote from> " Kinsky is an open source UPnP control point for iPod/iPhone, iPad, Windows, MacOSX, Linux, Android and PocketPC. Queue music from your Media Servers to any Media Renderer in your home"> apps for tablets and phones are a dime a dozen, but this appears to have a desktop interface as well


but like I said, this was just the result of a quick search, this is not something I’ve tested

Well, the Kinsky app is free, so I installed it on my iPad. It has a nice interface, I got it to cue up a track, it played for less than a second to the WDTV, then stopped, obviously realizing it was not playing to Linn equipment, is my guess.  Then, it would not try to play again until I closed app and opened it again.  So, I will uninstall it.  Too bad, I would have liked to use it.

If anyone can get it to work (and continue playing) as I have tried to do, lemme know!

a few quick test tonight

kinsky app on android tablet works play 1 song at a time

I could not get it to cue any files

tried upnpplay again, it plays, and automatically plays the next file in the folder

both suffer from the “this is playing content from windows” message

which make them only usable for audio , not for video files

oh a gupnp on ubuntu 14.04 works just fine as well and has a gui with basic play, stop, pause, next

it only displays audio files, so no video

and it has the same windows error message, but works just fine

also kinsky for linux works, but they have it listed as beta, and there’s some very obvious bugs

and just to reiterate this is the same process as using a phone or tablet as a control point

serviio running on headless server, and different pc linux desktop running control point

is able to see serviio and use it to play back audio on the WD

Well it all sounds a little dicey no matter what, so will stick with what I have – Twonky Beam, although I am quite unhappy with current version since the Japanese bought the company. 

mike27oct wrote:

Well it all sounds a little dicey no matter what, so will stick with what I have – Twonky Beam, although I am quite unhappy with current version since the Japanese bought the company. 

and that sort of sums up DNLA

“a little dicey”

over all DNLA has high ambitions, but it feels more like an unfinished project

with 90% of dnla anything that I’ve tried, having some sort of major bug

serviio is one of the very few that I actually like, but it does not have a control point

Firstly, thank you for the input here, there is some good information :smiley:

I tried GUPnP . I tried for a whole day to install it ! The (terminal) install kept failing complaining that it could not find various “Lib” files. I researched this and it seems common. The solutions I found involved intalling libupnp-1…1.tar.gz , which in turn failed. Solutions also involved some hellish terminal codes. I am still fairly new to terminal and had trouble re-writting the lines to suit my paths

Then I tried xbmc which installed OK, but I could only get it to play locally.

Note, I am not concerned about video content, I am happy to “pull” that using the physical WDTV remote control.

What I am wishing to do is “play DJ” with my laptop, queing up the next track etc, when friends are round for the evening (Saturdays mostly :wink: )

It is a shame that my requirement is seemlessly built into Win7/MediaPlayer12 and Andriod phones/Tablets but is a rare/unobtainable thing in LInux.

With your help though, I will pursue it, even with my limited Linux skills. It is something I know many out there are trying to get working. I know this from the (considerable) searching I have done over recent days.

I guess search engines will find this thread when folks type the appropriate terms into Google etc. If “we” can find a workable solution I am sure many many folk, worldwide will be very pleased and the person who comes up with the answer will be promoted to a Linux DNLA saint (topical reference there) :smiley: