LCD Does Not Turn Off on PR4100

Zensunni, stay with it and keep asking for replacements until you get a product that works. Let us all that tried and failed see the success through you. I for one know that this option works as some on this forum have reported it. I also owned an EX4100 that had this feature work successfully.

Good Luck and Happy New Year!

I’m beginning to believe certain batches of these units (MyCloudPR4100) are defective where disabling (turning off) the LCD is concerned as I too have never been able to turn off my LCD.

And even updating the firmware (now 2.31.204) has no effect. BTW I purchased my MyCloudPR4100 unit back in April of 2019.

In the end I stopped worrying about it and just accepted it’ll never work. Period!

@Zensunni Please PM me your support case number

Sorry, but I feel like that’s a futile exercise as this issue has been known for at least two years.

And BTW, I called WD’s tech support last year on this and basically got babble talk. They basically told me the “LCD panel doesn’t shutoff it just dims” And while the LCD panel does dim, it’s ever so slight as to be hardly noticeable.

Anyway it’s not like this is new so…

Dru2, I had the same experience as well. I was told that it was working as intended. I had an EX4100 that this feature (able to turn off LCD) was the only thing that worked. I had it replaced by the PR4100. The LCD was never able to be turned off from the beginning nor with firmware updates. I too feel this is futile at this point, however on the oth8er hand I wish that companies would own up to issues that are brought up by several people and provide solutions.

Thanks again for letting me know that I am not alone in th8is issue.

Apologies for the delay - I’ve been on holiday and am just back. I’ll PM you my support case shortly.

To the others -

WD Support apparently doesn’t believe this issue is widespread. In one of the last replies to me on the support ticket, I was told, ‘these incidents mentioned in the community are isolated.’

I’ve sent them additional logs, and the response was, ‘We have escalated the case multiple times with the log files to no avail, since they do not show errors or anything related to the LED [sic]… Please, manually install the latest firmware version for your NAS… If the issue is not resolved, the only solution we can offer is a Failure Analysis that will take place in the USA.’

I replied back asking if the FA could be done on the unit I had just sent back, which had the same fault, or if they would send me a temporary replacement to use in the interim. The reply was that, ‘It needs to be done on the device you have… there is no option for a replacement while the investigation is ongoing.’

I was also told, ‘If this is not a feasible scenario, I am afraid that the only option that you have left is to cover the LCD screen.’

Uh huh.

I replied asking what he expected me to do with the 8TB of data I have on the NAS if they weren’t going to give me an option for a temp unit and asked why they couldn’t do the FA on the unit I had just returned, as it had the same fault. I had this response:

'I justo confirmed with my superiors that, in order to make things easier for you, the devices that you have already sent to us through the RMA’s will be the ones that we will ship to the WD headquarters for a Failure Analysis.

‘When the engineering team identifies what the exact issue is and its cause, hopefully you (and the rest of the affected users) will see the results in the next firmware updates.’

So apparently they now can do it on the other NAS I had returned that had the issue.

I’ll be sending him a follow-up a month after the last reply, but I’m getting the feeling this is a brush-off at this point. @SBrown, hopefully you can follow-up on this.

Please, if you are experiencing this issue, log a ticket and quote this thread. The more people who log this fault, the more likely WD is to acknowledge and fix it.

Thanks very much for adding this to the thread, @dswv42. Hopefully this helps in the investigation.

Surprisingly, I had an email from WD support on my case today, where they now say they’ve decided to send me a temporary replacement so I can send the PR4100 I have now to the US for the fault analysis. @SBrown, I’m not sure if you had a hand in this, but if you did – thanks!

I’ll be sure to post an update when they’ve finished with the analysis.

As the person that started this thread back in June of 2018, I want to thank everyone that has jumped into this thread and especially the feedback that was just posted recently. I was told that I was crazy and there was no issue with this feature of being able to turn off the LCD.

A Big Thank you to all.

I’ve had this issue since day 1, but have just been living with it.
My SN is WNAQ2719XXXX, my email says I registered it to WD on 12/28/16.
Looks like the issue goes back until at least 2016.

I should add that I haven’t had any other issues with this NAS or the two HDDs I installed with it when I first ordered back in 2016. It’s been powered up near-continuously since then.

After a lot of back and forth and forwarding WD support earlier emails from them, the replacement that had been promised finally came to me yesterday. (Unsurprisingly, it has the same lcd issue.) UPS will today be collecting the one I had been using to go back to WD for fault analysis.

Apparently I’m shipping it to WD in Poland and they’ll be shipping it to WD in the USA, so I’m guessing it’ll take at least another couple of weeks before the fault analysis is done.

I’ll report back once I have any news.

Well, it’s been a few months! Due to the pandemic, I’d not been chasing, assuming fault analysis would take awhile to happen.

But I thought it was time to touch base with WD to see if they had an outcome and ask when I’d be getting my NAS back. Their reply: ‘Regarding the results of the analyzes, they are made by our engineers for their database, however this information cannot be shared.’ I was also told I wouldn’t receive my NAS back, given I had one from the advanced RMA.

So I’m back to escalating this issue, and now under an entirely new ticket number. Sigh.

I’ve emailed back quoting a reply from them on the previous ticket where I was told that the PR4100 I sent for fault analysis would be returned to me. And I’ve pointed out that the NAS I was given under the aRMA has the same LCD fault.

I wonder - does anyone else had an update on this issue? I think there were a couple others who had been asked to send their PR4100 off for fault analysis on this issue?

Edit: Their reply is:

  • they apologise, I should not have been told that the PR4100 I sent for fault analysis would be returned
  • they don’t provide the results of fault analysis
  • I need to do another advanced RMA

I’ve replied to accept the advanced RMA and have flagged that I’ll make a written complaint to the WD CEO if the replacement has the same fault.

So I’m back in this endless loop…

I had an EX4100 and upgraded to PR4100 , and found the display issue. It had always worked on the EX4100. I RMA’d the PR4110 and got another with the same problem. I have upgraded the firmware to 2.40.155 and the display still is not completely off, just dim. I had hoped that they would have fixed it by now. I love the performance, this is just an annoyance.


!
English is not my native language.

Analyze the backlight LED control circuit and confirm that this is a design flaw,
LCD setting is on, LM358 input is 55Hz duty cycle adjustable square wave.
LCD setting off, LM358 input is 0V
When LCD is set to OFF, pin 1 of LM358 cannot reach 12V, and the p-mos tube cannot be completely turned off. It is recommended to open pin 1 of LM358 and connect a 1n4148 diode in series.

1 Like

Thanks k_unc!

I suppose that your solution actually works? If so, then WD does have a hardware fault that they sold us and never admitted to. (My PR4100 has the same “LCD won’t turn off” problem.)

Western Digital, When are you going to own up to the fact that you sold us hardware with a fault?
Where’s the recall or partial refund Western Digital?

I see a couple of helpful WD Staff on the forum, can someone please confirm if this is a hardware fault or intended behavior? My unit is still under warranty (~6 months old), Tried reaching out to customer care over email (reference 200925-002819) but they just go through usual troubleshooting/reset steps but not much help either.

@mirge101, if your device’s LCD is not properly turning off, you can contact the WD Support team directly for help & RMA if still under warranty.

I’ve reached out to email support (only option available now), unfortunately this forum and WD staff here are more helpful than Indian WD customer support who keep reciting irrelevant sections from the manual and then switch to another newbie. Apologies for sounding rude but it’s beyond frustrating since I contacted them ~2 months back (ref: 200925-002819). Will escalate on social media, hopefully that gets their attention.