Kein FTP-Zugriff über das Internet

Hallo zusammen! Ich habe Ende letzten Jahres mir eine WD My Cloud mirror gen2 2 x 4 TB gekauft. Seitdem versuche ich über das Internet mittels FTP eine Verbindung aufzubauen. Der Support von WD direkt war bisher weder hilfreich noch zielführend.
Zu meiner Konfiguration: Ich bin Kunde bei Kabeldeutschland/Vodafone und habe eine FritzBox 6490 cable. Zugriffsversuche waren: FileZilla, Windows-Explorer und NetDrive.

Ich möchte nicht die Vielzahl von Dokumenten (Screenshots, LogIn-Scripts, HTML-Scripts, Beschreibungen), welche bereits an WD-Support ergangen sind, ohne sinnvollen Filter darstellen. Ich denke, einer der User hat sicher die gleiche oder eine ähnliche Konstellation.

Wäre schön, wenn es endlich (nach einem halben Jahr) klappen würde.

Beste Grüße

Lothar

Kannst Du denn über den Browser (mycloud.com) auf das Gerät zugreifen?

Wenn Du privater Kabelkunde bist, bekommst Du vermutilch nur eine IPv6-Adresse mit diesem Dual Stack lite (oder wie das heißt). Damit funktionieren keine Portweiterleitungen, kein DynDNS-Dienst und damit auch kein FTP von Außerhalb.
Hier ist das schön erklärt:

Also erst einmal vielen Dank für Deine Antwort.
Punkt 1: Das Thema IP6-Adresse wurde bereits zu Beginn der „Odyssee“ geklärt. Kabeldeutschland hat mir eine IPV4-Adresse zugewiesen.
Punkt 2: Ja, ich kann über den Browser (mycloud.com) auf die cloud zugreifen.

Mein letzter Versuch ist wie folgt beschrieben: Ich habe von einem fremden Internetzugang mit meinem Laptop über den Explorer drei FTP-Verbindungsversuche gemacht. Alle Zugangsdaten nachstehend:
dlp FTP Test
FTP URL: ftp.dlptest.com or ftp://ftp.dlptest.com/
FTP User: dlpuser@dlptest.com
Password: 8PxNA0QuFVZozwA

UCONN FTP Test
FTP Hostname: ftp.uconn.edu or ftp://ftp.uconn.edu/
Port: 21
User: anonymous

WD FTP Test
FTP Hostname: ftp://wdmycloudmirror-2.11x3hfzmxxvaecuh.myfritz.net:8021/
Port: 8021
User admin

Die Ergebnisse sind: Beide öffentliche FTP-Server können verbunden werden, die Dateistrukturen werden korrekt angezeigt. Bei dem MyCloud-Zugangsversuch erscheint immer folgenden Fehlermeldung:
FTP-Ordnerfehler – Auf diesen Ordner kann nicht zugegriffen werden. ………Details: Die Serververbindung konnte nicht hergestellt werden.

Ich habe alle Einstellparameter der WD und der Fritzbox seit Dezember 2016 mehrfach dem WD-Support geschickt. Aber entweder können die nicht helfen, oder sie wollen nicht helfen.

Danke für Deine Mühe und Beste Grüße

Lothar

Alle Zugangsdaten sehen nicht so aus, als würden sie zu Deinem NAS führen. Registriere Dich mal bei www.noip.com, trage die Daten des DNS-Dienstes in Deinem Router ein u. melde Dich mit dem Nutzernamen u. Passw. der My Cloud mit einem gescheiten ftp-Programm (filezilla, fireFTP) an.

Gibt hier auch detailliertere Anleitungen von mir. Benutze die Suche.

Hallo nogood,

ich fürchte, ich habe mich etwas missverständlich ausgedrückt. Ich möchte einmal die Historie kurz darstellen.

Von allen drei Parteien, welche als „Lieferanten“ in dieser Kette hängen, also AVM (Router), Kabeldeutschland (Internetprovider) und WD (NAS) existiert das Statement: Bei mir alles in Ordnung! Alle Einstellungen sind dokumentiert und den Parteien in Form von Screenshots zur Verfügung gestellt worden.

Der zuletzt aufgezeigte Versuch sollte von daher zeigen, ob ein FTP-Zugang mit den derzeitigen Einstellungen überhaupt möglich ist. Die zwei öffentlichen FTP-Server DLP und UCONN konnten ohne Probleme erreicht werden. Ein Zugang zu meiner NAS hingegen ist derzeit nicht möglich, obwohl WD die Einstellparameter für OK erklärt hat.

Alle Versuche haben ohne dritte Zugangssoftware stattgefunden, also weder FileZilla, o. a. Es wurden nur Windows-Bordmittel eingesetzt, den Explorer. So, so das Statement von WD, muss der Zugang funktionieren. Tut es aber nicht.

Zu Deiner INFO: Ich habe WD als Ultima-Ration zwei Dinge vorgeschlagen.

  1. Aufschaltung auf meinen Rechner durch WD mittels TeamViewer
  2. Temporärer Tausch meiner WD durch ein von WD voreingestellte NAS

Beide Vorschläge blieben bislang unbeantwortet.

Danke für Deine Unterstützung bis dato und Beste Grüße
Lothar

Ok, cool.

Du kannst Dich hier so lange über WD u. deren Support beschweren wie Du willst - das interessiert die (leider) überhaupt nicht.

Entweder Du willst, dass es funktioniert und machst es wie von mir empfohlen, oder Du kämpfst eben weiter gegen Windmühlen.

Aber vielleicht hat ja noch jemand hier eine zündende Idee (z.B. @Wideglide?)

Hallo nogood,

ich möchte schon verstehen, was ich hier mache. Deshalb habe ich noch ein paar Fragen bevor ich die FritzBox „suboptimiere“.

  1. Ich habe gelesen, dass bei meiner FritzBox ein Dynamischer DNS-Dienst integriert ist. Du schreibst aber auch z. B. in einem anderen Forumseintrag: …Du benötigst einen dynamischen DNS-Dienst (z.B. no-ip.org), damit Deine My Cloud immer unter der gleichen Netzwerkadresse aus dem Internet erreichbar ist…. Die Netzwerkadresse meiner NAS ist fest vergeben, der IPv4-Netzwerkmodus steht auf statisch.

  2. Ich verstehe immer noch nicht, weshalb mein Hinweis, dass ich zwei öffentliche Server über FTP-Zugang problemlos erreichen konnte, meine NAS aber nicht, nicht zielführend sein soll. Nach meinem Verständnis haben die beiden Adressen die FritzBox ohne Beanstandung passiert. Weshalb soll da ein anderer DNS-Dienst Abhilfe schaffen.

Tut mir leid, verstehe ich nicht. Vielleicht sollte ich mir doch einen Server aus Holz basteln?!

Trotzdem Danke bis hierhin.

Beste Grüße

Lothar

Ja klar, der DNS-Dienst der Fritzbox sollte auch funktionieren.
Oder versuche es doch erst einmal ganz einfach mit der gerade aktuellen öffentlichen IPv4-Adresse. Der DNS-Dienst (egal ob Fritz oder andere) sorgen ja nur dafür, dass das Netzwerk bei ( vom Provider) geänderter IP-Adresse noch erreichbar ist. An Deiner fest vergebenen internen IP für die My Cloud musst Du nichts ändern.

Aber prüfe mal, ob die Ports, die Du im Webinterface der My Cloud eingestellt hast, auch korrekt in der Fritzbox geöffnet sind.

Hallo nogood,

ich glaube, dass Du da den Finger auf die Wunde gelegt hast. Ich gebe zu, so ganz will ich dem Statement von WD nicht glauben, wenn die sagen, die Parameter sind ok.

So sieht das nämlich aus:

  1. Vereinbarung im Dashboard der NAS
    a. Netzwerkdienst -> FTP-Zugriff -> Port 8021
    b. Portweiterleitung FTP -> Externer Port 21 -> Interner Port 21

  2. Vereinbarungen in der FritzBox
    a. MyFritz-Freigaben -> FTP -> Port 8021
    b. MyFritz-Portfreigaben -> von Port 21 bis Port 21 an Port 8021

Ich möchte ganz unbescheiden einmal vermuten, dass der Fehler in 1.b. liegt. Für mich wäre es logisch, wenn dort die Einstellung lauten würde Portweiterleitung FTP -> Externer Port 21 -> Interner Port 8021.

Oder bin ich jetzt ganz plemplem?

Beste Grüße und Danke für die Geduld

Lothar

Ich würde es mal anders herum probieren:
Portfreigabe für MyCloud (TCP) Port 8021 an Port 21
Mit den Angaben unter 1. würde ich auch noch einmal herumprobieren. Mir ist nicht ganz klar, was die Einstellung unter 1.a bewirkt. Es könnte sein, dass dadurch die Angabe des (normalen FTP-)Ports 21 überhaupt nicht mehr erforderlich ist und überall 8021 drin stehen muss. Ausprobieren!

Und erst mal mit der öffentlichen IP, einem FTP-Programm und den Anmeldedaten Deines My Cloud-Accounts.

Wenn das dann funktioniert kannst den Rest ja schrittweise ‘suboptimieren’.

Ich habe eine FTP Verbindung einmal hinbekommen, das war aber wohl eher Zufall. Kann nicht mehr genau sagen, was zum Erfolg geführt hat.

Was ich aber noch in Erinnerung habe: ein FTP Zugang auf eine öffentliche Freigabe ohne Benutzer und Passwort hat nicht funktioniert. Eine nicht öffentliche Freigabe + Benutzerlogin war aber irgendwie möglich.

Danke für Deine Ergänzungen.
Ich denke, dass die My Cloud Mirror hier einfach zu viele Einstellungsmöglichkeiten bietet. Vermutlich sollte man einfach erst mal die Finger von den erweiterten FTP-Einstellungen im Dashboard lassen u. dort einfach nur den FTP-Dienst aktivieren. Dann wird der Standard-Port 21 verwendet, den man über die Router-Portfreigaben auf z.B. Port 8021 leitet (weil Port 21 schon vom FTP-Dienst der Fritzbox verwendet wird).

Benutzer und Passwort muss man in der My Cloud natürlich auch angelegt haben und im Router die Portfreigabe für MyCloud (TCP) Port 8021 an Port 21 gesetzt haben.

Dann kann man sich in einem beliebigen FTP-Programm mit diesen Daten anmelden:
FTP-Server: öffentliche Provider-IP
Port: 8021
Benutzer: Benutzername auf der My Cloud
Passwot: PW für My Cloud-Benutzer

Wenn das klappt, kann man die öffentliche Provider-IP durch die Addresse eines Dyn-DNS-Dienstes ersetzen. Wenn man den Dyn-DNS-Dienst der Fritzbox verwenden will, sind sicher noch ein paar Einstellungen mehr erforderlich, da dieser m.W. per default den FTP-Dienst der Fritzbox unterstützt (und nicht den des NAS).

Ganz schön viel Aufwand, für die Realisierung eines unsicheren Datenübertragungsprotokolls :wink:

Edit: Mods, bitte den Thread zu Netzwerk Laufwerke verschieben. Danke.

Aktuelle Einstellungen Fritz und WD.pdf (431.1 KB)

Hallo nogood, wideglide und andere, geneigte Unterstützer!

Ich habe heute peu à peu die vorgeschlagenen Modifikationen durchgeführt und, da keine Auswirkungen spürbar, wieder zurück gesetzt. Um das Verfahren zu vereinfachen, habe ich die Screenshot von FritzBox und NAS in eine PDF gepackt und angehängt.

nogood schreibt heute: …Ganz schön viel Aufwand, für die Realisierung eines unsicheren Datenübertragungsprotokolls…

Vielleicht sollte ich einmal die Aufgabenstellung beschreiben! Ich nutze die NAS vorwiegend (wie könnte es anders sein) als Datenserver. Mein Hobby Fotografieren bringt es mit sich, dass ich von Unterwegs auf meine Datenbestände zugreifen möchte. Und zwar in der Form, dass über einen Browser Bilder ausgewählt und direkt mit der Bearbeitungssoftware geöffnet werden können. Die eingesetzte Software setzt in diesen Fällen voraus, dass die relevanten Ordner gemappt sind. Ich kann also Laufwerksbuchstaben vergeben.

Ob jedoch der Datenzugriff mit FTP oder WebDAV realisiert wird, ist grundsätzlich nebensächlich. Wenn also jemand eine bessere Idee hat, her damit.

Ich bedanke mich bei Euch.

Beste Grüße

Lothar

Hallo Lothar,

nur kurz mal das probieren:
Myfritz-Freigabe im Router löschen und FTP-Einstellungen im Dashboard des NAS auf Port 21 einstellen.

Und parallel dazu würde ich es wirklich mal mit webdav probieren. Ist auf jeden Fall sicherer, als FTP.

Unabhängig von der technischen Lösung stellt sich mir die Frage, ob ein von externes Bearbeiten von Fotos aus Performace-Gründen überhaupt Spaß macht.

Ich stelle mir gerade vor, Du nutzt z.B. Lightroom und willst RAW Fotos bearbeiten. Damit ist die Mirror von der Leistung her im Heimnetz schon an ihren Grenzen. Und dann von Extern?

Hallo nogood,

habe verstanden. Werde morgen früh den Vorschlag gleich umsetzen und berichten!

Danke

Lothar

Hallo Wideglide,

Du darfst Dir das nicht als Onlinebearbeitung vorstellen. Die Kopie des Bildes wird selbstverständlich in den Hauptspeicher geladen und nach der Bearbeitung, wenn überhaupt, als Replikat zurück gespeichert. Originale überschreibe ich grundsätzlich nicht.

Beste Grüße

Lothar

Hallo nogood,

ich habe Deinen Vorschlag ausprobiert: Leider ohne Erfolg!
Ich habe nun einmal versucht, mit der bei mir „angeborenen Logik“, die Begriffe so zuzuordnen, dass es einen Sinn geben könnte. (Dazu die beigefügte Grafik)
Nach meinem Verständnis ist die Portweiterleitung der Fritzbox der Eingang der NAS. Also Fritzbox (Portweiterleitung) intern ist NAS (Portweiterleitung) extern. Denn NAS (Portweiterleitung) intern ist Port FTP-Zugang NAS.
Allerdings habe ich diese Variante auch schon ausprobiert. Gleiches Ergebnis.
Ich ärgere mich immer mehr, dass ich die WD nicht schon im Januar zurückgegeben habe. Aber ich konnte ja nicht ahnen, dass ich auf einer Notenskala von 1-6 für den WD Support noch eine Extension kreieren muss: 7- in Worten (ungenügendes Mangelhaft).
Doch möchte ich nun tatsächlich wissen, ob das Teil überhaupt funktioniert. Allerdings ist für mich WebDAV ebenso ein Buch mit sieben Siegeln!
Vielleicht hat jemand gerade mal so eine leicht verständliche WebDAV-Kurzanleitung in seiner Nachttischschublade.

Bis hierher nochmals Danke!

Beste Grüße

Lothar
Schema FB-NAS.pdf (33.0 KB)

Das am Ende des Links in Deiner Grafik:

ftp://wdmycloudmirror- 2.11x3hfzmxxvaecuh.myfritz.net:21/Lothar

noch die Freigabe fehlt, auf die Du zugreifen willst, ist bekannt (siehe Beispiel oben fett)? Und, nur zur Sicherheit, für die gewünschte Freigabe hast Du explizit auch FTP eingeschaltet?

Hallo Wideglide,

zu Deinen Fragen:

  1. Ja, dieses ist die Syntax, welche von der FritzBox vorgegeben wird. Es spielt allerdings keine Rolle, ob ich den User (zum Beispiel Admin) im String angebe, oder ob er zur Verbindungslaufzeit angefordert wird. Das Ergebnis ist das Gleiche.

  2. Ja, die FTP-Freigaben sind alle korrekt eingerichtet

Aber mich beschleicht die ganze Zeit ein anderes Gefühl! Ich habe schon “Tage” damit verbracht, im Netz User zu finden, bei denen bei ähnlichen Konstellationen der FTP-Zugang funktioniert. Und was ich bisher im Netz gefunden habe, wirft streng genommen kein besonders gutes Licht auf “WD my cloud mirror”. Oder die zufriedenen User halten sich alle bedeckt?!

Danke für die Unterstützung

Beste Grüße

Lothar

P. S.: Ich fürchte, ich werde mich wohl oder übel mit WebDAV befassen müssen. Hoffentlich wird das nicht auch so eine “Endlosschleife”.