Issue with WD Ext HDD 1021 USB Device

Hello, some years ago my WD fell on the floor and it worked but the pc couldn’t find it, recently I decided to give it ago since so many years passed I decided to see if the pc would recognize it, it did, however everytime I try to allocate it, it says access denied, I’ve tried with diskpart to remove the write protection and it doesn’t let me. Anyone knows a solution for this? I’ve tried a dozen of programs and of solutions but I can’t find the proper one but I blv there must be one for this so I can retrieve the files from this HD.

The computer doesn’t let me assign a letter to the HD, it states the disk is unallocated and not initialized, when I try to allocate it, it says acess denied. I’ve used easeUS to try to retrieve data but nothing happens idk if it’s the bad sectors or because the HD is with the acess denied.

Model of my HD is WD2002FAEX - 007BA0

Hello,

Please perform a diagnostic test using the data lifeguard diagnostics tool to determine the optimal health of the drive by following the steps mentioned in the KBA: Testing a drive for problems using Data Lifeguard Diagnostics for Windows