Is the cloud server waking up my WD Cloud every 25 minutes?

This is the second time I have seen this type of activity. At exactly 25 minutes my device wakes up, although it could be a service that I haven’t stopped or needs attending to. On most days, I would wake up my device and turn off standby for the day, however I’ve left it on standby since yesterday night thinking it was sleeping soundly until I noticed the blue light on after my gym activity to find my user.log filled with wake ups…

Since my last sound sleep that slept continuously for 5 hours, this seems nefarious…

Apr 9 00:56:05 WDMyCloud logger: exit standby after 13 (since 2014-04-09 00:55:52.746452000 -0700)
Apr 9 01:26:12 WDMyCloud logger: exit standby after 1504 (since 2014-04-09 01:01:08.126452000 -0700)
Apr 9 01:56:12 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 01:31:15.166452000 -0700)
Apr 9 02:26:12 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 02:01:15.126452000 -0700)
Apr 9 02:51:30 WDMyCloud logger: exit standby after 1215 (since 2014-04-09 02:31:15.136452000 -0700)
Apr 9 03:26:12 WDMyCloud logger: exit standby after 1476 (since 2014-04-09 03:01:36.126452000 -0700)
Apr 9 03:56:12 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 03:31:15.096452000 -0700)
Apr 9 04:26:13 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 04:01:15.116452000 -0700)
Apr 9 04:56:12 WDMyCloud logger: exit standby after 1496 (since 2014-04-09 04:31:16.116452000 -0700)
Apr 9 05:26:12 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 05:01:15.136452000 -0700)
Apr 9 05:56:12 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 05:31:15.116452000 -0700)
Apr 9 06:26:13 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 06:01:15.136452000 -0700)
Apr 9 06:56:12 WDMyCloud logger: exit standby after 1496 (since 2014-04-09 06:31:16.126452000 -0700)
Apr 9 07:26:12 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 07:01:15.076452000 -0700)
Apr 9 07:56:13 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 07:31:15.076452000 -0700)
Apr 9 08:20:29 WDMyCloud logger: exit standby after 1153 (since 2014-04-09 08:01:16.116452000 -0700)
Apr 9 08:26:12 WDMyCloud logger: exit standby after 40 (since 2014-04-09 08:25:32.486452000 -0700)
Apr 9 08:36:51 WDMyCloud logger: exit standby after 336 (since 2014-04-09 08:31:15.086452000 -0700)
Apr 9 08:56:12 WDMyCloud logger: exit standby after 858 (since 2014-04-09 08:41:54.196452000 -0700)
Apr 9 09:26:13 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 09:01:15.086452000 -0700)
Apr 9 09:56:13 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 09:31:16.096452000 -0700)
Apr 9 10:26:12 WDMyCloud logger: exit standby after 1496 (since 2014-04-09 10:01:16.076452000 -0700)
Apr 9 10:42:34 WDMyCloud logger: exit standby after 679 (since 2014-04-09 10:31:15.076452000 -0700)
Apr 9 10:56:12 WDMyCloud logger: exit standby after 515 (since 2014-04-09 10:47:37.086452000 -0700)
Apr 9 11:26:13 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 11:01:15.096452000 -0700)
Apr 9 11:56:13 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 11:31:16.096452000 -0700)
Apr 9 12:26:13 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 12:01:16.066452000 -0700)
Apr 9 12:56:13 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 12:31:16.086452000 -0700)
Apr 9 13:04:06 WDMyCloud logger: exit standby after 170 (since 2014-04-09 13:01:16.066452000 -0700)
Apr 9 13:26:14 WDMyCloud logger: exit standby after 1025 (since 2014-04-09 13:09:09.496452000 -0700)
Apr 9 13:56:13 WDMyCloud logger: exit standby after 1496 (since 2014-04-09 13:31:17.096452000 -0700)
Apr 9 14:26:13 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 14:01:16.086452000 -0700)
Apr 9 14:56:14 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 14:31:16.086452000 -0700)
Apr 9 15:26:14 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 15:01:17.066452000 -0700)
Apr 9 15:56:14 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 15:31:17.056452000 -0700)
Apr 9 16:26:14 WDMyCloud logger: exit standby after 1497 (since 2014-04-09 16:01:17.136452000 -0700)
Apr 9 16:56:15 WDMyCloud logger: exit standby after 1498 (since 2014-04-09 16:31:17.146452000 -0700)
Apr 9 17:26:14 WDMyCloud logger: exit standby after 1496 (since 2014-04-09 17:01:18.136452000 -0700)
Apr 9 17:33:57 WDMyCloud logger: exit standby after 160 (since 2014-04-09 17:31:17.136452000 -0700)
Apr 9 17:39:51 WDMyCloud logger: exit standby after 52 (since 2014-04-09 17:38:59.726452000 -0700)

any thoughts?

1 Like

Thanks for sharing this information Ralphael, have other users experienced the same thing?  

I cannot check logs, but indeed, the box started to wake up regularly a day ago, after a few days of behaving (almost) as it should while in sleep mode.

Are you guys really working on the issue? Can’t be that difficult.

Same here. 

Mine does … I thought it was my MyCloud , but I guess there are other also. This started happening this week.

Does setting it to run non-stop for a few hours (a day) calm your boxes down? Seems like it helped me. But then again, still wakes up for no reason every now and then.
With the stories re heartbleed bug, this seems to annoy me even more. :wink:

luizfermiranda wrote:

Same here. 

Same here :frowning:

me too.

I sent many reports to the support, they will come back to me if they know something new about it.

It even wakes up when it’s only connected to the router without internet access.

I had this “phenomenon” as well and assume that it is a lack of memory (aka swapping) issue. Since I moved my “swap” partition to an external usb drive, the problem does not occur anymore (at least not in the last 3 days). Here’s what I did:

  1. Insert usb drive

  2. blkid (to figure out which path the usb drive is automatically mounted to -> /dev/sdd1 in my case)

  3. umount /dev/sdd1 (unmount usb drive)

  4. mkswap /dev/sdd1 (format usb drive to swap)

  5. nano /etc/init.d/swap2usb.sh (create small shell script to use usb drive as swap with higher prio than hd)

#!/bin/sh -e 

sleep 120

swapoff /dev/md2

swapon /dev/sdd1 -p 2

swapon /dev/md2 -p 1

  1. crontab -e (add following line to execute the script on every reboot)

@reboot /etc/init.d/swap2usb.sh

  1. reboot

8) cat /proc/swaps (to check if all worked -> usb drive should appear in list with prio 2)

Probably not the best solution but it seems to solve the problem :smiley:

Edit: I have a “My Book Live Duo”.

bjoern

just curious if you are one of the many having issues with the wdmcservd & wdphotomerged processes?

if so is it any better after moving the swap off the internal disk?

I don’t need DLNA and deactivated those processes (wdmcservd & wdphotomerged) long before I had the idea of moving swap to usb. So I cannot tell if that becomes any better but I assume that those services still need to access the drive from time to time, no matter if they swap or not. Apache and Rsync (backup to external drive) are the biggest memory hogs in my opinion…

they do cause a lot of swapping which is what kills the system. As far as I know these are not needed for DLNA but for the WD photo app.

I disabled mine too

Yes, you are right. “wdmcserverd” and “wdphotodbmergerd” are related to photo indexing and snapshot creation, see  http://community.wd.com/t5/WD-My-Cloud/before-you-pack-up-your-WD-and-return-it-let-s-talk-about/td-p/683307/page/4

Edit: Those two services do not exist on “My Book Live Duo”.