Is it possible to use My Passport Ultra with iPad Pro (4th gen)?

I connected the drive to my iPad using a Kingston Nucleum hub. The hard drive has power and the disk spins, but the iPad never shows the drive. Does anyone have experience with this?

1 Like

Im having an issue with it on a third gen so would love to hear a response to this. I even tried factory resetting it ad for some reason it’s not wanting to show up. It still works on my Mac though. Gutted if this isnt compatible.

The drive works on my (really old) MacBook as well.

it seven more annoying when you can see other people are able to do it https://www.youtube.com/watch?v=Tgxj-vINjHQ&t=357s

I don’t know about Apple devices but my WD Passport works with my Android phones and Android tablets without any hassle.

My WD drive is the older version I guess - its a regular USB connection, not a USB-C. I’m using the Kingston Nucleum hub so I wonder if the drive isn’t getting enough power maybe.

So i got mine to work @Brittanym108.
I downloaded WD utilities from their application and erased the disk and made sure that it was in EXFAT format and now my tablet reads it perfectly fine.

1 Like

I tried that and still no luck, which is a real bummer.