Is it possible to mount and use a G-Speed Shuttle XL thunderbolt 2 on a late 2013 MacPro (trashcan) running Mojave 10.14.6?

Is it possible to mount and use a G-Speed Shuttle XL thunderbolt 2 on a late 2013 MacPro (trashcan) running Mojave 10.14.6?

The G-Speed Shuttle XL Thunderbolt 2 works perfectly on a PC. I am using a thunderbolt 2 to thunderbolt 3 adapter into a thunderbolt 3 usb-c port on the PC. I am using just straight Thunderbolt 2 on the Mac.

As far as I can tell, the firmware was updated to the latest version via the PC (the utility software claimed it was).

I have tried everything I can possibly find online, and suggested by g-tech:

I started here:

Thunderbolt 2:

[https://support-en.g-technology.com/app/products/detailnew/p/98/~/98#WD_downloads]

All options failed for mac, so I moved on to drivers and software for Thunderbolt 3, hoping something would work.

Thunderbolt 3:

https://support-en.g-technology.com/app/products/detailnew/p/100/~/100#WD_downloads

Even though I’m not using an M1 mac, I tried to follow the instructions. But “controller” doesn’t show up:

No_Controller.png

Even though the traschan can see the the shuttle:

Mac_See_Shuttle.png

I’ve tried this suggestion from the forum about Mac TB3 driver, which also failed:

FYI - If you use the G-Speed Shuttle Utility to upgrade the Utility, it will download and upgrade to the GRAIDutility. Which is what I did on the PC.

Just to reiterate, working with either the old G-Speed Shuttle Utility or the new GRAIDutility, the G-Speed Shuttle XL Thunderbolt 2 worked just fine on PC.

In desperation, I found this on the G-tech forums. And it worked…for one day!!!

I could mount, format, copy to the Shuttle XL Thunderbolt 2 on the late 2013 trashcan running Mojave. However, the next, I couldn’t mount again.

I have a G-Speed Shuttle RAID which also wouldn’t mount on my M1 MacBook Pro - very disappointing. There is nothing on G-technology’s website to help out. I managed to get it to work by downloading the new driver (R_MacDrv_V6_2_16) from the Promise website,

PROMISE Technology - Storage Solutions for IT, Cloud, Surveillance, and Rich Media

I think all the drivers are the same on that page.

The G-Speed made use of the Intel Ktext and now they have re-written it to work with M1 Macs. The install involves lowering the security at boot to load a non-Apple extension (there are very clear instructions downloadable from the Promise website) but quite frankly to get the RAID working, that’s not a problem. It now works like it did before without issue for me - phew! I hope this helps as it was driving me nuts.

Here are all the drivers and software I have attempted:

https://drive.google.com/drive/folders/18zQlkIiklqfmXV889--MhjiJNmsecF0S?usp=sharing

Please, if anyone knows, I’m willing to pay! Thanks!

No response from anyone?

I guess g-tech/speed is a dead product.