Is Belkin F6D4050 wifi adapter really supported?

Hi everyone,

just bought the Live today and I’m having difficulties having it working with this Belkin adapter, despite the fact that according to the release notes, it should be supported since the 1.02.14 firmware version. I tried both 1.02.14 and 1.02.21 unsuccesfully. What can I do?

Thanks in advance. :slight_smile:

Have you tried a factory reset?

You can do so via the side button (next to the USB input) and/or via the setup menu.

However, please be aware that there are 2 versions of that USB adaptor.  The WD release notes specifically mention “Resolved WIFI Belkin F6D4050 with RAlink 3070 chip”.  I believe this is Version 1 (v1) of the hardware.

If you have the other version of this adaptor (v2), it may be that your model is still not supported.

Please post back with your results and, if possible, the version number of the device.

This link may help you determine the model / version number:

Thanks, actually I have the v2 of this adapter so I guess that’s the problem. How can I ask WD to include support with e of the next releases?

Same problem here with the v2… :frowning: any help ??

edoardopost wrote:

Same problem here with the v2… :frowning: any help ??

It appears that this version is not supported.

Hya all…I joined to revive this topic: is there any news about the Belkin F6D4050 V2 and the new firmware (beta)?

I ordered an adaptor last week and as fate has it it’s a v2…

I’d rather not venture with a firmware change if this issue is not fixed.


It looks like the Live Hub supports the F5D4050 - Is the F5 the V1?

No, F5 are power line adapters. F6 are wireless.