Iphone and iPad on local network "LOADING"

Hi wondered if anyone can help.

I’ve setup all the required access for all my devices and whilst out and about the MyCloud App on iPhone and iPad work great. That’s goes for 3G, 4G and Wifi.

However, on my local home Wifi network, the mobile apps simply refuse to load any of the shared folders. It just sit’s on “loading”. Now, granted I’ve never left it for a really long time to see if it ever does load because as far as i’m concerned, if it can’t load before my iphone/ipad screen shutdown occurs then it’s too long. I don’t really want to sit, keeping tapping the screen to keep it awake until it loads. Especially whenon 3G or outside my home network it loads instantly.

Oh and on a Mac laptop and desktop, it’s instant, both with the My Cloud App (remotely) and finder (locally)

Anyone figure out how to resolve this?


Is your local router at home using UPnP? Enabling the option is recommended for optimal local performance.

It is indeed using UPnP. 

Can’t figure it out myself. As soon as I switch them to 3G, it’s loads instantly. Even on Wifi outside my network. However, as soon as I connect to my local network…“Loading”. Works on the WD Cloud Desktop App on two Macs very well. It’s litterally just a local network issue on the mobile apps.


Hmm.   I see no reason why UPnP would have anything to do at all with local connections – UPnP is a router thing.

When you’re on your own network, the router doesn’t even need to be there.

Besides, if it works when you’re out and about, then UPnP is working fine.

I’m wondering if your phone is having trouble transitioning from 3G data path to the WiFi data path.

Next time this happens, try force-closing the Cloud app, then toggle Airplane mode on and off, then re-open the app and try again.

For more info:



Thanks, however none if these solutions worked. Let me reiterate that everything else works EXCEPT my iPhone and iPad on my local network (wifi) using the WD My Cloud App. Remote works, computers work, xbox works. Just not iPhone and iPad whilst on my local network. The App just sits “loading”. Switch to 3G and like magic, works great.

I am have the exact same problem - ditto!

only with ipad and iphone and on my local wifi - works great everywhere else and on android/PC/Mac

There is definitely some settiing or switch somewhere that needs to be flipped/unflipped

So when you go through the troubleshooter above, all steps work as described?

Exact same problem. Bizarre

HI Tony,

Yes, I have been through those steps but they don’t help and seem geared towards remote connectivity issues, which I don’t have.

Remote works fine. I’d just rather not have to use up my 3G data allowance whilst sitting 3 feet away from my NAS and Router whilst at home.


What exactly happens when you open the apps.

Do you have both the mycloud app and the photo app?

Does the same thing happen on both?

Have you tried deleting the app and reinstalling it?

How did you set up the app when you first installed it?

Hi Rich,

In answer to your questions.

When I open the App, it appears to see my NAS, when I click on it the shares never load. Just sits on Loading.

I only use the My Cloud App, I have no need of the Photo App.

Yes, I have deleted the App and reinstalled.

I setup the App using the code generated on my NAS.

I hope that helps.


Try installing the photo app and see what happens.

How were you connected when you entered the nas code on your iPhone etc.

I assume that you don’t have some strange setup on your network. Its just a straight setup with modem/router, mycloud connected via Ethernet and your PC / iPhone connected via the same wifi connection.


Well, turns out all you have to do is remove the NAS from the mobile App and re-add it again whilst connected to your local wifi. Now it works remotely and locally.

As the NAS still remembers it as being cloud access added you don’t need to do anything at all in the dashboard.

And it’s often the simplest solution that escapes us all.