Invalid drive count!

I’m trying to setup a new Sentinel dx4000 with 2 drives (long history on this, basically one of my 4 drives of a RAID 5 dropped out of the RAID array and since i have several things, still nowhere). The drives are new, the box is new, i have downloaded a number of copies of the ISO recovery files (!!!) and created the USB recreate etc. and more… and when I try to recreate the box, I am getting this error. Any idea all?

You need to slave or USB caddy each drive in a PC and run DISKPART
select the CORRECT DISK
and then type “clean”

Thanks a lot
My plan is to buy a proper HDD Bay tomorrow, and try below.
My bigger and more frustrating issue is that even with my new Sentinel box, I can’t successfully run recovery with my old survived drives (3 of them) to recover my data. And worst I’m given a URL to download latest ISO which the ISO seems corrupted and doesn’t work

You previously suggested a method involving RAID recover s/w and I’m yet to try that one.

the drives contain the raid info. So if you had 4 drives and try to repair with 3, it is missing one.
If you go to two drives that also changes form raid 5 to raid 1.
That is why you have to clean the drives to start over with the ISO.
But clean erases everything. So if you are trying to get to data DO NOT clean

Yes, that’s my understanding.
there is a long story.
I had a NAS with 4 drives, one of which failed. All my attempts to run recovery using WD recovery ISO failed - I was pointed to several URLs to download the latest ISO etc. and all failed. (i even tried the original I had at the time I got the box) I was working with WD level 2 support on all these tests. At some point we guessed the issue might be the NAS enclosure (because we were also getting BAD STORAGE error on the LCD). so I went down the path of getting extra drives… initially I bought one to use it in place the failed drive (to run recovery with 4 drives, 3 being part of the failed RAID 5, + 1 new one), then another one to make two, so that I can test the enclosure.
When I used the 2 new drives to create new box, again i got other errors, preventing me from setting the box up as a new NAS. This was the point WD said they are going to replace the box. and they kindly did so (they didn’t have to, as my box was outside of warranty - I appreciated it)
SIGH, when I got the new box, … I went through the same set of tests (which I can list, but that’s a long set of things we did), to cut the story short: 1) 3 good drives + 1 drive and recovery > failed 2) 3 good drives > failed 3) even trying to setup with 2 drives (when i posted this message) > failed…!!

What is still at the back of my mind, is the ISO. When the WD support sent me the link to the new ISO and I downloaded, they didn’t have the MD5… I made several attempts to download the file, some of which failed, but I managed to download the file about 4 times, and ran MD5 thing and I got the same key for all those, so I figured I have the correct one. BUT mounting of this file failed, tried on a few different PCs and all failed. then WD pointed me to a particular s/w to do the mount… and even though I mounted the ISO, but the thing wasn’t right, because I was seeing some weird text on the click buttons (on the wizzard) which was the same as all the other scenarios which resulted in failed mounting.

I don’t understand why the ISO doesn’t mount (i’m sure is corrupted, but WD says the ISO is ok!! SIGH am I the only one experiencing this ISO mounting issue!) so I have a few unanswered questions.

Sorry, long reading, but this just a snapshot of what I really did…!!!
what i am planning to do next is to buy HDD bays and try to run the WD lifeguard s/w to test whether they are OK.
then possibly run the method you suggested in another one of my postings and ultimately see a data recovery expert (one was proposed by WD as being their partner.) I know the risk of all these I am doing is that I might cause more issues… But i’m going crazy I think…

as always, thanks for replying to posts.

Hi Gramps,
I tried this and I am still getting “RECOVERY INVALID CONFIG”.
:frowning:
running out of options.
My drives are compatible with the NAS enclosure, according to: http://support.wdc.com/knowledgebase/answer.aspx?ID=9443#apac

So all the letters on the drive have to match, the front model number and the dash firmware version. Those that have a star * require the latest firmware iso firmware 1_7_6_21

Do you not have a windows 8.x or win 10 box anywhere? Just dbl click the ISO and it will mount

When you say you have done “this”, you mean a diskpart Clean?

H there,
Yes, I have win 10.
I also tried on win 7 (in case).
I understand that all the characters must match before and after ‘-’
That latest ISO is the problem - it actually does not build the USB (well, at least in my case).

I will double check a few things and get back to you

The drives I have got are WD2002FYPS-02W3B0 and WD2002FYPS-02W3B1
So, on the link: http://support.wdc.com/knowledgebase/answer.aspx?ID=9443#apac
since it does not have that *, therefore the latest ISO is not going to help? correct?
I have the original ISO which I downloaded when I bought the box - thinking one day I will need it! D’oH
Whether this assumption is correct or not, I actually tried it and still got the same error.

I think the problem is that I don’t know the pre-requisites for recreating the box. eg. version XXX of the ISO, drives (which I know the part numbers, but I didn’t know I need to “clean” them… even though I did and still didn’t work…).
interesting story I think
Gramps this is a great problem scenario for you I think :slight_smile:

by the way, regarding that ISO, I downloaded it, but it seems to be impossible to mount it successfully and creating the USB.

Well you have to have a good ISO to start with. The hash I get is
32031f2454d3510d7ce2bf5891f7d25d

Then mount it and run setup.exe

I can’t seem to find any ISO’s other than panam downloaded here to look but the drive list says just panam? When you mount the iso look in
the folder \WINPE\WDRECOVERY for whitelist.xml and make sure that the drive is listed

The drives are impossible to find so I do not know where you got them and wonder if they might be counterfeit??? Use something like CrystalDiskInfo to see if the report the proper info. This is not a compatible drive, just a for example

If you are using your old ISO, make a thumb and boot from it. Do the middle step recreate my storage. One of these you have to make a new thumb each time, so make a new one anyway.

Once it is done, remove the thumb and put it in a PC and look at the log file and see what is says.

Hi there
Let me check this with you - what OS do I need to run the ISO mounting etc on to create the USB?
I was doing some research on my issue and somewhere I read Win 10 wouldn’t work!!?
Now I’m trying to setup a pc with Win 7

Where did you see me say Win10 would not work?

Thanks Gramps, I will check these and will post the result.
I also managed to find PANAM ISO, but when I contacted support, they sent me the link to anther one APAC, which was the one doesn’t work for me. For this APAC, I don’t have an original MD5. for the PANAM I do.

I will get back

Hi,
actually the drives were second hand, bought from eBay, but tested etc., and I tested again with WD lifeguard tool. both from 2 different sources.
re PANAM ISO, I get the same checksum 32031f2454d3510d7ce2bf5891f7d25d

I was told by the WD support that only Win 7 and Vista would work - I think it wasn’t from you saying Win 10 won’t work. From someone else (and the WD support)

still trying to setup a Win 7 box.

Nop!
no luck
tried with win 7 as well
tested the drives with WD lifeguard tool and they were ok
used the panam ISO and the MD5 is the same as your Gramps
error I’m getting! INVALID DRIVE COUNT
amazing


and this is what I get when trying to use an ISO given to me by the WD support. this is APAC ISO, note the ‘.’ in front of the text on those buttons.

So did you do diskpart clean with the panam.iso?
You are doing the middle step recreate correct?
Put the log file from the thumb drive in a dropbox share and post the link here for me to look at it

Hi mate,

  1. Yes, diskpart and used the PANAM ISO. and it’s ok (MD5 is the same as yours)
  2. Yes, recreate.

Which log file is this one? do you have a name so I can search on the USB?

Just a few things I’m double checking:

  1. at the point that I create the USB (on the PC), is LAN connectivity any relevant? I presume no, because the box is off at that point, and only once created the USB, it is inserted into the USB at the back of the box (the Sentinel);
  2. One the recreate starts, is network connectivity any relevant? I presume no for this one also, since the recreate does not interact with the PC, unlike the recovery which on the screen says after …happens, come back to this wizard and click next…etc.