Import file does nothing to change accessibility of shares

When I upload the import file, a configuration file that I create, and select to overwrite what had been previously submitted, and upon applying such a file, I am expecting certain changes to occur for each instance of share folder assigned to a user. In other words, the importing of the import file should, for every user, be able to set any share to be in one of three permissions: (1) share set to access denied, in effect, not allowing user to view contents of such a share, making that share practically non-existent to that user, or if share folder is visible, its content isn’t, (2) user may be given permission to read-write to that share, or (3) user may be given permission to read-only view that share.

But what happens to me is that, after applying such an import file, all shares become useless, they all get set as denied access, completely inaccessible to all users, as if set to private and only visible and writeable to its owner user. Of course I can manually set the shares to become visible [and either read-write or read-only] to certain particular users of my choice, but that defeats the purpose of being able to create a file to manage users and shares.
Because the capability of being able to add multiple users and assign for each user what permissions they get for the various shares is available not just for my device the MyCloud PR4100 NAS, but for any MyCloud with OS 3 and OS 4, then I am placing this post here. I have posted something similar at another area of the community corresponding more to my NAS.
How to set-up multiple users (continuing saga)
see post of May 11, 2022 in an area referring to MyCloud NAS

that topic refers to the same issue.
I have created this topic here to see if I get any attention, because the original TomBurbury thread [see How to set-up multiple users] of 2017 has been totally being ignored. I am still in contact with WD Support, and will continue to bug them until I get someone there to understand the problem and figure out what is the problem.

Thank you for your consideration. I hope I am able to make this topic clear, but it is difficult for me, and it gets complicated pretty fast.
Om Ah Hum
Jairo Jamyang-Pawo Moreno

Hi @jairowd,

Have you opened a Support Case? If not opened, for more information, please contact the WD Technical Support team for the best assistance and troubleshooting:

Thank you Keerti_01,
I have already, and I am still communicating with them. Not much help. They are very good at responding, but there experience with this particular feature is zero. [May 25, 2022]

[Update (and Edit/Errata to the previous recently posted update, please ignore the previous one): June 6, 2022 {2:36 PM 6/6/2022, Orlando Florida} follows:]
But many days later since, I have an important update, and it’s mostly good news, as follows:
I have managed to get the hang of it.
I have figured out a way to get the import file to work and so produce what I want in terms of setting the permissions correctly. Perhaps me trying to explain this here may help someone else who is trying to use the import file method of managing users and shares.

The trick, I found, is to pass the import file twice, of course the second time, make sure that one is overwriting the users. That is what I had to do. I had to pass the file twice. The first time I run it, it creates the users, but it doesn’t completely produce the permissions I desire for each user, like it only moves the settings for the user and its share of the same name, giving the user complete control of that share by same name, but it fails to set read-only for shares that I want other users to view. So in the first pass, if I recall correctly, there were settings that should have gone to read only or read write, for particular users and shares. However when I ran the file a second time, in other words, when I went to import the same file without changing anything to the file, then it did function to set the permissions the way I wanted.

But besides having to pass the import file twice, I have to start out small, with only two primary users plus their share folders, and two special folders, for a total of 8 lines consisting of 8 users, although only two of those users are the primary users, the remaining six users are being used as shares.

And so I import that file, I call it stage 1, which I also call the original or the starting file. Then after I pass it twice, and confirm that it worked, I create a new import file, which includes previous information, but the new file builds upon the previous file, I add to the original import file, another pair of users, one primary user and his share folder. I save the new file with a name indicating that it is stage 2.

So when I import the new file, stage 2, I also pass it through twice, then confirm that it worked.

And then again, I create a new import file, making it stage 3, where I add yet another pair of user-share combos, consisting of one new user and its share. That requires careful attention across the three permission columns to make sure I have given the correct permission to the new user, his share, denying access correctly across all shares, and indicating that all the old users have read-only access to the new share.

I run stage 3, passing it twice, confirming that it works, and so on. I repeat the process, with each stage building on the previous stage adding incrementally one user at a time. I have gotten to stage 5 this way, increasing the number of users from 2 to 7, and shares from 6 to 11.

However, in the previous file and in the new file, I detected a mistake in spelling of one share, so I had to start over by correcting the files, and deleting all shares and users, to start off with a clean slate. Now that the files are corrected, I will run the stages again to build up all the users and share. And I will confirm that stage 5 is working before I continue with stage 6.

Each stage creates the one additional user that I need, and some stages also will create special folder shares for specific people to use privately or to share with others. I will be creating as many stages as I need to have a total of about 17 users. And each user has their own share, so double 17 and you have 34 user-shares, and add to that several special folders to be shared amongst users, so I hope to manage about 45 user-shares this way.

I am creating documentation in the form of painstaking videos and screen recordings as to how I discovered this, and how I figured out a way to create users and shares in stages. I have come to a snag recently, but I think it may have been caused by a mistake in the naming of one of the shares, if it is spelled wrong, it may cause errors in the form of resetting all shares to access denied.
So when I come to an error along the way of creating users, I have to start over again by deleting the users and shares until I have cleared everything, then I can import the corrected file that adds users.

Thank you for reading all this.

I hope to send a link to YouTube video showing this process.

Here’s a link to YouTube video where I read this update aloud using Word Read Text Aloud: 2022 06 06 15 06 07 adding users in stages - WD MyCloud - YouTube