How to set-up multiple users [TomBurbury started in 2017 for his EX4 but ignored]

How to set-up multiple users (continuing saga). I have not been able to get it to work.

It seems like nobody in the whole wide world, except me and someone named TomBurbury is concerned about managing users and their shares through a feature known as adding multiple users by way of an import file. Five years ago [July 2017] TomBurbury started a thread [see How to set-up multiple users] asking if there’s anyone who had a working example of how the users should be set-up in an import file to create multiple users on the EX 4 [but such procedure should apply to any device with MyCloud OS, where one signs in to a dashboard to create users, and is given a way to create multiple users using that import file and map the created users to specific shares and give the users access to or deny access to particular shares. TomBurbury and I and perhaps countless others who remain silent but who find the proposition of managing users and shares via a text file attractive are being ignored.

There seems to be no one in WD support that has a clue as to how to use the import file. I have been in communication with a their experts by submitting a case and communicating back and forth through emails and through phone calls. It seems like there is no expert nor engineer in WD Support that has an idea about this. I wonder if the software engineer who coded this importing feature is still alive today, or if he got fired from WD and so no one knows how to use this feature, nor how to update and fix its bugs, and so there’s no hope of eliminating the notorious bugs in it. I have not been able to get it to work, and so I and others whom I have shown this to have seen it not work, and have a high inclination to suspect it is a bug, unless there’s something external that is blocking its expected ability to change settings. It simply won’t do what it’s expected of it. When I create a user, I also want that user to have certain levels of privilege or permissions towards shares. But the import file will not set those levels that I specify in the text file, given in the third, fourth, fifth, and sixth parameters out of seven parameters allowed in every line that is composed for each user.

The thread created five years ago has seen no activity except for a few of mine done within the past few months and no one is responding to it, TomBurbury’s post has been totally ignored, amazingly, perhaps on purpose by some algorithm that this community has placed, I suspect, that specifies if the post is older than so many years, then it is ignore, even though I have responded to it a month ago, or perhaps that algorithm is designed to ignore or hide any post that requires WD software engineers to fix programming issues, I guess. It would be too much trouble to fix OS things. There’s also documentation issues, by the way. And the unclarity of the documentation was noted by TomBurbury in his post of five years ago, and it’s an online documentation that must serve a wide range of devices, any MyCloud device. I am posting here because I am using a PR4100. But I should also post in every other device category that would have the MyCloud OS 3 and OS 5.

I have created a new discussion here to see if I get any attention, because the original TomBurbury thread has been totally being ignored. Wish me luck. Direct me to resources. Ask me to submit a case at WD Support. I have done all that. I am still in contact with WD Support, and will continue to bug them until someone there realizes and understands the problem.

I think I need to create a video and upload it to YouTube to demonstrate the bug.
Basically, I upload an import users list file [with each parameter separated by a tab character] such as the following:

alvaro- alvaro1223 alvaro:ops:ops_ carlos:fin_ carlos-:fin 20000:0:0
carlos- carlos1336 carlos:fin:fin_ alvaro:ops_ alvaro-:ops 20000:0:0
alvaro ewi2022! 20000:0:0
carlos ewi2022! 20000:0:0
fin ewi2022! 20000:0:0
ops ewi2022! 20000:0:0
fin_ ewi2022! 20000:0:0
ops_ ewi2022! 20000:0:0

So that file does create those users and their passwords. In this case I am only playing with two users, alvaro- and carlos- whose resultant shares I want to keep private for them. But I also want to create shares with names alvaro and carlos and I want them to be read-only for others but read-write for users with common names. The fin, and the ops users are to be used as shares, but I create them as users and hope that I can set them up as shares.

So after I run the import file, all those users/shares are created but they are stuck as public, so then I manually set them as private to gain access to permissions for their shares. So I run the import file again to see if I can configure the shares as other than private, I want to be able to set each share with respect to every other user to be either read-write, read-only, or access denied. Obviously I want read-write for any share/user with the same name. But I don’t want others to write over what an owner of a share has shared. So for example, I want user alvaro- to have read-write access to both shares with his name in it, that would be alvaro- and alvaro shares. Same for carlos- and carlos. But I don’t want alvaro- nor alvaro to see what’s in carlos-, so carlos- share set for access denied to alvaro- and alvaro. In other words, I am creating users but I am multi-purposing the user folders, I am treating whatever folder is created for a user as a share. So alvaro- is both a user and a share. Likewise for all other users. A user is created and is given a share by that same name. But I won’t really be giving read-write access to any of the shares with names such as fin and ops. They will be accessed by particular users alvaro- and carlos-

In the end, when I run the import file and select to overwrite what had been sent previously, the importing of the import file, ignores any requested changes to the shares, instead it will reset them all to access denied making all shares useless. Of course I can manually set the shares, but that defeats the purpose of importing and applying the import file.

I pray that someone can come with some hopeful clue or resource. You may contact me here. I may share my phone, and you can text me.

Thank you for taking the time to read and consider this case.

Om Ah Hum

Jairo Jamyang-Pawo Moreno
Orlando, Florida

Hi @jairowd,

Please contact the WD Technical Support team for the best assistance and troubleshooting:

Yes, thank you, Keerti, but I have been chatting with WD Technical Support since April 26, and I am having difficulty getting across to them my issue, and they seem to not have the technical abilities to figure anything out.