iMac/My Passport Connection Issue

Good morning,

Been using my WD My Passport on my 2011 iMac for about 1.5 years now no problems. Took the drive with me to work to load up a bunch of files came back and it mounts for one minute then disconnects.

It does not show up in Disk Utlity. It works fine on my old iBook from 10 years ago, and worked for a brief period of time on my iMac yesterday but today I’m back to it showing up for 10 seconds when first plugged in then disappearing. I reset the PRAM and all with my iMac unplugging, waiting and plugging in and all and nothing.

Tried different USB ports, used other devices to check the ports still work.

I think I read on here somewhere that the more data on the drive the more power it requires? now that I’ve added more data do I need a y cable? If so then why does it work on old laptop?

Any help? Thanks!


It is possible your computer is not providing enough power over the USB ports.  Check the power option of your computer and verify if you can find anything related to this.

Thanks for responding.

My apologizes I should’ve been more clear. An iMac is a desktop computer so there is no power options, whereas the iBook which has the power options has no problem with the drive.

Any insight?

Thanks again!

Wanted to add - I bought a power booster Y cable and same problems.

Found a computer it worked on - ran the WD utlity thing and it crashed half way through and now won’t turn on. So not only was the drive suspect, the software WD provides caused it to crash.

Second WD hard drive bites the dust.

Any help would be appericiated!


Have you received any solutions to this?  I’m having the same problem and can’t find any viable solutions that have worked. All my pictures on this drive and it worked fine until today.  It keeps unmounting / disconnecting itself.  disk utility would not recognize it or it would appear and I couldn’t click on any buttons and then the message would come up that i needed to connect a wd supported device.  I keep plugging and unplugging it but it only appears on the finder for about 10 seconds and then it’s gone again.

I really hope they find a fix to this.  

I have posted in a different thread with exactly the same issue, except my newish 2TB My Passport USB 3.0 has started randomly disconnecting from a MacBook Pro 2008, but was stable in a 2007 iMac when I checked yesterday…

I have had no problems to date with a 1TB My Passport USB 2.0 which is 2-3 years older…

I have sent an email to the WD technical team to see what they suggest.