I have to be doing something wrong.......ughh

Okay, I had the hub working fine and then I lost power.  I am on Win 7 and connected through wireless.  The wireless connection on the hub is good, but I can not access the media server on the hub side and my PC does not find the hub as a media server.  I have tried resetting the workgroup on both, factory reset, unplugging the hub, but still nothing.  I have tried WD discovery, but since the PC does not find the hub on the network neither does the discovery tool.  

I am not using homegroup or homeshare either.

What I do not understand is how I am connected wirelessly, but am not recognized on my pc.

Any help is greatly appreciated.


If your hub is using DHCP, it might be possible that it was given a different IP address after the power was restored.

You may need to check your firewall rules, since they may have PERMITTED the old IP address but are DENYing the new IP address?

It’s also possible (though unlikely) that your PC decided to create a different NETWORK PROFILE which has different settings applied.

By the way, MEDIA SERVER has NO need for Workgroup / Homegroup / WD discovery, etc.   So don’t waste your time on those things.

Thanks for the reply, but where can I find the ip address of the hub?  It is connected wirelessly to the internet through a wifi adaptor. 


If it’s connected to the INTERNET through a WiFI adapter, then there’s very little chance of it connecting to your PC and vice versa.   Both devices need to be on the same LAN, not the INTERNET.


Maybe my terminology is off.  It is a wireless usb which picks up my wireless network (my router) connected to my pc. 

My hub is connected to my wireless network from my router which is connected to my pc.  Does this help or would you need additional information to understand my setup?

I should note that I have tried to ping the address on my hub and it is unreachable, however, my hub has access toall the services such as netflix, etc.  I should also note the ip addresses for my router and hub are not the same, however the LAN addresses are the same.

I have another update.  I unplugged the hub along with the wireless usb.  Waited 10 minutes and restablished the network connection.  Went to videos and selected the content for media server and voila, it recogized the hub as a storage device.  Within seconds, it then indicated the last content source was removed and it no longer located the hub as the meida server.   Any ideas as to why this happened?

what do you mean by the “LAN addresses are the same?”

Sorry, the ip addresses are exact.  I am really frustrated that it worked and now it does not.  

I have 2 ip addresses.  One is labled LAN and the other is my computer IP address.  I am assuming the LAN is the router ip address and the other is my internet service provider.  If you can not tell, I am an very technical.

I honestly have no idea what you’re referring to.   Can you take a screen capture and post it to an image sharing site so we can see what you’re referring to?

Really sorry for the confusion, but I really appreciate the help. Here are the details for my router.

Connection type (WAN): DHCP

IP address (LAN):

IP address (WAN):

Computer IP address:

When I see my network settings on the live hub the LAN is the same and the computer address is different from my router, but it still connects to the internet for services like netflix.

Hope this helps.

It just keeps getting stranger.  Now, the WDTVLIVE hub shows up as a second computer on my network page in win 7, but I can not access it.  It also does not show up as a media device either.


I thought I would reference a troubleshooting guide you published here. I went through step one and found my pc and my wd hub, however, when I move onto the nbstat command I get a host not found for both devices.

I went onto the domain command and I have 2 domains listed.  One is the pc and the other seems to be my router and my hub is the same workgroup as my pc.  I just changed my router workgroup to “Routers”

Now I only see the pc on the net view and when I go to step two of the nbstat, I see the net bios of the pc when before I did not only the host not found.

Finally, I have my Master browser under my pc workgroup name.  

Does this information provide any more insight into my problems?

Thanks again for the replies.

The HUBs IP address is the same as your router’s LAN address?

Actually the hub’s ip address is the same as my computers ip address

Well, thats a problem. All IP addresses on the LAN must be unique.

maybe I am not looking at the right ip address.  I am finding the ip address for the “hub” when I open network settings and see the wireless network in my home.  It lists the name of the network and then all the various information such as IP address, gateway, dns, etc.  Is this the right location for the hub’s ip?

Yes, that’s the correct location. But if the IP address it tells you is the same as your PC’s address, that’s a problem.

Okay.  I have reset my hub and now they are different.  The computer is and the hub is

Is this better?  Also, a few posts up I tried following your well written tutorial for cmd commands.  I have listed what shows up.