I can't unbrick my MyCloud Gen2

Hi!

I tried installing Debian on my MyCloud Gen2 following the steps at https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/Debian/ and it got bricked. It shows a yellow light, and it connects to the router and gets an IP (it replies to ping) but it has no open ports, no way to connect to it (no web, no ssh, nothing)

Then I tried unbricking it following the steps at ht tps://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt and it almost worked. I got to the “safe mode” where I was supposed to upload the official firmware, but after uploading it, the light becomes red and it does nothing.

Then I tried restoring an image from ht tps://community.wd.com/t/guide-debrick-a-completely-dead-mycloud/92253 or [GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud, but those are for Gen1 and they don’t work.

So I’m lost, my drive is already open and warranty void, and I can’t go forward or backwards, so any help in any direction will be greatly appreciated.

An interesting fact is when I’m in safe mode, it’s requesting for firmware version 1.01.007, but it’s nowhere to be found. In this list of firmwares ht tps://community.wd.com/t/wd-my-cloud-v3-x-v4-x-and-v2-x-firmware-versions-download-links/148533 the first one is 2.10!

Anyway… I’m interesting in having debian on it, but at this point I settle to get a blue light, so… whatever helps would be great.

Thanks a lot!

PD: Some links are broken as “ht tps” because being a newcomer I couldn’t post more than 2 of them on the post. Sorry!

Hello,

I have never tried this since it is not supported. However, on this community we have a lot of experienced users that might be able to share some comments on this thread.

Maybe someone can share a disk image I can “dd” as the ones I found for Gen1 at [GUIDE] Debrick a completely dead MyCloud?

Or help troubleshooting why my nas is unavailable either through ssh or http when I follow the steps to install debian…

@Tomas_Nunez did you get any further with this?

I have a drive at the same safe mode screen requesting 1.01.007 firmware after replacing a dead drive following @Fox_exe instructions from https://ftp.anionix.ru/WDMyCloud/WDMyCloud-Gen2/_Unbricking_en.txt to setup the new drive.

The single bay/single drive My Cloud gen 2 didn’t have a firmware with the version number of 1.01.007. The intial firmware for the gen 2 single bay My Cloud was 2.10.302. The current firmware is 2.21.126.

Cheers Bennor, i thought as much :frowning:

I’ve managed to restore to the new drive now from the dd image i made so all is good :slight_smile:

Hi Bennor,
do you found a solution for your problem cause I got the same one.
I have WD My Cloud Gen 2 with 2 TB and tried to fit a 3 TB HDD in. No chance to get the blue light. I recognized to late that there are two generations that have nothing in common…

@mastergilgalad, you may have replied to the wrong person. I don’t have a gen 2 v2.x My Cloud. I was simply replying to Daemonic that there isn’t a v1.x firmware version for the gen 2 single bay My Cloud units.

Yes. that’s exactly the problem: The device was requesting 1.01.007 firmware but that version doesn’t exist, the first one is 2.10. It didn’t accept any firmware version I uploaded.

I have the same problem. how to solve?