I cannot access my WD ELEMENTS 25A2 1TB

My WD ELEMENTS 25A2 1TB shows up as Local Disk. I tried to open it but it keeps on loading. I would like to restore my portable device as an external hard drive disk and I want to retrieve my files. For reference, please refer to the photo attached.

I tried to restart my pc and a “Removable Disk” appears. I tried to open it but it says “Please insert disk in drive H”. Please see the photo.

you should post a picture of how the drive appears in “Disk Management” as that information is more pertinent.

click … Control Panel \ System and Security \ Administrative Tools \ Computer Management \ Disk Management

if it says “Offline” click it to make it “Online” …

if it say “Initialize” DON’T do that … as it will erase the data.

maybe try changing the drive letter from F: to example Z: … in case it’s a drive letter conflict

try using a different USB to connect the hard drive

try plugging it into a Different computer and see if it works

lot’s of things to try

Firstly, recover your files on the external hard drive to another place using certain data recovery software. After recovering files, enter Diskpart and run the commands as follows:
Warning: this operation will erase all data on external hard drive.

  • list disk
  • select disk n, n is the disk number of your external hard drive
  • clean
  • create partition primary
  • format fs=ntfs quick
  • assign letter=f