I can access WD Unlocker but after unlocking it cannot access the Hard Drive

I’m just newbie here , Please Help . After Plugging out the Hard Drive because of My OS(Windows 8.1) becomes unstable, I restarted my computer and plugged the External HDD again I now cannot access my External HDD :frowning:

This is the status of my Hard Drive now:

The WD Unlocker Does not seem to have any problem when I plugged the External HDD but after unlocking it, It shows the the Disk Drive but I cannot access it and my OS becomes unstable

I tried using cmd to see all the drives but when using diskpart it just freezes when the External Drive is plugged in to the computer

Also I tried disk management but it does not show all drives when the external Drive is plugged in the computer

I found the Disk Drive in device and printers and it shows the status that the drive has error

Tried Opening it using device and printers and this pops up

and my OS is now malfunctioning but right after i plug out the external drive , my OS becomes stable again



Also I was able to find the drive in the Task Manager Performance
This is the status when I tried to troubleshoot it in Devices and Printers

This is the Status right after unlocking the Hard Drive

What is the status of my Hard Drive ?
Can it still be fixed ?

Suggestions and Assistance would be much Appreciated . Thank you !

It all points out to data corruption or a volume failure. I’d recommend testing your hard drive using WD Drive Utilities. If the unit passes all tests then it should be formatted. If the unit fails any test then it should be replaced.