How to Install Bittorrent Sync on the WD My Cloud (Windows)

Gave it a try, but there is no file.

‘Killed’ is still the only message I got. But also here, I am not a Linux Pro myself, maybe with more btsync users we can put the puzzle together.

Anybody else?

I talked to tech support today this is what they said:

  •   Please change the FW’s file extension to .deb
  •   Make sure the FW file is in the root directory of a blank FAT-32 USB flash drive
  •   Power off the EX4
  •   Insert the USB stick into  Port 1
  •   While holding down the reset button, press the power button.
  •   Keep the reset button help for 1 minute and then release the button.
  •   Verify a FW update has started on the LCD: The LCM should be displaying a FW update is in progress - “Installing Firmware Update”
  •   When power LED is solid blue, Firmware update has been completed.

I did not recieve the deb file from them, and ended up the one used on here, however the firmware update failed.

On that note, I found the bin update file( and thought I might try it out. I updated thru the IP GUI browser. It worked in the sense that the version now states 1.03.41, however the GUI is still from 1.04.04 and BTSYNC won’t fire up.

Will keep you guys posted, unless someone can give me a way they have done it. 

Doing as you suggested (commenting out the 4 lines, etc.) I was successful in rolling back the firmware. Thank you! 

It’s worth noting for anyone else who plans to use this method, that using will erase whatever shares you created previously, and all data contained on them. Back it up first. 

Like many others, my WD My Cloud 4TB (along with BTSync) was crippled since the automatic firmware upgrade to v4.00.00-607 .  BTSync was killed every time I tried to start it.  I patiently waited many weeks hoping WD would make a firmware update to fix the problem. 

I finally pulled the trigger to downgrade the firmware using the " Easy Method" in the other thread.  The process made sense (simple version number edit to fool the firmware update checking).  After rebooting (with automatic update turned off), I had to SSH (I am by no means proficient in Linux, but this worked for me, so try at your own risk) in and start BTSync again by typing:


BTSync started and I used the web browser interface and it eventually showed all my previous sync folders and started indexing them again.  So far so good.

Edit: I haven’t tried restarting my WD My Cloud yet (to see if I have to redo the " install script so BTsync automatically restart" from the first post of this thread.  I will let BTSync do its indexing, then restart and give it a try.

Can anyone please tell me ig this instructions apply to the my cloud EX2?


not sure if others are having this problem. 

I’m still on v03.04.01-230 and I upgraded btsync to v1.4.83 (by way of replacing the btsync file in the Public folder). 

After running btsync, I could not seem to access the webgui.  I ended up doing the following which seemed to work (again i’m no linux expert at all.  this was all trial and error.  and now i’m just tracing back what i did to make it work):

  1. [research phase] I googled btsync 1.4.83 webgui and found many sites refering to a “sync.conf” when running btsync.  I know that the “sync.conf” file allows for advance customisation of btsync, but I could not find the file.  It turns out you can generate a sample “sync.conf” file. 

  2. I found this 2013 page on securing the webgui and SSH into My Cloud and typed the following to generate the “sync.conf” file:

    cd /shares/Public/
    ./btsync --dump-sample-config > sync.conf

  3. [research phase] I took a look at the “sync.conf” using the “nano” editor (similar to the OP method) by:

    nano sync.conf

From ths post regarding the “sync.conf” file, I confirmed in nano that the “shared folders” should be commented out (by having /*  and */ encapsulating it).  Then I exited the nano editor by Ctrl X.

  1. I then ran btsync with the “sync.conf” activated by

    ./btsync --config sync.conf

  2. this then somehow allowed me to use the webgui again.

I’m not sure why running ./btsync like before didn’t get webgui working for me like previously, but this worked somehow.  I think i’ll need to edit the auto start sequence as well… perhaps more on that later.

I know this is quite a n00b post, but if it could help others like me, that’s all that matters.

1 Like

Further to my post above, I modified the following underlined part (in relation to the OP) to make webgui work on autostart:

sudo nano /etc/init.d/btsync


2). Then copy the bold text below, and when you right click in putty, it should automatically paste it in.


#! /bin/sh

# /etc/init.d/btsync



# Carry out specific functions when asked to by the system

case “$1” in


    /shares/Public/btsync --config /shares/Public/sync.conf



    killall btsync



    echo "Usage: /etc/init.d/btsync {start|stop}"

    exit 1




exit 0

hope this helps!

1 Like

the installer link is not working. can someone share me the installer for bit torrent sync.
please let me know if it compatible with new version firmware. 



From my perspective and strictly considering the use of Sync for LAN transfers I have found value in moving very large files with no corruption issues that I have in the past experienced when using Windows Explorer via mounted shares as an assigned drive letter.  The files I am refering to are Engineering files in native AutoCad format for very large Enterprise networks operated by Tier I & Tier II service providers.

While I personally do not use Sync for moving / transfering smaller files I can certainly see it being a convenience for other peoples style of file management by using a drag & drop from a particular prorams working folder to a Synch shared folder within a given devices operating environment knowing that due to intermittent connectivity capacities eventually via Synch operating as a background service I will eventually achieve file transfer (via duplication) without being actively involved with the process.  SMB mounts, FTP services tend not to perform well when connectivity fails to any number of reasons ( used an elevator, dropped out of cellular coverage, etc.) requiring another manual action on my part as a user.

My normal use of Synch is to provide the ability to access in times of no, or poor connectivity various engineering documents I create for my clients from all of my devices i.e. Samsung Note 3, Laptop, and desktop with the requisit ridiculously large monitor for my almost 50 year old eyes to still work with AutoCad and not make too many errors…

I hope that sharing my reasons / usage methods will help you find a little respite from the overthinking issue our type of mindset suffers from at all times… take care & I hope your situation improves.

Can you please mention the 4 lines that you commented out? I have the entirety of h ere   on pastebin for you convinience. I have been stuck on this for a very long time and your help is highly appreciated.

Hi yahavrave,

I tried your instructions to Peter and it didn’t work.

BTSync is creating folders in the Public shared folder, which content is not visible in other pcs/mac connected to the network.

Is there any command to force btsync to inherit the Public’s folder rights? It will be tough to change rights for all hundred folders created by BTSync.

Thanks in advanced.


PS. My expertise in Linux is very close to zero.

in install btsync in /home/pi/.btsync on my wdmycloud

 WDMyCloud:/home/pi/.btsync# sudo /etc/init.d/btsync start
/etc/init.d/btsync: line 6: 11422 Killed /home/pi/.btsync/btsync --webui.listen

However I cannot start btysnc manually or by init.d  

why was this process killed?

is this a permission problem?

Please note I did not have any problem installing btsync on my raspberry pi.


#! /bin/sh
# /etc/init.d/btsync

# Carry out specific functions when asked to by the system
case “$1” in
/home/pi/.btsync/btsync --webui.listen
killall btsync
echo “Usage: /etc/init.d/btsync {start|stop}”
exit 1

exit 0

So can someone make a step by step process of how to roll back the FW. I’d like to setup btsync, but don’t want to mess up something and have to restore data from backups cause it will take a long time. I’m talking about 10tb worth of data, I got backups but don’t want to waste time.