How can I remove WD Unlocker

Looking for updates on my WD Utilities I downloaded what i thought was updated software but turned out to be WD Security which required me to inititate a password for my MY Passport hard drive.
I have a home computer and am not worried about the security of my external hard drive. Now I have to unlock the external hard drive if i want to do anything and its a pain in the posterior.
How do i get rid of this pleae?


There is an option to remove the security from the drive using the WD Security software.

WD Security for Windows

WD Security for Mac

Thanks, yes the WD Security for Mac did resolve the problem, uninstalling the software,and allowed me to make one further backup but
now the device reports that time machine has a problem in creating a back-up file. I fear the device is either stuffed or, just as likely, I don’t have the knowledge to resolve the problem.
Thanks for your help though - Appreciation

Hello … I tried this on my Mac and the WD Security did not install or remove the WD Unlocker. Unable to find anything that allows me to remove it in Utilities or Applications. Appreciate any input on how to remove the Unlocker.

After so many time i tried to delete/disable the WD Unlocker just so i could use it on my android tablet, finally i DID IT!!! haha…
Not so remember how i do manage to delete that WD Unlocker bcoz it happen so fast since i just click everywhere. But, i do remember i click on “Properties” of the WD Unlocker Drive…then another “Properties”… then i scroll for section disable drive and then click. Voilla!! It delete the WD Unlocker…hahaha
But then i try to open again my passport drive and it not showing up in window :smile:
so i used WD smartware to open the drive and put 5 time wrong password then it recommend me to erase all data and format the drive…and then everything become normal. Now the WD Passport drive is just like normal drive :slight_smile: and i could use WD Passport for my android