Help! Smartware doesn't see MBL (XP in Virtualbox)

My employer mandated an upgrade to Windows 7 across the board, but I have several line-of-business applications that still require XP. My only option for the time being is to run them in XP on a virtual machine, like Virtualbox, under Windows 7.

I dutifully backed up my old PC with Smartware (1.6) to my My Book Live. I reinstalled Smartware on the new Windows 7 PC, and everything is fine. I installed Virtualbox and reinstalled a copy of XP in it, and that went fine.

But although I installed Smartware on the virtual XP machine in Virtualbox, it doesn’t see the MBL so I can’t restore the backup. Ugh!

I thought this might be network-related, in that some sort of traffic (uPnP?) was being filtered out before it got to the XP machine. I have tried all the networking options in Virtualbox, including bridged mode so that the XP machine gets its own valid DHCP-supplied IP address, and when I do that I can even ping the MBL. I can also access the dashboard in a browser using the MBL IP address as the URL, which might actually rule out UPnP (I’m not certain).

NetBIOS traffic seems okay, if that’s an issue, because I can see the MBL in the workgroup and can get info on it using nbtstat.

I haven’t looked into any port forwarding (via Virtualbox) since that’s at the outer limits of my network knowledge. The only other thing I can think of is that there’s some part of Smartware not working under Virtualbox, some sort of process responsible for detecting the drive?

Please help so I can restore my files!

Doubt this will work

just look for an alternative to backup the virtual machine

Been quite a while, but since I finally got this working I wanted to update the post in case anyone else has the same problem (can’t see the My Book Live from a VirtualBox WinXP machine).

When I logged a ticket with WD, I got an automated reply with a few links to related issues. One mentioned enabling UPnP in Windows Firewall ( and I had a suspicion it was UPnp-related (UPnP traffic not getting through to the XP machine?) but when I tried it, I still couldn’t see the drive.

Eventually, I got a message from WD that said what I was trying to do might not work, but just in case to try looking at the Network Services:

"On the Computer you can verify the Network Services by clicking on “Start”, “Run” and typing “Services.msc” and pressing Enter. This will evoke the Services control panel. You will see all the services on your computer listed here.

Since we’re here, we’ll verify that all Network related services are up and running correctly. You will verify the following:

-SSDP Discovery

-Network DDE

-Network DDE DSDM

-UPnP Device Host

All of these Services, under Status, need to be either “Manual” or “Automatic” in order to be working correctly. If any of those Services show as being “Disabled” under the Startup Type, you will need to enable it.

To do this, you right click on top of the Service, and click on “Properties”. After that, on “Startup Type”, set it to Automatic, and then close it.

Notice that if Network DDE and Network DDE DSDM are both disabled, you should know that the DDE one is a prerequisite for the DDE DSDM one, and since it’s Windows XP, you need to enable the DDE, reboot the computer, and then enable DDE DSDM. Otherwise, it could create conflicts and not enable them correctly."

In my case, neither of the DDEs nor UPnP was on. I enabled both, still nothing. On a whim, I then went back and retried enabling UPnP in Firewall again, still nothing. Lastly, I changed the network adapter type in the virtual machine to “bridged” and voila! I can see the My Book. Note that I had tried all of these changes before, including the bridged adapter, without success. 

It must’ve been a combination of services settings, UPnP, and bridged adaptor. YMMV. Good luck!