HDMI output does not work


#1

I had my WDTV unplugged for a while and after plugging it back in, the HDMI output doesn’t work.  My TV does not recognize the device at all.  The TV recognizes all my other HDMI devices with no problem.  I plugged the WDTV in with the yellow component cable and it worked.  I then tried to change the video output to HDMI.  The screen would go black, and then it would come back on and the video would switch to Composite.

For a brief instant I was able to get the HDMI to work.  I had to unplugg the WDTV for about 15 minutes.  When I plugged it back in the HDMI worked.  But shortly thereafter, the screen went black and would not come back on.

I’m running the latest firmware from November.  This is a first gen WDTV.

If anyone has any good suggestions, I’d appreciate the help.  But I think this thing may need to go back to WD.


#2

Just an update on some things I’ve tried.

1.  Several different HDMI cables in different ports on my TV.  Cable box and Blue Ray work on any cable in any port

2.  Updated the firmware on my TV to the newest available.  The TV is a Samsung LN40A530

3.  Tried different electrical outlets to make sure the WD box was getting enough juice.

4.  Tried to use the reset button on the WD.  It made the picture go black and white and all grainy, but it didn’t appear to do anything.

Still, the HDMI is not working. The composite does, but not the HDMI.  Help!


#3

I have problem and just send my HD TV for an exchange just received the new one and will see if it still does it 


#4

I think is a bug, I have the same problem, I received an email from support saying that the only HDMI cable that works is version 1.2, sincerely I do not know what version of cable I have, so, the best solution that I manage is the next:

Plug the HDMI and the AV cables

Turn your TV with the AV input

Select the WD in settings to change to HDMI 720p at 50hz

Select HDMI input in your TV (here I have signal from HDMI)

Accept the new settings

After that, the HDMI settings would change to AUTO, leave it there, and with luck you might have now HDMI output from your WD.

I hope this trick would help you all.


#5

I agree it’s a sfotware bug as the box a received it’s on  1.0.2 software and he works fine ! and I remember my HDMI problem starting after the 1.0.3 update !

Also  1.0.3 software is very slow compare to 1.0.2, like when you watche a movie and you want to see the timeline you click OK on 1.0.2 it show straight away and another OK click take it away straight away but on 1.0.3 it’s very slow and buggy !

I hope that WD didn’t give up on the 1st Generation software and will fix that HDMI issue and Slowiness of 1.0.3 ! in the mean time I’m staying on 1.0.2 :wink:


#6

I have the same problem. doesn’t anyone have a permanent solution to this. I mean I’ve haven’t done anything wrong :mansad:


#7

Same issues here.  I had the HDMI working for about 2 days when I initially got it as a gift.  Then, after about a week of non-use, the HDMI out doesnt work.  I ran through the same problem sovling steps as Stormseeker with no luck.

I was hoping the firmware update would solve the issue but it hasnt.


#8

after horus of searching about this issue, it appears some folks think that one should cut about 3mm off the end of their HDMI cable that is being plugged into their WDTV backend.   Apparently they say the hole in the back has been made shorter than it shouldve been.

I dont see how the plug can be the problem as when I reset my WDTV, the boot up screen shows the WD logo through the HDMI plug!


#9

I’m not surprised if that’s the issue ! 


#10

Here is the thread i am following.  The site has some good info:  http://wdtvforum.com/main/index.php?topic=351.0


#11

Oh yes 

"Here is the solution for “WDTV won’t stay in HDMI mode”

The problem is related with HDMI connector on the stuff (WDTV). 

It is so deep and HDMI cable connectors not eneugh long plug correctly.

Just need to cut 1-2 mm plastic cover from the connector on cable.

When the metal place became longer 1-2mm. the problem end.

The connector reach end of the female HDMI **bleep** 

good chanche"

The problem is I don’t know with what to cut the HDMI as the plastic is very thick ! 


#12

I cut my HDMI cord down with a boxcutter and it didnt do anything as I guessed it wouldnt.

If I reset the device with only the HDMI cable plugged in (no yellow composite at all) I see the Blue WD logo upon startup.  So I know the connection is fine.  The box just doesnt want to output once I try to change it in the settings.


#13

Well I guess that answer the HDMI it’s definitely a software issue then !

COME ON WD AN ANSWER PLEASE !!! 


#14

I tried all the tricks with settings as well.  No luck.  

But the cutting of 2 mm or so off the HDMI cable shoulder worked!  It now fits further into the HDMI socket in the back of the WDTV.  HDMI output comes up fine now.

Just a note, this cable works perfectly on my DVD and PVR so i know it’s not a ■■■■ cable.

I was very dubious when i read that cutting works.  Sounded dodgy, but after ringing WDTV support and getting no help i figured it was worth a try.  Support suggested i try a different “version” of HDMI cable, or keep buying one until i find one that works.  Obviously they know they are out of spec for HDMI cables and it’s up to us to fix the problem by finding one that is longer than normal.

Here’s a photo of what i did.  The left hand plug is the uncut end that plugs into my TV and the right one plugs into the WDTV. It shows the cut plug and the left over bit.  I used a box cutter or what we call in oz a stanley or craft knife. It was thick plastic but pretty soft. Plug still feels solid in the sheath and doesn’t wobble so i reckon it’ll save me the hassle of going into town to buy a new one.

“This issue is caused by the fact that the WDTV does not meet the mechanical specification for HDMI.  The specification requires no greater than 2mm between the bezel and the connector, but the WDTV has 3mm.  I strongly suggest that WDTV fix this issue or they may face losing their HDMI certification.”

http://wdtvforum.com/main/index.php?topic=351.msg12436#msg12436


#15

i’ve had same problem and have cut 2mm off plastic part of my hdmi lead as suggested on here and hey presto it now works in hdmi mode,thanks .


#16

Omg, this is actually the solution to the problem!!! Just cut the cable 2mm, exactly as shown above.

God bless you man. :smiley:

I guess the case design isn’t fully hd ready… lol


#17

Hi, I also have problem regarding connecting WD media player to full HD TV using HDMI. My WD media player is the 1st generation. Current firmware version : 1.03.01 My full HD TV is Samsung LA32B530. HDMI cable spec. : support version 1.3b Problem details: I can connect WD media player to TV and everything works fine at first. But after one hour, there is intermittent signal from media player to TV. The screen became blank and 1 second after the signal came up and then the screen goes blank again. When I connect my Acer notebook using HDMI connection to my TV, everything works fine even or a long period usage. Action taken: 1. I have try to use high quality HDMI cable ( giraffe brand ) but the problem still same. 2. I have reset the WD media player by using reset menu in “setting” but the problem still same. Question : 1. Anyone have better DIY suggestion to overcome this problem? 2. Do you think this problem related to firmware? 3. I have all 3 firmware version: a) 1.01.02 b) 1.02.07 c) 1.03.01 Is that possible to downgrade the firmware? How? Anyone have experience, please help. WD team, do something about this problem.


#18

Thankyou,

Even though I have searched forums all day I am happy to find the ‘cut it off’ solution at the enbd of the day…Cant believe that i had sent my initial player back  then recieved a new on with same problem.

I spoke to suppport several times without a solutiuon.   WHY do they not know OR are not admitting to a failure in the unit connection,

Hope othesr find this solution also.

Today I have at last viewed the WD menu screen for the first time after a month in the dark.

Now I am not game enough to turn it off.

Regards Pia


#19

I bought a WD TV Live last week and it worked fine with Component (RGB) video, but I couldn’t get anything via HDMI (though the TV recognized something was plugged into HDMI 1).  I called WD support and they suggested upgrading the firmware (though there was nothing in the upgrade notes about HDMI).  They had no other suggestions.  I tried the FW upgrade to no avail (big surprise).  I tried different cables, different TVs - nothing.  So I returned it, got a new one - same problem.  I thought that too unlikely, so I began doing some research and ran across this thread.  It’s almost unbelievable, but I trimmed off one end of a cheaper (no gold on the contacts) HDMI.  It exposed a wee bit of the “inner workings” of the cable, but it actually works!

I am both amazed and dismayed that this problem has been going on for like a year (based on some of the posts I’ve seen) and WD hasn’t corrected it.  It makes me wonder about their commitment to building a quality product.  I’m seriously considering returning my WD TV Live and buying one of the new Seagate units.

In any event, thanks to all you folks who tried this before me.


#20

I have the same problem. Did you find any solution?