[GUIDE] Upgrade a working My Cloud to a bigger HDD (easy steps)

Hi all, I know this topic is a little bit old, but I recently also upgraded the My Cloud (gen 1) disk from 2TB (WD Red) to 4TB (HGST), but I’m running into the same issue as @superswade, that is that all disks have an unknown filesystem and the My Cloud doesn’t start (no IP address visible in router, led almost constantly white → only (frequently) goes off very short).
I didn’t extend the largest volume yet, only did a clone in CloneZilla with both disks connected via an USB adapter with the exact steps from @Proglin’s opening post.

I really prefer to keep my setup they way it is, instead of ‘unbricking’ via @Fox_exe’s steps, since I also did a lot of custom security scripts and setups via SSH a while ago. I’m not a Linux expert, so I’d like to copy the things I did back then instead of trying to reproduce what I did back then.

  1. Why does this happen with some persons following the steps from this topic exactly, while others don’t seem to have this problem?
  2. Is it wise to try another tool similar to CloneZilla to see if that copies the file systems in a correct way?
  3. What if I try to set the right file systems via Gparted after cloning (which will cause formatting I guess) and copy the files on the partitions somehow via a live Ubuntu environment or so? Anybody had success with this? Is it possible, or is it a noob’s idea?
  4. Or are there other ways to copy settings (cron, users, installed apps/tools) after a fresh installation/unbrick?

Thanks in advance for your help!

As a troubleshooting step try doing a 40 second reset if you haven’t tried it already after performing the cloning.

Pin Reset and System Only Restore WD My Cloud OS 3

I had trouble trying to clone using CloneZilla. Found I had to use different USB to SATA adapter(s). One may have to try doing a sector by sector clone. One may have to try using a different computer. If one has access to a two hard drive docking station that will clone drives, one can try using it to clone one drive to another. CloneZilla has a basic guide for doing a disk to disk clone.

CloneZilla Disk to disk clone

Hi Robert,
I first tried mirroring the entire drive using Clonezilla too but found that the Linux RAID partitions couldn’t be cloned. I ended up applying the software to the new drive as instructed via this info:
That worked for me.

As posted previously up thread there is a archive repository of user Fox_exe’s single bay My Cloud unbrick files here: https://wd.hides.su/fox_exe/

First gen directions: https://wd.hides.su/fox_exe/WDMyCloud-Gen1/Replace%20HDD%20-%20English.txt
Original_v03.04.01-230.tar.gz: https://wd.hides.su/fox_exe/WDMyCloud-Gen1/Backups/original_v03.04.01-230.tar.gz
Original_v04.01.02-417.tar.gz: https://wd.hides.su/fox_exe/WDMyCloud-Gen1/Backups/original_v04.01.02-417.tar.gz

Second gen directions: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/_Unbricking_en.txt
usbrecovery.tar.gz: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/usbrecovery.tar.gz
Alternate way second gen files:
uImage-wdrecovery: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/Developing/uImage-wdrecovery
uRamdisk-wdrecovery: https://wd.hides.su/fox_exe/WDMyCloud-Gen2/Developing/uRamdisk-wdrecovery

The last firmware for the discontinued OS3 single bay My Cloud units can be downloaded directly from the WD Support link top of page, or from the the following links.

First gen 04.06.00-111 (4/15/2022) firmware:
Release Notes

Second gen 2.42.115 (1/18/2022) firmware:
Release Notes

Hi @Bennor and @superswade, thanks for your replies.

I didn’t try the 40 second reset, because I really like to keep the custom settings I did outside the UI. I can of course try the reset to see if the disk basically can function in the device, but I hope there’s a solution where I can re-use my current settings (maybe clone all files on the partition from the shell after the reset?)
This is also the reason why the instructions from @superswade are my preferred steps to take at first (but of course I will if there is no solution to keep my current settings along to the new disk).

I didn’t try a sector by sector clone yet. So that’s different from the one in the guide in the opening post? If that will keep the partitions, that would be great. Did it work for you, @Bennor?

1 Like

Haven’t used Clonezilla in a few years so don’t remember if sector by sector clone was part of the default option or if one has to select the expert mode. From what I remember I used the default mode but that was a number of years ago so the program may have changed since I last used it.

Hi @robertl87. Years ago when I wrote this guide I used direct sata connections:

Connect your original hdd and your new bigger hdd to your PC (sata connections)

My guess is there is an issue using USB to SATA. But I’m justing guessing :person_shrugging:

1 Like

I have tried a few things over the past few days, and am back here to report back on them. The good news is that it finally worked out. The bad news is that I don’t know exactly what finally did the trick.
I did the copying again via CloneZilla, via expert mode with the option -q1 (sector by sector) - again using two USB to SATA adapters. Then immediately I looked at the disk in Gparted and unfortunately the partitions looked the same again as after the previous attempts. I then (stupid of course) did not bother to stick the disk in the NAS to see if it worked, but I went right on, to try other tools.
If I am not mistaken I then started a sector by sector clone in the Windows tool HDClone.X.4.FE. However, this took so long (expectation of >12 hours) that I stopped it at 1%, because I didn’t think the chances of it succeeding were high (because why would a Windows tool transfer Linux partitions correctly?).
Then I made bootable USB sticks from Ultimate Boot CD and SystemRescue and started SystemRescue to try one of the tools. Just to be sure, I booted Gparted from there to see which drive I needed to have (sda, sdb, etc.). To my great surprise, I saw the correct partition labels there on the new, large disk.
I then immediately built the disk into my NAS, and booted it, and it worked!
I did worry that the one percent of HDClone had messed up the entire partition structure or data, but so far I haven’t found any corrupted files or partitions.
I then expanded the largest partition so I could make use of the full space of my disk, and now it’s been running for a day to update my backup again.
Now what finally did the trick, I don’t know, but either CloneZilla or HDClone (or the combination of both :wink: ) fixed it. Hopefully there are indeed no corrupt files popping up later.
Thanks all for thinking with me!


Has anyone tried upgrading the ext3 data partition on a WD NAS Gen1 devices to ext4? Any benefit from doing that? The Linux kernel on my old Gen1 NAS is 3.2.26.

Thanks for any info!

Have you run lsblk -f via SSH to see what format the My Cloud data partition (sda4) is formatted to?

What firmware version is your My Cloud running? (See the My Cloud Dashboard for firmware version.)

For example on an unbricked first gen single bay My Cloud (running v04.06.00-111 firmware), unbricked using Fox_Exe’s directions, the data partition (sda4) is formatted for EXT4.

If one’s first gen single bay My Cloud sda4 data partition isn’t formatted for EXT4 one could likely attempt to reformat it. One will likely loose all user data on the partition if they do so. So backup the user data prior to attempting to reformat. One may have to extract the My Cloud hard drive and connect it to a Linux PC to properly format the sda4 partition for EXT4. Trying to change the other partitions (sda1, sda2, sda3, sda5, sda6, sda7, sda8) format structure will likely brick the My Cloud since those other partitions are what the operating system uses to run the My Cloud. One may have to perform a System Only Restore (My Cloud Dashboard > Settings > Utilities) after changing the data partition’s format to EXT4.

One proceeds at their own risk if they attempt to reformat a single bay My Cloud hard drive partition or the entire drive itself!!!

1 Like

Good call Bennor! Lol, my data partition is already ext4! For some reason I thought it was ext3; maybe I was thinking of the other partitions. The RAID partitions are ext3, just as yours are. She’s an old girl! Way out of support time. Yes, running the v04.06.00-111 firmware - I’m sure that will be the last ever made for these things.

I’ve been messing around with TrueNAS a bit lately on a spare PC. Good stuff! Also Open Media Vault and Universal Media Server. I’m thinking about building something new but I want to have a NAS (probably only RAID1) that I can also run as a webserver. I’ll be running some derivative of Ubuntu as the OS.

Have you ever used the btrfs file system by chance? I’ve been looking into it as a replacement for ext4 on the new system. I’ve read good things about it but it’s supposed to be a bit slower than ext4.


I think a Synology NAS I’m running uses BTRFS or some hybrid form of it. Each partition format has its benefits and tradeoffs.

Hi Bennor,
thanks a lot for your very usefully tips.
I have a WDMyCloud 1stGen, but the HDD was broken a years ago. Now I’m trying to replace this HDD with a new one following your and community guide.
So, the NAS is re-born, but I have a critical error issue now, Data Volume not Mounted. However the system give me webUI interface and SSH server too, so I found this log during the boot:

[ 44.769170] EXT4-fs (sda4): couldn’t mount RDWR because of unsupported optional features (400)
[ 45.266497] EXT4-fs (sda4): couldn’t mount RDWR because of unsupported optional features (400)

I’ve tried to mount the data partition manually, but the error is the same. Here there are my lsblk command result

WDMyCloud:/# lsblk -f    
|-sda1  linux_raid_member       
| `-md0 ext3                    /
|-sda2  linux_raid_member       
| `-md0 ext3                    /
|-sda3  swap                    [SWAP]
|-sda4  ext4                    

and here the mount command result:

WDMyCloud:/# mount /dev/sda4 /DataVolume
mount: wrong fs type, bad option, bad superblock on /dev/sda4,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

The strange things, is that I have re-build the partitions images by the firmware v03.04.01-230
but now the webUI show me the firmware version v. 03.04.01-219. Could a 40 seconds reset to have reloaded a previous firmware on the device?
Very grateful for your opinions!


Post update>> I found a solution for the critical error; I formatted the data partition with a too newer version of mkfs, since I use an Ubuntu 22.04 distro in the PC from by I re-build the HDD. So, some features of new ext4 version were not recognized by the kernel of my NAS. Solved re-formatting the data partition by SSH connection:

WDMyCloud:~# mkfs -t ext4 /dev/sda4
mke2fs 1.42.5 (29-Jul-2012)
Discarding device blocks: done
Filesystem label=
OS type: Linux
Block size=4096 (log=2)
Fragment size=4096 (log=2)
Stride=0 blocks, Stripe width=0 blocks
7520256 inodes, 30079744 blocks
1503987 blocks (5.00%) reserved for the super user
First data block=0
Maximum filesystem blocks=0
918 block groups
32768 blocks per group, 32768 fragments per group
8192 inodes per group
Superblock backups stored on blocks:
32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208,
4096000, 7962624, 11239424, 20480000, 23887872

Allocating group tables: done
Writing inode tables: done
Creating journal (32768 blocks): done
Writing superblocks and filesystem accounting information: done

Now the only issue is that I can’t update firmware manually, from the webGUI, due to an out of space error. Free space shown in the dashboard is 1.5GB, but it should be 120GB.


What hard drive are you using? And what is it’s total capacity? Are you trying to use an SSD drive?

If you can access the Dashboard have you tried a System Only Factory Restore? That typically will fix certain issues post unbrick.

1 Like

Yes, I’m using temporarily a Samsung SSD 128GB to test cloning procedures. I bought a WD RED 8TB HDD, and I will install it soon.
Total capacity in dashboard is 1.5 GB of free space + 550 MB Other stuffs

Here are mounted devices in this NAS:

WDMyCloud:/# mount
/dev/root on / type ext3 (rw,relatime,errors=continue,barrier=1,data=ordered)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=23056k,mode=755)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=40960k)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev type tmpfs (rw,relatime,size=10240k,mode=755)
tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /tmp type tmpfs (rw,relatime,size=102400k)
cgroup on /sys/fs/cgroup type cgroup (rw,relatime,memory,cpu)
/dev/root on /var/log.hdd type ext3 (rw,relatime,errors=continue,barrier=1,data=ordered)
ramlog-tmpfs on /var/log type tmpfs (rw,relatime,size=20480k)
/dev/sda4 on /DataVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/sda4 on /CacheVolume type ext4 (rw,noatime,nodiratime,user_xattr,barrier=0,data=writeback)
/dev/root on /nfs/SmartWare type ext3 (rw,relatime,errors=continue,barrier=1,data=ordered)
/dev/root on /nfs/TimeMachineBackup type ext3 (rw,relatime,errors=continue,barrier=1,data=ordered)
/dev/root on /nfs/Public type ext3 (rw,relatime,errors=continue,barrier=1,data=ordered)
nfsd on /proc/fs/nfsd type nfsd (rw,relatime)

Figured as much when I saw the 120GB capacity. You may have problems trying to get an SSD drive to work with the first gen single bay My Cloud. As indicated in a post I did on using 2.5 inch hard drives with a first gen single bay My Cloud I couldn’t get SSD drives, two different manufacturers and capacities, to work with the single bay first gen My Cloud.

[Guide] How to use a 2.5 inch hard drive in a single bay My Cloud

Note on SSD Drives: I tried using two different spare SSD drives (a 64GB and 120GB drive) and was not able to get either one to properly boot. Both got stuck with a Red front LED and no Dashboard access. Multiple attempts at cloning and manually running the unbrick process failed. Not sure if its an issue with the drive small size or with an incompatibility between the firmware/hardware of the My Cloud and using an SSD drive as the main drive. YMMV Others may have better luck with their SSD drives (or not).

1 Like

So, I’ve mounted a new HDD WD RED 8GB on that WDMyCloud Gen1, and now all stuffs are OK.

Then I have also upload a new firmware, v04.06.00-111 and now this is the result of lsblk command:

WDMyCloud:~# lsblk -f
|-sda1  linux_raid_member       
| `-md1 ext3                    /
|-sda2  linux_raid_member       
| `-md0 ext3                    
|-sda3  swap                    [SWAP]
|-sda4  ext4                    /DataVolume

RAID partitions are different from that ones I prepared and cloned with previous firmware v03.04.01-230

Do you think this system is now reliable for a SOHO use? Obviously with cloud features disable for security reason.

Thanks a lot!

If you want reliability with single bay first My Cloud then consider having a backup plan in place to backup the My Cloud contents just in case. The single bay My cloud includes a backup feature called Safepoint. Or use other methods to backup the My Cloud to another location; USB drive attached to My Cloud or to another location on the local network.

Otherwise so long as the Dashboard doesn’t indicate any errors or alerts then the My Cloud should function fine for what it is. A no longer supported older very simple, very basic NAS with very limited features and options.

Hello @Proglin,

is this method still working with the latest firmware version 5.26.119? can I upgrade my WD My cloud gen 1 from 2 TB to 12 TB with this method? and then will I be able to update the firmware at anytime a new version is release without any problem? was it reliable for you so far?

Thank you.

Does anyone else have any comments?