[GUIDE] Installing CrashPlan for MBL - Cloud backup

The below allows you to install CrashPlan to your MBL and backup to the cloud. This is tested on the latest firmware update. I have rebuilt and installed this a couple of times now. I am a beginner at Linux and thanks go to NFodiz for demonstrating what is possible!

Updated 21-May-2013 to correct “shares” name where libjtux.so may be stored and posted a link to the working libjtux.so file.


_ Install Java/JRE _

  1. SSH in to your MBL
  2. Update the libraries from the command line with “apt-get update” ** If you have additional advice to minimise this action please share it
  3. Install the JRE from the command line with “apt-get install default-jre”
  4. Install the JNA library from the command line with “apt-get install libjna-java”

_ Install CrashPlan _

CrashPlan instructions http://support.crashplan.com/doku.php/getting_started/installing_crashplan

  1. Download the CrashPlan for linux from their website http://www.crashplan.com/

  2. Extract the files on your MBL and start the install. I used all the default directories

_ Install updated libjtux.so file _

This is the important step. I have posted a version of the libjtux.so file that is working for me.

  1. Download the libjtux file that works with the MBL’s ARM processor and extract it from the zip - I place it in the root Public folder

  2. Rename the existing libjtux file
    From the command line “mv /usr/local/crashplan/libjtux.so /usr/local/crashplan/libjtux.so.backup”

  3. Copy the replacement libjtux.so from your download location. I extracted and stored it in the Public share so simply replace the location below as necessary [/shares/Public/libjtux.so]
    From the command line “cp /shares/Public/libjtux.so /usr/local/crashplan/libjtux.so”

_ Start CrashPlan _

From the command line “/usr/local/crashplan/bin/CrashPlanEngine start”

_ Configure CrashPlan _

You can connect from your Windows or other client as a Headless Client as per CrashPlan’s instructions here
You may need to wait a few mins for CrashPlan to start up and the client to connect. You can monitor the process on MBL with top. From the command line “top” and monitor the java process

Backing up to CrashPlan central (the cloud) takes a loooooooooong time. I backed up sets of folders at a time and was able to achieve around 185kps backup speed so yes, you might be initialising your backup for a couple of weeks or several months… For the initial backup I increased the CPU usage to 95% and afterwards reduced it down. Simply follow CrashPlan’s guidance.

If you upgrade your firmware simply follow the instructions to reinstall and then use the “adopt” option from Crashplan to connect to your previous backups.

I’m looking forward to any feedback/comments including the backup speeds you achieved. Good Luck!!


Nice guide Ned :slight_smile: I don’t have a Crashplan account but I will give the one month free trial a go and follow this wonderful guide and report back when I get some free time.

You said you were getting 185kps… Out of curiosity what is your internet upload speed? Or is the CPU in the MBL holding the speeds back?

Thanks again for the nice guide and keep em coming :slight_smile:

I am still using the 30 day trial with just a few days to go. I will then upgrade and pay month by month until I am truly satisfied but so far so good. Recently upgraded to have 3mb upload speeds and have tested that however I understand the performance is coming from factors including the CPU/compression/performance of the MBL, the file being backed up, how you are allocated/assigned in the CrashPlan cloud (which system they attach you to), and the routes for your provider to CrashPlan. I’m in Vancouver Canada and using Telus as my provider. I have seen peaks of 200kps+ but average around the 180kps. As you quickly identified, I am suspicious of the MBL CPU and I have not run CrashPlan on another PC or other to compare…

Looking forward to the feedback :smiley:

A short update here. I am seeing speeds of 800k upload currently. I set the CPU max to 100% in the CrashPlan client and I stopped apache on the MBL. I will adjust these again in another day to see if I can confirm if itsmy configuration or if its at the CrashPlan cloud end…

Hi there,

Having followed your guide to the word I am currently faced with an error regarding the libjtux.so file:

java.lang.UnsatisfiedLinkError: /usr/local/crashplan/libjtux.so: /usr/local/crashplan/libjtux.so: ELF file data encoding not big-endian (Possible cause: endianness mismatch)
        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1750)
        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1675)
        at java.lang.Runtime.loadLibrary0(Runtime.java:840)
        at java.lang.System.loadLibrary(System.java:1047)
        at jtux.UUtil.init(UUtil.java:14)
        at jtux.UProcess.<clinit>(UProcess.java:30)
        at com.code42.os.posix.PosixProcessCommands.getuid(PosixProcessCommands.java:56)
        at com.backup42.service.CPService.logIds(CPService.java:1349)
        at com.backup42.service.CPService.start(CPService.java:418)
        at com.backup42.service.CPService.main(CPService.java:1749)

I have tried several versions of the libjtux.so file from various forums etc with no luck. If you have any pointers on how to fix it would be most appreciated. It’s a little odd that you have managed to get it to work with these steps - can you please confirm what version of the firmware you’re running and also what outputs you get from the commands, below?

 Output of /proc/cpuinfo:

MyBookLive:/usr/local/crashplan/log# cat /proc/cpuinfo
processor : 0
cpu : APM82181
clock : 800.000008MHz
revision : 28.131 (pvr 12c4 1c83)
bogomips : 1600.00
timebase : 800000008
platform : PowerPC 44x Platform
model : amcc,apollo3g
Memory : 256 MB

 Output of uname -a:

Linux MyBookLive #1 Thu May 17 13:32:51 PDT 2012 ppc GNU/Linux

 Output of java -version:

MyBookLive:/usr/local/crashplan/log# java -version
java version "1.6.0_27"
OpenJDK Runtime Environment (IcedTea6 1.12.5) (6b27-1.12.5-1)
OpenJDK Zero VM (build 20.0-b12, interpreted mode)


Hi robcyb,

The error you highlight is definitely what I encountered until I identified the correct libjtux.so file. I just rebuilt my MBL in the past days and the guide worked perfectly for me to reinstall crashplan and get it up and running again, except that I keep a local copy of the libjtux.so file. I tested with the original and got the expected error, I tried the libjtux.so from the previous links and got the error, and then I used my local copy and it works 100%. Now I am embarassed that I don’t know where I obtained the file from!!
I have posted the working libjtux.so file in a zip at the following location and updated my directions above. I expect you will copy this file in and it will work. I look forward to your confirmation.


Output is below:
cat /proc/cpuinfo
processor : 0
cpu : APM82181
clock : 800.000008MHz
revision : 28.129 (pvr 12c4 1c81)
bogomips : 1600.00
timebase : 800000008
platform : PowerPC 44x Platform
model : amcc,apollo3g
Memory : 256 MB

uname -a
Linux KFile #1 Thu May 17 13:32:51 PDT 2012 ppc GNU/Linux

java -version
java version “1.6.0_27”
OpenJDK Runtime Environment (IcedTea6 1.12.5) (6b27-1.12.5-1)
OpenJDK Zero VM (build 20.0-b12, interpreted mode)


From a performance perspective I have found the upload speed about 140kps on average when set to 90% CPU max. You can possibly get it a little higher with more CPU.

From what I have read in other posts on the CrashPlan website it appears that some routes in North America are poor and result in this low performance. I don’t know why at some time I saw 800Kps…I wish I could see it again :slight_smile:

My near 100GB of critical files are now in the Cloud and my backup continues on a regular basis. I think this is a great solution albeit slow.

Thanks for posting this.

I am however seeing the same issue as robcyb, using both of the libjtux.so files o_0


Searching around a bit I found this one which seemed to do the trick!

wget  http://www.opticality.com/blog/wp-content/uploads/files/libjtux.so

(from  http://www.jonrogers.co.uk/2012/05/crashplan-on-the-raspberry-pi/))

I have recently bought a MBL and I already use Crashplan for backing up my laptop to the cloud storage, but want to move everything from my laptop to MBL and then backup from the MBL to the cloud. Found these instructions for how this is possible, but to be completely honest, is still a little advanced for me and I don’t want to do a half arsed job, that results in me causing myself problems.

Would any one be willing to provide me with a very straightforward idiots guide as to how I do this? (you may be thinking the instructions on here are simple but there are a couple of points i’m not sure on!!)

Thanks in advance

@John: I managed to get it installed on an ARM based netgear. Look at a post I just shared  http://givebacktoit.blogspot.co.uk/2013/07/crashplan-on-netgear-nas-104-with-arm.html