[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud


#82

Hi guys,

I have unbricked my cloud with this guide and 250GB image succesfull.
I wanted to make a firmware update to the newest firmware but everytime after the cloud reboots I am no longer able to enter the dashboard. So I have to do the whole unbrick process again to get it back.
Am I right that it is not possible to update firmware after unbricking the device with virgin image? Or do you have any idea to get the orginal firmware(update) back again.

I am also facing another problem - after unbricking the device and doing setup in dashboard I left the device idling - after a while the LED went into red and the dashboard is showing SMART failure in notifications. But it looks like everything is working well.
Does anybody know how to fix this issue?

Many thanks in advance.


#83

@bOne After you finish the unbrick process and checked the blue light I recommend to do a 40sec reset to clean the dashboard problems and start from factory settings.

  • Unplug disk from power
  • Take a paper clip and push the reset hole
  • While pushing the reset hole plug the disk again and keep pushing for 40secs
  • Stop pushing and wait the unit to reboot. It will take its time.

@Ouglee I have a 2TB My Cloud bricked after attempting to install qbittorrent from an external sources list. That ended upgrading libraries and making a total mess. Now it has White led that retarts every 40secs or so.

Should I begin your tut? Or should I wait for the new version?

I see this tut is a success for most of people so big big thank you for your effort guys.


#84

Ran into the Dashboard not loading issue, repeatedly, after unbricking a 250GB drive I have in the My Cloud Enclosure. Tried all sorts of unbricking methods mentioned in these forums. The 2T and 250GB img files above never worked for me no matter how I tried to restore them to the drive. Fell back to using the a variation of this method of unbricking/installing a bare drive mentioned in other unbrick threads.

I found that if I used the “original_v3.04.01-230.tar.gz” file from this link, and running the following commands (with /dev/md0 unmounted) I was able to upgrade the firmware to the latest version and have the dashboard loading again. Don’t know why it worked but it did for me on a 250GB drive. I make no guarantees this will work for others who are not having the Dashboard load after upgrading, proceed at your own risk. The commands:

dd if=kernel.img of=/dev/sdb5
dd if=kernel.img of=/dev/sdb6
dd if=config.img of=/dev/sdb7
dd if=config.img of=/dev/sdb8
dd if=rootfs.img of=/dev/sdb1
dd if=rootfs.img of=/dev/sdb2

On a side note I found that if I used the original_v4.01.02-417.tar.gz from this link it would throw an error when trying to kernel.img to /dev/sdb5 because the partition at 99.6MB on my 250GB drive was too small. Turns out in the original_v4.01.02-417.tar.gz file the kernel.img file is something like 100MB or 101MB rather than 97MB in the original_v3.04.01-230.tar.gz version.


#85

@Bennor
Thank you very much for your help. Please let me know how did you unmount /dev/md0 ?
A small step by step guide for installing the firmware incl. unmouting and so on would be very nice :slight_smile:


#86

There are several links both to the directions I’ve used (both recently and in the past) as well as links to the files I used in my post, but with this new forum layout those links don’t stand out from the regular text. The direction I used can be found at this link: https://drive.google.com/file/d/0B_6OlQ_H0PxVejVic2ZubXBfbHM/view

Personally I’ve modified those directions slightly in several spots to fit my own needs. In particular there is one point (after step 7) where I have to reboot the PC (and do apt-get update && apt-get install mdadm parted again) otherwise step 8 wouldn’t work.

The command to unmount /dev/md0 is: mdadm --stop /dev/md0


#87

Will give it a try tomorrow. Looks a little bit complicated. How did you do the update to latest firmware? Via Dashboard (auomatic/manual) or SSH with the files provided by wd on their homepage?


#88

This last time I updated the firmware (where it was ultimately successful) to the latest version was right after I did the Quick Restore after accessing the Dashboard post unbricking with v3.04.01-230. Past times the upgrade would indicate it was successful but then the Dashboard would fail to load while the Twonky admin page would load. Quick Restore can be accessed via the Dashboard -> Settings -> Utilities -> System Factory Restore section.


#89

Hi!

Just to report my experience in case some user finds it helpful.

After an unsuccessful installation of qbittorrent I bricked and recovered the unit thanks to this guide. The only thing I saw is that the LED was continuously red. Since I read another user had the same problem I checked SMART feature but it was ok. So I did a 40sec reset and a quick restore from settings and after reboot LED was in glorious blue.

Big big Kudos to all people contributing in the thread for this valuous information :slight_smile: :slight_smile:


#90

Wanted to add my experience as well in case it help someone. I bought a 3 TB My Cloud and bricked it while trying to set up CrashPlan on v4. Tried to unbrick it using this guide, with the exception that I used GParted Live. Tried two different 2 TB images several times, but it didn’t work; it got stuck on a solid white LED and never booted.

What finally worked for me was the 1 TB image using SystemRescue (on USB; version 4.2, which I think was released just before this guide was written, so as to rule out any changes that could cause it not to work). I skipped the resize at first and it reported only 1.5 TB. After the restore, it went down to 1 TB and I got a red light (SMART, probably because of the size difference). I popped it in my PC again, started SystemRescue and deleted partition 4 and made a new 3 TB partition using GParted. It reported a SMART error again at first, but I ran a quick restore and it seems to be working now.

Thanks a ton for this guide and the 1 TB image, guys! :smile:


#91

sry, wrong post


#92

Hi fellows!
Thank you so much for this guide!

I have corrupted linux on My Cloud 2TB via ssh with apt-get upgrade. After reboot LED was solid white, all services were down. So was after 40s system restore.

I followed this guide and got the situation: LED becomes blinking white for a second, then solid white for two minutes, then solid red. Activity LED is blinking, link LED is off. Router does not establish a connection.

It’s definitely not a high temperature issue. And I think that it is not a router’s one either.
First time I tried to unzip the mycloud2tb.7z on Windows. Then, on SystemRescue. Still does not work for me.
I also tried to follow this guide - https://eriffoorp.wordpress.com/2015/05/28/replace-a-hard-drive-on-wd-my-cloud-3/
Result remains the same.
SMART test is passed (disk is WD Red Series).

How can I check whether it is a software issue or my miniboard is broken?
Does anyone know how the initialization process works? Which tests should pass to get solid blue?
What else should I try?
I would be grateful for advice. Thanks in advance.


#93

The information for what is going on with the device is on the disk. The problem is getting to the information. If you can’t ssh into the device how are you supposed to get the information. There are a files on disk in the tmp directory that contain information about the leds. There are also files in /sys/devices/virtual/leds/system_led directory describe the current color and blink information.

But if you can’t get to them it doesn’t help. There is 16 different states the led can be set for. There are normal_mode,warn_mode and err_mode led settings. Each of these modes has 16 different states. Each state has a defined color red,blue,yellow,white and off. Any of these colors can be on,off,blink or pulse.
For information about these colors you can look at /usr/local/sbin/ledConfig.sh

RAC


#94

rac8006, thank you for your response.

I have already disassembled cloud so I can manually mount the drive to my linux and check these files. But, obviously, I cannot get access to this information while my cloud is on. I have also read the user manual where these possible reasons are stated. Now I am trying to realize what goes wrong with this device.

Update to my previous post. I followed this guide - https://drive.google.com/folderview?id=0B_6OlQ_H0PxVRXF4aFpYS2dzMEE&usp=sharing - same result.

Is there a chance that LED is solid red while device is booting or checking something? I think that it should be solid white in this state.


#95

Since you can mount the disk to a Linux system. look at the /var/logs/. Look at the /tmp/led files. and look at /sys/devices/virtual/leds/system_led.*. I’m interested in the /tmp/led files and the files in /var/log.

RAC


#96

RAC, here is my /var/log. It seems that system did not start at all. The /sys catalog is empty.
log.zip (18.9 KB)


#97

As best as I can tell from the logs is that the system appears to be installing firmware or upgrading firmware and stopped. There is nothing in the logs that indicate the system completed the installation.

RAC


#98

RAC, thank you for your time! I’ll keep trying.


#99

This question is from last March, but I didn’t see a direct answer. Yes, this will work with a 6TB drive, I’ve just completed the process on two of them.

Initially, I was having some problems with resizing the partition to use the full capacity. Every time I did it, the My Cloud would no longer boot. If I didn’t resize, it booted fine, but as a 2TB or 3TB.

I’m no Linux expert, in fact I’m a bit of a novice with just a little bit of experience, but I was looking at the partitions in Ubuntu and realized that the partition had been resized but not formatted. So I formatted it using GParted in Ubuntu and boom, worked perfectly giving me the full size.

The sectors that I used were:

Start: 9428992s
End: 11721043967s

When the My Cloud booted up, it reported 5.8TB free. After a firmware update, 5.9TB.

Now, we just need the End number for the 8TB’s, because we’ll eventually need it lol.


#100

Hi,
was starting to Unbrick my 2 TB My Cloud. But I really need this Virgin Disk Image. Otherwise I cannot use this My Cloud 2 TB anymore. He was working very good until I was Brick him.
Please help me. I’m 76 and not so rich to buy a new one.

Erwin Philippines


#101

Hi,
finally I get this Virgin Disk Image. Hopefully it will help. Will update You then.
Regards Erwin.